aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-05-08 04:04:17 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-05-08 04:04:17 +0000
commit3dcb251e1af7d9d3cae04191d8a8f9ce2464e842 (patch)
treeed9fa50a0cfdd16af3a95e4a6f1564a6caa96897 /audio
parent2b3295fca6fe0fb4f741c4c4eec929af410ec283 (diff)
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/speex-devel/Makefile19
-rw-r--r--audio/speex-devel/distinfo4
-rw-r--r--audio/speex-devel/pkg-plist2
3 files changed, 18 insertions, 7 deletions
diff --git a/audio/speex-devel/Makefile b/audio/speex-devel/Makefile
index e50b6b5e170e..45fab4958d2a 100644
--- a/audio/speex-devel/Makefile
+++ b/audio/speex-devel/Makefile
@@ -7,10 +7,10 @@
#
PORTNAME= speex
-PORTVERSION= 1.1.7
+PORTVERSION= 1.1.8
PORTEPOCH= 1
CATEGORIES= audio
-MASTER_SITES= http://www.speex.org/download/
+MASTER_SITES= http://downloads.xiph.org/releases/speex/
PKGNAMESUFFIX= -devel
MAINTAINER= ahze@FreeBSD.org
@@ -23,9 +23,9 @@ CONFLICTS= speex-1.0*
USE_GNOME= gnomehack
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
-LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_INC_LIBTOOL_VER= 15
+USE_GCC= 3.4+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
@@ -34,6 +34,15 @@ MAN1= speexdec.1 speexenc.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|doc win32|win32|g ; \
diff --git a/audio/speex-devel/distinfo b/audio/speex-devel/distinfo
index 526fd969f0a5..c0028aee45d8 100644
--- a/audio/speex-devel/distinfo
+++ b/audio/speex-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (speex-1.1.7.tar.gz) = a900d009f937efbb896f1f816193742f
-SIZE (speex-1.1.7.tar.gz) = 594364
+MD5 (speex-1.1.8.tar.gz) = 734892c8ca5e7e835828048a1289a0cc
+SIZE (speex-1.1.8.tar.gz) = 603433
diff --git a/audio/speex-devel/pkg-plist b/audio/speex-devel/pkg-plist
index 948c36baa29c..243b3dcdfc7c 100644
--- a/audio/speex-devel/pkg-plist
+++ b/audio/speex-devel/pkg-plist
@@ -3,11 +3,13 @@ bin/speexenc
include/speex/speex.h
include/speex/speex_bits.h
include/speex/speex_callbacks.h
+include/speex/speex_config_types.h
include/speex/speex_echo.h
include/speex/speex_header.h
include/speex/speex_jitter.h
include/speex/speex_preprocess.h
include/speex/speex_stereo.h
+include/speex/speex_types.h
lib/libspeex.a
lib/libspeex.so
lib/libspeex.so.3