aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-19 22:02:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-19 22:02:41 +0000
commit445df800b70809ca7c5a3086ea2584e28a2b2a7f (patch)
tree4d76c9f3ba2ef2cd07424449cefe709d0671a92e /audio
parent69765a8b879f8a99c50f0a2a413f5ff32c777bd3 (diff)
downloadports-445df800b70809ca7c5a3086ea2584e28a2b2a7f.tar.gz
ports-445df800b70809ca7c5a3086ea2584e28a2b2a7f.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp3burn/Makefile33
-rw-r--r--audio/mp3burn/distinfo1
-rw-r--r--audio/mp3burn/pkg-descr4
-rw-r--r--audio/mp3burn/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 0f4c53bb6894..033886ff4f17 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -182,6 +182,7 @@
SUBDIR += mp3_check
SUBDIR += mp3asm
SUBDIR += mp3blaster
+ SUBDIR += mp3burn
SUBDIR += mp3butler
SUBDIR += mp3c
SUBDIR += mp3check
diff --git a/audio/mp3burn/Makefile b/audio/mp3burn/Makefile
new file mode 100644
index 000000000000..d98b048fbbce
--- /dev/null
+++ b/audio/mp3burn/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mp3burn
+# Date created: 17th December 2003
+# Whom: Vincent Tantardini <vinc@FreeBSD-fr.org>
+#
+# $FreeBSD$
+
+PORTNAME= mp3burn
+PORTVERSION= 0.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Command line tool for making audio CDs from mp3s
+
+RUN_DEPENDS= cdrecord:${PORTSDIR}/sysutils/cdrtools \
+ mpg123:${PORTSDIR}/audio/mpg123 \
+ ${SITE_PERL}/MPEG/MP3Info.pm:${PORTSDIR}/audio/p5-MP3-Info
+
+USE_PERL5= yes
+NO_BUILD= yes
+USE_REINPLACE= yes
+MAN1= mp3burn.1
+MANCOMPRESSED= no
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/mp3burn
+
+do-install:
+ @${CP} ${WRKSRC}/mp3burn ${PREFIX}/bin
+ @${CP} ${WRKSRC}/mp3burn.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/audio/mp3burn/distinfo b/audio/mp3burn/distinfo
new file mode 100644
index 000000000000..cc758450a899
--- /dev/null
+++ b/audio/mp3burn/distinfo
@@ -0,0 +1 @@
+MD5 (mp3burn-0.1.tar.gz) = 3e9a0d5d676da43445c03949098c3b77
diff --git a/audio/mp3burn/pkg-descr b/audio/mp3burn/pkg-descr
new file mode 100644
index 000000000000..18f6b5256043
--- /dev/null
+++ b/audio/mp3burn/pkg-descr
@@ -0,0 +1,4 @@
+mp3burn is a simple command line tool for making audio CDs from mp3s
+without filling up your disk with .wav files.
+
+WWW: http://mp3burn.sourceforge.net/
diff --git a/audio/mp3burn/pkg-plist b/audio/mp3burn/pkg-plist
new file mode 100644
index 000000000000..f96e0aaa0b0d
--- /dev/null
+++ b/audio/mp3burn/pkg-plist
@@ -0,0 +1 @@
+bin/mp3burn