aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-07 00:18:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-07 00:18:15 +0000
commit44e28677c85a0fe6aa39329449a58895cae1ab17 (patch)
treeeb3c78f21d3df76045daedad30f2f08dca6ea85d /audio
parent9fa8c536a0210f54a8c20ac074ce9c84f962c96c (diff)
downloadports-44e28677c85a0fe6aa39329449a58895cae1ab17.tar.gz
ports-44e28677c85a0fe6aa39329449a58895cae1ab17.zip
New port: audio/bamp-lv2: Basic testing plugin for using BWidgets for LV2
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/bamp-lv2/Makefile35
-rw-r--r--audio/bamp-lv2/distinfo3
-rw-r--r--audio/bamp-lv2/pkg-descr3
4 files changed, 42 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f8a982991f41..0095d4d5fc90 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -48,6 +48,7 @@
SUBDIR += avldrums-lv2
SUBDIR += aylet
SUBDIR += bambootracker
+ SUBDIR += bamp-lv2
SUBDIR += baresip
SUBDIR += baudline
SUBDIR += bcg729
diff --git a/audio/bamp-lv2/Makefile b/audio/bamp-lv2/Makefile
new file mode 100644
index 000000000000..7979976c928f
--- /dev/null
+++ b/audio/bamp-lv2/Makefile
@@ -0,0 +1,35 @@
+
+PORTNAME= bamp
+DISTVERSION= g20210212
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Basic testing plugin for using BWidgets for LV2
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+
+USES= compiler:c++11-lang gmake gnome pkgconfig xorg
+USE_GNOME= cairo
+USE_XORG= x11
+
+USE_GITHUB= yes
+GH_ACCOUNT= sjaehn
+GH_PROJECT= BAmp
+GH_TAGNAME= fe91b838f2ec801df55b12ffbdf6c6a4ab4ef093
+
+MAKEFILE= makefile
+
+PLIST_FILES= lib/lv2/BAmp.lv2/BAmp.so \
+ lib/lv2/BAmp.lv2/BAmp.ttl \
+ lib/lv2/BAmp.lv2/BAmp_GUI.so \
+ lib/lv2/BAmp.lv2/manifest.ttl
+
+post-install:
+ @${RM} ${STAGEDIR}${PREFIX}/lib/lv2/BAmp.lv2/LICENSE
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/BAmp.lv2//BAmp*.so
+
+.include <bsd.port.mk>
diff --git a/audio/bamp-lv2/distinfo b/audio/bamp-lv2/distinfo
new file mode 100644
index 000000000000..4cff051ddbb6
--- /dev/null
+++ b/audio/bamp-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1617754187
+SHA256 (sjaehn-BAmp-g20210212-fe91b838f2ec801df55b12ffbdf6c6a4ab4ef093_GH0.tar.gz) = 2aa48de9da51f87c5c5c4de9caee7b3084c9ed3b968c1a648e5b2739c5183411
+SIZE (sjaehn-BAmp-g20210212-fe91b838f2ec801df55b12ffbdf6c6a4ab4ef093_GH0.tar.gz) = 194605
diff --git a/audio/bamp-lv2/pkg-descr b/audio/bamp-lv2/pkg-descr
new file mode 100644
index 000000000000..6f182a114dc4
--- /dev/null
+++ b/audio/bamp-lv2/pkg-descr
@@ -0,0 +1,3 @@
+B.Amplifier (BAmp) is a basic testing plugin for using BWidgets for LV2.
+
+WWW: https://github.com/sjaehn/BAmp