aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-05-31 18:45:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-05-31 18:45:18 +0000
commit51d27b272d54bffe3daf326bc971a1ca56bbbf6c (patch)
treec156400a29080ae3935b1d406bc24645364183d4 /audio
parent0ab55f50ce83edf408d20017cb480ba8c6a01c66 (diff)
downloadports-51d27b272d54bffe3daf326bc971a1ca56bbbf6c.tar.gz
ports-51d27b272d54bffe3daf326bc971a1ca56bbbf6c.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/audacity/Makefile13
-rw-r--r--audio/audacity/distinfo5
-rw-r--r--audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqsrc_sound.h11
-rw-r--r--audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp11
-rw-r--r--audio/audacity/files/patch-src_effects_vamp_LoadVamp.cpp11
-rw-r--r--audio/audacity/files/patch-src_import_ImportFLAC.cpp20
-rw-r--r--audio/audacity/pkg-plist3
7 files changed, 10 insertions, 64 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 18a3d071c323..1fc7bc27c2aa 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 2.1.2
-PORTREVISION= 5
+PORTVERSION= 2.1.3
CATEGORIES= audio
MASTER_SITES= https://github.com/audacity/audacity/archive/
DISTNAME= Audacity-${PORTVERSION}
@@ -25,11 +24,12 @@ BROKEN_powerpc64= Does not build
WRKSRC= ${WRKDIR}/${PORTNAME}-Audacity-${PORTVERSION}
GNU_CONFIGURE= yes
-USES= autoreconf compiler:c++11-lib cpe desktop-file-utils gettext-tools gmake iconv libtool pkgconfig shared-mime-info shebangfix dos2unix
+USES= autoreconf compiler:gcc-c++11-lib cpe desktop-file-utils gettext-tools gmake iconv libtool pkgconfig shared-mime-info shebangfix dos2unix
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
NLS_CONFIGURE_WITH= libintl-prefix="${LOCALBASE}"
OPTIONS_SUB= yes
+USE_GCC= 4.9+
USE_WX= 3.0+
WX_COMPS= wx
INSTALLS_ICONS= yes
@@ -59,7 +59,8 @@ TWOLAME_DESC= Use libtwolame for MP2 export support
VAMP_DESC= Vamp plug-in support
VST_DESC= VST plug-in support
-CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}"
+CONFIGURE_ENV+= WX_CONFIG="${WX_CONFIG}" \
+ ax_cv_gcc_4_9_0=yes
CONFIGURE_ARGS+= --enable-unicode \
${ICONV_CONFIGURE_ARG} \
@@ -137,10 +138,6 @@ VST_CONFIGURE_ENABLE= vst
.include <bsd.port.pre.mk>
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-CXXFLAGS+= -std=c++11
-.endif
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/audio/audacity/distinfo b/audio/audacity/distinfo
index c00dbab33d63..b073342ca8a0 100644
--- a/audio/audacity/distinfo
+++ b/audio/audacity/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Audacity-2.1.2.tar.gz) = 90007b50cdc3885607b1afef2f158777a61c1658e869a88ec4d98c59c133f9bd
-SIZE (Audacity-2.1.2.tar.gz) = 24718129
+TIMESTAMP = 1490408781
+SHA256 (Audacity-2.1.3.tar.gz) = cb30870b93c7f6f90b2ec70807ab6dcd9c3a3a29015478ae7b19af46d63bbd86
+SIZE (Audacity-2.1.3.tar.gz) = 24106855
diff --git a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqsrc_sound.h b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqsrc_sound.h
deleted file mode 100644
index ee47829b6d86..000000000000
--- a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_nyqsrc_sound.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib-src/libnyquist/nyquist/nyqsrc/sound.h.orig 2016-07-26 13:34:06 UTC
-+++ lib-src/libnyquist/nyquist/nyqsrc/sound.h
-@@ -459,7 +459,7 @@ double step_to_hz(double);
-
- #ifdef WIN32
- double log2(double x);
--#endif WIN32
-+#endif /*WIN32*/
-
- /* macros for access to samples within a suspension */
- /* NOTE: assume suspension structure is named "susp" */
diff --git a/audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp b/audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp
deleted file mode 100644
index 033d6e597f37..000000000000
--- a/audio/audacity/files/patch-src_effects_VST_VSTEffect.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/effects/VST/VSTEffect.cpp.orig 2016-07-26 13:34:06 UTC
-+++ src/effects/VST/VSTEffect.cpp
-@@ -2129,7 +2129,7 @@ bool VSTEffect::Load()
- // symbols.
- //
- // Once we define a proper external API, the flags can be removed.
-- void *lib = dlopen((const char *)wxString(realPath).ToUTF8(), RTLD_NOW | RTLD_LOCAL | RTLD_DEEPBIND);
-+ void *lib = dlopen((const char *)wxString(realPath).ToUTF8(), RTLD_NOW | RTLD_LOCAL);
- if (!lib)
- {
- return false;
diff --git a/audio/audacity/files/patch-src_effects_vamp_LoadVamp.cpp b/audio/audacity/files/patch-src_effects_vamp_LoadVamp.cpp
deleted file mode 100644
index 8cfdf476f077..000000000000
--- a/audio/audacity/files/patch-src_effects_vamp_LoadVamp.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/effects/vamp/LoadVamp.cpp.orig 2016-07-26 13:34:06 UTC
-+++ src/effects/vamp/LoadVamp.cpp
-@@ -266,7 +266,7 @@ Plugin *VampEffectsModule::FindPlugin(co
- Plugin *vp = PluginLoader::getInstance()->loadPlugin(key, 48000); // rate doesn't matter here
- if (!vp)
- {
-- return false;
-+ return NULL;
- }
-
- // We limit the listed plugin outputs to those whose results can
diff --git a/audio/audacity/files/patch-src_import_ImportFLAC.cpp b/audio/audacity/files/patch-src_import_ImportFLAC.cpp
deleted file mode 100644
index 53454436f169..000000000000
--- a/audio/audacity/files/patch-src_import_ImportFLAC.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/import/ImportFLAC.cpp.orig 2016-07-26 13:34:06 UTC
-+++ src/import/ImportFLAC.cpp
-@@ -296,7 +296,7 @@ ImportFileHandle *FLACImportPlugin::Open
- int cnt;
- wxFile binaryFile;
- if (!binaryFile.Open(filename)) {
-- return false; // File not found
-+ return NULL; // File not found
- }
-
- #ifdef USE_LIBID3TAG
-@@ -313,7 +313,7 @@ ImportFileHandle *FLACImportPlugin::Open
-
- if (cnt == wxInvalidOffset || strncmp(buf, FLAC_HEADER, 4) != 0) {
- // File is not a FLAC file
-- return false;
-+ return NULL;
- }
-
- // Open the file for import
diff --git a/audio/audacity/pkg-plist b/audio/audacity/pkg-plist
index c812603cbdbd..ef44229a071f 100644
--- a/audio/audacity/pkg-plist
+++ b/audio/audacity/pkg-plist
@@ -62,7 +62,6 @@ share/applications/audacity.desktop
%%DATADIR%%/plug-ins/StudioFadeOut.ny
%%DATADIR%%/plug-ins/adjustable-fade.ny
%%DATADIR%%/plug-ins/beat.ny
-%%DATADIR%%/plug-ins/clicktrack.ny
%%DATADIR%%/plug-ins/clipfix.ny
%%DATADIR%%/plug-ins/crossfadeclips.ny
%%DATADIR%%/plug-ins/crossfadetracks.ny
@@ -73,8 +72,10 @@ share/applications/audacity.desktop
%%DATADIR%%/plug-ins/lowpass.ny
%%DATADIR%%/plug-ins/notch.ny
%%DATADIR%%/plug-ins/pluck.ny
+%%DATADIR%%/plug-ins/rhythmtrack.ny
%%DATADIR%%/plug-ins/rissetdrum.ny
%%DATADIR%%/plug-ins/sample-data-export.ny
+%%DATADIR%%/plug-ins/sample-data-import.ny
%%DATADIR%%/plug-ins/tremolo.ny
%%DATADIR%%/plug-ins/vocalrediso.ny
%%DATADIR%%/plug-ins/vocalremover.ny