aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2005-06-16 19:59:39 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2005-06-16 19:59:39 +0000
commit5e09d4a8e222468bf1507c4a3ce921161dfb0ff4 (patch)
tree54db4de8399d4e2d5c610130f68c74ee6b1598ee /audio
parentc290227a8572408856558122457fd04b00192d38 (diff)
downloadports-5e09d4a8e222468bf1507c4a3ce921161dfb0ff4.tar.gz
ports-5e09d4a8e222468bf1507c4a3ce921161dfb0ff4.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/xmms-xf86audio/Makefile29
-rw-r--r--audio/xmms-xf86audio/distinfo2
-rw-r--r--audio/xmms-xf86audio/files/patch-Makefile19
-rw-r--r--audio/xmms-xf86audio/pkg-descr4
-rw-r--r--audio/xmms-xf86audio/pkg-plist4
6 files changed, 59 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 633dd50ccd5f..f60ab220ac7b 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -543,6 +543,7 @@
SUBDIR += xmms-uade
SUBDIR += xmms-volnorm
SUBDIR += xmms-wma
+ SUBDIR += xmms-xf86audio
SUBDIR += xmp
SUBDIR += xmpeg3
SUBDIR += xmradio
diff --git a/audio/xmms-xf86audio/Makefile b/audio/xmms-xf86audio/Makefile
new file mode 100644
index 000000000000..60a310dfd348
--- /dev/null
+++ b/audio/xmms-xf86audio/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xmms-xf86audio
+# Date created: 2005-06-16
+# Whom: Christian Weisgerber <naddy@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-xf86audio
+PORTVERSION= 0.4.3
+CATEGORIES= audio
+MASTER_SITES= http://www.devin.com/xmms-xf86audio/download/
+
+MAINTAINER= naddy@FreeBSD.org
+COMMENT= XF86Audio multimedia-key support for XMMS
+
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
+
+USE_X_PREFIX= yes
+MAKE_ARGS= CC="${CC}" OPT="${CFLAGS}" DEBUG=""
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libxf86audio.so \
+ `xmms-config --general-plugin-dir`
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-xf86audio/distinfo b/audio/xmms-xf86audio/distinfo
new file mode 100644
index 000000000000..4af518081c17
--- /dev/null
+++ b/audio/xmms-xf86audio/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmms-xf86audio-0.4.3.tar.gz) = 25d09c39eb35705bd11ee7e58e3f2f5a
+SIZE (xmms-xf86audio-0.4.3.tar.gz) = 14703
diff --git a/audio/xmms-xf86audio/files/patch-Makefile b/audio/xmms-xf86audio/files/patch-Makefile
new file mode 100644
index 000000000000..ac1d8ba663d5
--- /dev/null
+++ b/audio/xmms-xf86audio/files/patch-Makefile
@@ -0,0 +1,19 @@
+
+$FreeBSD$
+
+--- Makefile.orig
++++ Makefile
+@@ -18,10 +18,10 @@
+ install $(PLUGIN) $(PLUGINDIR)
+
+ $(PLUGIN) : xf86audio.o
+- $(CC) $(LIBS) -shared $^ -o $@
++ $(CC) $(LIBS) -shared $? -o $@
+
+-%.o : %.c
+- $(CC) $(CFLAGS) -c $^ -o $@
++.c.o:
++ $(CC) $(CFLAGS) -c $? -o $@
+
+ clean :
+ rm -f $(PLUGIN) *.o
diff --git a/audio/xmms-xf86audio/pkg-descr b/audio/xmms-xf86audio/pkg-descr
new file mode 100644
index 000000000000..18e79420219d
--- /dev/null
+++ b/audio/xmms-xf86audio/pkg-descr
@@ -0,0 +1,4 @@
+A plugin that enables XMMS to use the media-control keys on many
+keyboards to control XMMS playback and volume.
+
+WWW: http://www.devin.com/xmms-xf86audio/
diff --git a/audio/xmms-xf86audio/pkg-plist b/audio/xmms-xf86audio/pkg-plist
new file mode 100644
index 000000000000..797fb540dbfa
--- /dev/null
+++ b/audio/xmms-xf86audio/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+lib/xmms/General/libxf86audio.so
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%