aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-19 14:11:38 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-04-19 14:11:38 +0000
commit653b1b1664f5b99de071940b3180d51f265347ce (patch)
treeb2036a7885b0f3248b39036d57fb084c60301caf /audio
parent780ffb6f725d68bd3589ebf1ec327903c283bdeb (diff)
downloadports-653b1b1664f5b99de071940b3180d51f265347ce.tar.gz
ports-653b1b1664f5b99de071940b3180d51f265347ce.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mhwaveedit/Makefile26
-rw-r--r--audio/mhwaveedit/distinfo1
-rw-r--r--audio/mhwaveedit/files/patch-Makefile.in11
-rw-r--r--audio/mhwaveedit/pkg-comment1
-rw-r--r--audio/mhwaveedit/pkg-descr14
-rw-r--r--audio/mhwaveedit/pkg-plist1
7 files changed, 55 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 994d92621fa3..eaa66c782084 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -119,6 +119,7 @@
SUBDIR += lopster
SUBDIR += mad
SUBDIR += maplay
+ SUBDIR += mhwaveedit
SUBDIR += midimountain
SUBDIR += mikmod
SUBDIR += mixer.app
diff --git a/audio/mhwaveedit/Makefile b/audio/mhwaveedit/Makefile
new file mode 100644
index 000000000000..e75370a12807
--- /dev/null
+++ b/audio/mhwaveedit/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: mhWaveEdit
+# Date created: Apr 19, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mhwaveedit
+PORTVERSION= 1.1.3
+CATEGORIES= audio
+MASTER_SITES= http://www.mtek.chalmers.se/~hjormagn/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile \
+ SDL-1.1:${PORTSDIR}/devel/sdl12
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_GTK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/audio/mhwaveedit/distinfo b/audio/mhwaveedit/distinfo
new file mode 100644
index 000000000000..a14734c73747
--- /dev/null
+++ b/audio/mhwaveedit/distinfo
@@ -0,0 +1 @@
+MD5 (mhwaveedit-1.1.3.tar.gz) = f012bba8292d7b401f5d13ebe361da98
diff --git a/audio/mhwaveedit/files/patch-Makefile.in b/audio/mhwaveedit/files/patch-Makefile.in
new file mode 100644
index 000000000000..228d5ebfdec9
--- /dev/null
+++ b/audio/mhwaveedit/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Fri Apr 19 22:08:26 2002
++++ src/Makefile.in Fri Apr 19 22:08:46 2002
+@@ -171,7 +171,7 @@
+ if test -f $$p \
+ ; then \
+ p1=`echo "$$p1" | sed -e 's,^.*/,,'`; \
+- f=`echo $$p1|sed '$(transform);s/$$/$(EXEEXT)/'`; \
++ f=`echo $$p1|sed 's/$$/$(EXEEXT)/'`; \
+ echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/$$f"; \
+ $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) $$p $(DESTDIR)$(bindir)/$$f; \
+ else :; fi; \
diff --git a/audio/mhwaveedit/pkg-comment b/audio/mhwaveedit/pkg-comment
new file mode 100644
index 000000000000..29be5dcec386
--- /dev/null
+++ b/audio/mhwaveedit/pkg-comment
@@ -0,0 +1 @@
+A graphical program for editing sound files
diff --git a/audio/mhwaveedit/pkg-descr b/audio/mhwaveedit/pkg-descr
new file mode 100644
index 000000000000..cfc65206ad85
--- /dev/null
+++ b/audio/mhwaveedit/pkg-descr
@@ -0,0 +1,14 @@
+mhWaveEdit is a graphical program for editing sound files.
+
+Features
+ - Loads, plays, records and saves wav-files and a few other formats as well.
+ - If the file is small, it's loaded into memory. Otherwise, it's edited on
+ disc.
+ - Cut, copy and paste.
+ - Zooming
+ - Volume and speed adjustment
+ - Convert between sample rates, sample sizes, stereo and mono
+ - You can always undo, all the way back to the original state of the file
+ (even when editing large files.)
+
+WWW: http://www.mtek.chalmers.se/~hjormagn/mhwaveedit.html
diff --git a/audio/mhwaveedit/pkg-plist b/audio/mhwaveedit/pkg-plist
new file mode 100644
index 000000000000..7419f031e87e
--- /dev/null
+++ b/audio/mhwaveedit/pkg-plist
@@ -0,0 +1 @@
+bin/mhwaveedit