aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-26 14:00:52 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-26 14:00:52 +0000
commit896b68ed93f0cef20c1642b041022fc3236a31e0 (patch)
treec2a3d2d03d5b242825ceb3f140189c7e85b23e99 /audio
parent08d589721712a059309093b97db777f9f3377f89 (diff)
downloadports-896b68ed93f0cef20c1642b041022fc3236a31e0.tar.gz
ports-896b68ed93f0cef20c1642b041022fc3236a31e0.zip
Fix after conversion to new options framework
Approved by: miwi
Notes
Notes: svn path=/head/; revision=315291
Diffstat (limited to 'audio')
-rw-r--r--audio/shntool/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/audio/shntool/Makefile b/audio/shntool/Makefile
index bbaf873e4046..c5db0ded4f3d 100644
--- a/audio/shntool/Makefile
+++ b/audio/shntool/Makefile
@@ -32,14 +32,14 @@ RDEP= AIFF:sox SHN:shorten FLAC APE:mac OFR:ofr:optimfrog LPAC WV:wavpack \
.include <bsd.port.options.mk>
-.for i in ${RDEP}
-o= ${i:C/:.*//}
-. if ${PORT_OPTIONS:M${o}}
-b= ${i:C/^[A-Z]*://:C/:.*//:L}
-p= ${i:C/^[A-Z]*://:C/.*://:L}
+.for o in ${PORT_OPTIONS}
+m= ${RDEP:M${o}*}
+.if ${m}
+b= ${m:C/^[A-Z]*://:C/:.*//:L}
+p= ${m:C/^[A-Z]*://:C/.*://:L}
RUN_DEPENDS+= ${b}:${PORTSDIR}/audio/${p}
RUN_DEPENDS:= ${RUN_DEPENDS}
-. endif
+.endif
.endfor
.include <bsd.port.mk>