aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-04-18 22:36:39 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-04-18 22:40:00 +0000
commit911d705637c1980bf4c30485fa3468fcf45a4b94 (patch)
tree449f8f87c64653a5b54b60749d87a963ceb9908b /audio
parent441dae7ec824036b2ac68f0793ff7b6f24bce377 (diff)
downloadports-911d705637c1980bf4c30485fa3468fcf45a4b94.tar.gz
ports-911d705637c1980bf4c30485fa3468fcf45a4b94.zip
audio/liblscp: Fix reported version and pathfix
The CMake file runs git to determine versioning data however since we don't import a git repo it fails to work as intended While at it fix install path of .pc file as USES= pathfix doesn't cover the logic used in this project
Diffstat (limited to 'audio')
-rw-r--r--audio/liblscp/Makefile3
-rw-r--r--audio/liblscp/files/patch-CMakeLists.txt20
-rw-r--r--audio/liblscp/files/patch-src_CMakeLists.txt10
3 files changed, 32 insertions, 1 deletions
diff --git a/audio/liblscp/Makefile b/audio/liblscp/Makefile
index 147c19fe0666..c013455054c8 100644
--- a/audio/liblscp/Makefile
+++ b/audio/liblscp/Makefile
@@ -1,5 +1,6 @@
PORTNAME= liblscp
DISTVERSION= 0.9.12
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/qsampler/${PORTNAME}/${DISTVERSION} \
http://download.linuxsampler.org/packages/
@@ -11,7 +12,7 @@ WWW= https://www.linuxsampler.org/
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake pathfix
+USES= cmake
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/audio/liblscp/files/patch-CMakeLists.txt b/audio/liblscp/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..013410fa5e95
--- /dev/null
+++ b/audio/liblscp/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2024-04-18 22:33:21 UTC
++++ CMakeLists.txt
+@@ -9,7 +9,7 @@ set (PROJECT_DOMAIN "linuxsampler.org")
+ set (PROJECT_COPYRIGHT "Copyright (C) 2004-2024, rncbc aka Rui Nuno Capela. All rights reserved.")
+ set (PROJECT_DOMAIN "linuxsampler.org")
+
+-execute_process (
++#[[ execute_process (
+ COMMAND git describe --tags --dirty --abbrev=6
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
+ OUTPUT_VARIABLE GIT_DESCRIBE_OUTPUT
+@@ -32,7 +32,7 @@ if (GIT_DESCRIBE_RESULT EQUAL 0)
+ set (GIT_VERSION "${GIT_VERSION} [${GIT_REVPARSE_OUTPUT}]")
+ endif ()
+ set (PROJECT_VERSION "${GIT_VERSION}")
+-endif ()
++endif () ]]
+
+
+ set (CONFIG_PREFIX "${CMAKE_INSTALL_PREFIX}")
diff --git a/audio/liblscp/files/patch-src_CMakeLists.txt b/audio/liblscp/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..c4d182f40363
--- /dev/null
+++ b/audio/liblscp/files/patch-src_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- src/CMakeLists.txt.orig 2024-04-18 22:33:51 UTC
++++ src/CMakeLists.txt
+@@ -62,6 +62,6 @@ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/lscp.pc
+ DESTINATION ${CONFIG_INCLUDEDIR}/lscp)
+
+ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/lscp.pc
+- DESTINATION ${CONFIG_LIBDIR}/pkgconfig)
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig)
+
+