aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-03-31 02:36:14 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-03-31 02:36:14 +0000
commita5bce4e792570635e34212ad509776639eee9184 (patch)
tree71398e8e51a3da2977274de327d44e39fea231f8 /audio
parente272b83198d6840a25ff8891f2e0573651b0c745 (diff)
downloadports-a5bce4e792570635e34212ad509776639eee9184.tar.gz
ports-a5bce4e792570635e34212ad509776639eee9184.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile3
-rw-r--r--audio/festvox-us1-mbrola/Makefile46
-rw-r--r--audio/festvox-us1-mbrola/distinfo3
-rw-r--r--audio/festvox-us1-mbrola/pkg-descr3
-rw-r--r--audio/festvox-us2-mbrola/Makefile12
-rw-r--r--audio/festvox-us2-mbrola/distinfo3
-rw-r--r--audio/festvox-us3-mbrola/Makefile12
-rw-r--r--audio/festvox-us3-mbrola/distinfo3
8 files changed, 85 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index e1a08042a2fb..8e044806d3b1 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -138,6 +138,9 @@
SUBDIR += festvox-rab16
SUBDIR += festvox-rab8
SUBDIR += festvox-tll
+ SUBDIR += festvox-us1-mbrola
+ SUBDIR += festvox-us2-mbrola
+ SUBDIR += festvox-us3-mbrola
SUBDIR += flac
SUBDIR += flac123
SUBDIR += flite
diff --git a/audio/festvox-us1-mbrola/Makefile b/audio/festvox-us1-mbrola/Makefile
new file mode 100644
index 000000000000..b81944a98d37
--- /dev/null
+++ b/audio/festvox-us1-mbrola/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: festvox-us1-mbrola
+# Date created: 31 Mar 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= festvox-${VOICE}-mbrola
+PORTVERSION?= 20041012
+CATEGORIES= audio accessibility
+MASTER_SITES= ${MASTER_SITE_FESTIVAL}
+MASTER_SITE_SUBDIR= 1.95
+DISTNAME= festvox_${VOICE}
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT?= The MBROLA ${VOICE} voice (${VOICEDESC}) for Festival
+
+RUN_DEPENDS= ${LOCALBASE}/share/festival/lib/dicts/cmu/cmulex.scm:${PORTSDIR}/audio/festlex-cmu \
+ mbrola:${PORTSDIR}/audio/linux-mbrola \
+ ${LOCALBASE}/share/mbrolavox/${VOICE}/${VOICE}:${PORTSDIR}/audio/mbrolavox
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+VOICE?= us1
+VOICEDESC?= American English, female
+
+VOICEDIR= ${PREFIX}/share/festival/lib/voices/english/${VOICE}_mbrola
+VOICEDIR_REL= ${VOICEDIR:S|^${PREFIX}/||}
+
+PLIST_FILES= ${VOICEDIR_REL}/festvox/${VOICE}_mbrola.scm \
+ ${VOICEDIR_REL}/festvox/usdurtreeZ.scm \
+ ${VOICEDIR_REL}/${VOICE} \
+ ${VOICEDIR_REL}/usradio
+PLIST_DIRS= ${VOICEDIR_REL}/festvox \
+ ${VOICEDIR_REL}
+
+MD5_FILE= ${.CURDIR}/distinfo
+
+do-install:
+ cd ${WRKSRC} && \
+ ${FIND} * -type d -exec ${MKDIR} "${PREFIX}/share/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${PREFIX}/share/{}" \;
+ ${LN} -sf ${LOCALBASE}/share/mbrolavox/${VOICE} ${VOICEDIR}
+
+.include <bsd.port.mk>
diff --git a/audio/festvox-us1-mbrola/distinfo b/audio/festvox-us1-mbrola/distinfo
new file mode 100644
index 000000000000..d12d160c4fd4
--- /dev/null
+++ b/audio/festvox-us1-mbrola/distinfo
@@ -0,0 +1,3 @@
+MD5 (festvox_us1.tar.gz) = d0c3e727003e715a65daf01003101813
+SHA256 (festvox_us1.tar.gz) = 23b332513867d6e9c340dc888a7ce67843e5a3c03db328cd36975985057c8b8e
+SIZE (festvox_us1.tar.gz) = 11040
diff --git a/audio/festvox-us1-mbrola/pkg-descr b/audio/festvox-us1-mbrola/pkg-descr
new file mode 100644
index 000000000000..04942e4c4d62
--- /dev/null
+++ b/audio/festvox-us1-mbrola/pkg-descr
@@ -0,0 +1,3 @@
+This port installs a MBROLA voice for the Festival Speech Synthesis System.
+
+WWW: http://tcts.fpms.ac.be/synthesis/mbrola.html
diff --git a/audio/festvox-us2-mbrola/Makefile b/audio/festvox-us2-mbrola/Makefile
new file mode 100644
index 000000000000..4c8a59ef075e
--- /dev/null
+++ b/audio/festvox-us2-mbrola/Makefile
@@ -0,0 +1,12 @@
+# New ports collection makefile for: festvox-us2-mbrola
+# Date created: 31 Mar 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+VOICE= us2
+VOICEDESC= American English, low-pitched male
+MASTERDIR= ${.CURDIR}/../festvox-us1-mbrola
+
+.include "${MASTERDIR}/Makefile"
diff --git a/audio/festvox-us2-mbrola/distinfo b/audio/festvox-us2-mbrola/distinfo
new file mode 100644
index 000000000000..72102adf873e
--- /dev/null
+++ b/audio/festvox-us2-mbrola/distinfo
@@ -0,0 +1,3 @@
+MD5 (festvox_us2.tar.gz) = fbcc8baacbff3aa2aaaf5a93701bb5e0
+SHA256 (festvox_us2.tar.gz) = d27ad26213144d956815e804c06e5473191ac12afb44f6a1029b3842e3a3007c
+SIZE (festvox_us2.tar.gz) = 11037
diff --git a/audio/festvox-us3-mbrola/Makefile b/audio/festvox-us3-mbrola/Makefile
new file mode 100644
index 000000000000..479bfdc33ff7
--- /dev/null
+++ b/audio/festvox-us3-mbrola/Makefile
@@ -0,0 +1,12 @@
+# New ports collection makefile for: festvox-us3-mbrola
+# Date created: 31 Mar 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+VOICE= us3
+VOICEDESC= American English, high-pitched male
+MASTERDIR= ${.CURDIR}/../festvox-us1-mbrola
+
+.include "${MASTERDIR}/Makefile"
diff --git a/audio/festvox-us3-mbrola/distinfo b/audio/festvox-us3-mbrola/distinfo
new file mode 100644
index 000000000000..9ee984343cf8
--- /dev/null
+++ b/audio/festvox-us3-mbrola/distinfo
@@ -0,0 +1,3 @@
+MD5 (festvox_us3.tar.gz) = 06dbfe2edaab6ffa31deeaf522e0c33e
+SHA256 (festvox_us3.tar.gz) = af9ca4d1832e1971aa6e52f6a3ff8f729bf970c7bee1de7e8ac0611ca01871b8
+SIZE (festvox_us3.tar.gz) = 11220