aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-29 19:11:51 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-29 19:11:51 +0000
commita84c115a09e00e14810cb1deb7bf4637a33ad313 (patch)
tree97c04ac5ad39d0af4b856d37b17a5a074d6adbc6 /audio
parentaa63c219bc3e4ef1b783a2b3c14615ecde12089a (diff)
downloadports-a84c115a09e00e14810cb1deb7bf4637a33ad313.tar.gz
ports-a84c115a09e00e14810cb1deb7bf4637a33ad313.zip
Convert a bunch of EXTRACT_SUFX=... into USES=tar:...
Approved by: portmgr (not really, but touches unstaged ports)
Notes
Notes: svn path=/head/; revision=363374
Diffstat (limited to 'audio')
-rw-r--r--audio/amrcoder/Makefile3
-rw-r--r--audio/chordpack/Makefile3
-rw-r--r--audio/cmt/Makefile3
-rw-r--r--audio/enscribe/Makefile3
-rw-r--r--audio/funktrackergold/Makefile3
-rw-r--r--audio/ladspa/Makefile3
-rw-r--r--audio/libconvolve/Makefile3
-rw-r--r--audio/libtremor/Makefile3
-rw-r--r--audio/mctoolame-decoder/Makefile3
-rw-r--r--audio/mctoolame-encoder/Makefile3
-rw-r--r--audio/mpdbrowser/Makefile3
-rw-r--r--audio/portaudio2/Makefile3
-rw-r--r--audio/squeezeboxserver/Makefile3
-rw-r--r--audio/taglookup/Makefile3
-rw-r--r--audio/toolame/Makefile3
-rw-r--r--audio/tta/Makefile3
-rw-r--r--audio/xcdplayer/Makefile3
-rw-r--r--audio/xoscope/Makefile3
18 files changed, 18 insertions, 36 deletions
diff --git a/audio/amrcoder/Makefile b/audio/amrcoder/Makefile
index a8be61e03e96..c315e77c16b2 100644
--- a/audio/amrcoder/Makefile
+++ b/audio/amrcoder/Makefile
@@ -6,12 +6,11 @@ PORTVERSION= 1.0
CATEGORIES= audio
MASTER_SITES= http://ftp.us.sinuspl.net/pub/src/ \
http://ftp.uni-erlangen.de/pub/FreeBSD/ports/distfiles/
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= AMR encoder/decoder for Mbuni MMS Gateway (www.mbuni.org)
-USES= uidfix
+USES= uidfix tar:tgz
post-extract:
@${RM} ${WRKSRC}/*.o
diff --git a/audio/chordpack/Makefile b/audio/chordpack/Makefile
index fed755c50aaa..f9f3eae0344b 100644
--- a/audio/chordpack/Makefile
+++ b/audio/chordpack/Makefile
@@ -6,12 +6,11 @@ PORTVERSION= 0.8.1
PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://sweb.cz/dan.polansky/chordpack/
-EXTRACT_SUFX= .tgz
MAINTAINER= sethk@meowfishies.com
COMMENT= Script to convert ChordPro files to HTML, ASCII, and TeX
-USES= shebangfix perl5
+USES= shebangfix perl5 tar:tgz
SHEBANG_FILES= chordpack
USE_PERL5= run
NO_WRKSUBDIR= true
diff --git a/audio/cmt/Makefile b/audio/cmt/Makefile
index 54df55f07463..9d9339dac14e 100644
--- a/audio/cmt/Makefile
+++ b/audio/cmt/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 1.16
CATEGORIES= audio
MASTER_SITES= http://www.ladspa.org/download/
DISTNAME= ${PORTNAME}_src_${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= The Computer Music Toolkit - a collection of LADSPA plugins
@@ -17,7 +16,7 @@ RUN_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
WRKSRC= ${WRKDIR}/${PORTNAME}
BUILD_WRKSRC= ${WRKDIR}/${PORTNAME}/src
-USES= gmake
+USES= gmake tar:tgz
MAKEFILE= makefile
MAKE_ARGS= CXX="${CXX}" \
CXXFLAGS="${CXXFLAGS} -fPIC -I${LOCALBASE}/include"
diff --git a/audio/enscribe/Makefile b/audio/enscribe/Makefile
index e4b6b4247fc1..4766beb56fa6 100644
--- a/audio/enscribe/Makefile
+++ b/audio/enscribe/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 0.1.0
PORTREVISION= 6
CATEGORIES= audio graphics
MASTER_SITES= http://www.coppercloudmusic.com/enscribe/
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Create digital audio watermark images from photographic images
@@ -17,7 +16,7 @@ LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile \
libpng15.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
-USES= pkgconfig
+USES= pkgconfig tar:tgz
LICENSE= GPLv2
diff --git a/audio/funktrackergold/Makefile b/audio/funktrackergold/Makefile
index 1244e5f801db..4738efdc047f 100644
--- a/audio/funktrackergold/Makefile
+++ b/audio/funktrackergold/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/sound/players
DISTNAME= funktrackergold-1.5-2
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Curses MOD/FNK music tracker
@@ -17,7 +16,7 @@ OPTIONS_DEFINE= DOCS
LICENSE= GPLv2
-USES= compiler:nestedfct
+USES= compiler:nestedfct tar:tgz
WRKSRC= ${WRKDIR}/funkgold
MAKE_ARGS= EXTRA_CFLAGS="${PTHREAD_CFLAGS}" \
diff --git a/audio/ladspa/Makefile b/audio/ladspa/Makefile
index 995fc2bb4ca2..7d7332ee2650 100644
--- a/audio/ladspa/Makefile
+++ b/audio/ladspa/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 1.13
CATEGORIES= audio
MASTER_SITES= http://www.ladspa.org/download/
DISTNAME= ladspa_sdk_${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= arved@FreeBSD.org
COMMENT= Linux Audio Developer's Simple Plugin API
@@ -15,7 +14,7 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/doc/COPYING
WRKSRC= ${WRKDIR}/ladspa_sdk
-USES= gmake
+USES= gmake tar:tgz
USE_LDCONFIG= yes
PROGRAM_FILES= analyseplugin applyplugin listplugins
PLUGIN_FILES= amp.so delay.so filter.so noise.so sine.so
diff --git a/audio/libconvolve/Makefile b/audio/libconvolve/Makefile
index 6d13566124ac..cafaa8d7c5ed 100644
--- a/audio/libconvolve/Makefile
+++ b/audio/libconvolve/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 0.0.8
PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= SF/heaven/Audio%20Applications/Jack%20Related/jack_convolve/
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple C library for partitioned convolution
@@ -19,7 +18,7 @@ LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libsndfile.so:${PORTSDIR}/audio/libsndfile
-USES= gmake pkgconfig
+USES= gmake pkgconfig tar:tgz
USE_LDCONFIG= yes
post-patch:
diff --git a/audio/libtremor/Makefile b/audio/libtremor/Makefile
index 3a2d376a4514..7777479b6a94 100644
--- a/audio/libtremor/Makefile
+++ b/audio/libtremor/Makefile
@@ -7,14 +7,13 @@ PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://members.chello.nl/~g.mast/distfiles/
DISTNAME= tremor_snapshot_${SNAP_DATE}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Integer-only fully Ogg Vorbis compliant decoder library
SNAP_DATE= 02132004
WRKSRC= ${WRKDIR}/Tremor
-USES= libtool:keepla
+USES= libtool:keepla tar:tgz
USE_AUTOTOOLS= aclocal automake autoconf libtoolize
AUTOMAKE_ARGS= -a -c
LIBTOOLIZE_ARGS=-i -c
diff --git a/audio/mctoolame-decoder/Makefile b/audio/mctoolame-decoder/Makefile
index 77bb2f54a749..0a2d962b3124 100644
--- a/audio/mctoolame-decoder/Makefile
+++ b/audio/mctoolame-decoder/Makefile
@@ -8,12 +8,11 @@ CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}d/${PORTNAME}d-01a
PKGNAMESUFFIX= -decoder
DISTNAME= ${PORTNAME}d-${PORTVERSION:C/\.//g}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= MPEG Layer II audio decoder with multi-channel support
-USES= gmake
+USES= gmake tar:tgz
ALL_TARGET= #
MAKE_ARGS= CC="${CC}" OPTIM="${CFLAGS}"
PLIST_SUB= PKGNAMESUFFIX="${PKGNAMESUFFIX}"
diff --git a/audio/mctoolame-encoder/Makefile b/audio/mctoolame-encoder/Makefile
index 01aa3fe65833..ed0a4564e4d0 100644
--- a/audio/mctoolame-encoder/Makefile
+++ b/audio/mctoolame-encoder/Makefile
@@ -8,12 +8,11 @@ CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-01a
PKGNAMESUFFIX= -encoder
DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.//g}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= MPEG Layer II audio encoder with multi-channel support
-USES= gmake
+USES= gmake tar:tgz
ALL_TARGET= #
MAKE_ARGS= CC="${CC}" OPTIM="${CFLAGS}"
PLIST_SUB= PKGNAMESUFFIX="${PKGNAMESUFFIX}"
diff --git a/audio/mpdbrowser/Makefile b/audio/mpdbrowser/Makefile
index ca88ca9f4d18..44564b69337f 100644
--- a/audio/mpdbrowser/Makefile
+++ b/audio/mpdbrowser/Makefile
@@ -7,7 +7,6 @@ CATEGORIES= audio python
MASTER_SITES= http://mpdbrowser.tuxfamily.org/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= mpdBrowser-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+ client for the Music Player Daemon (MPD)
@@ -15,7 +14,7 @@ COMMENT= GTK+ client for the Music Player Daemon (MPD)
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpd>=0.2.0:${PORTSDIR}/audio/py-mpd
PYDISTUTILS_PKGNAME= mpdBrowser
-USES= gettext iconv
+USES= gettext iconv tar:tgz
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_GNOME= intltool pygtk2
diff --git a/audio/portaudio2/Makefile b/audio/portaudio2/Makefile
index d12be1386b95..d80c8398e061 100644
--- a/audio/portaudio2/Makefile
+++ b/audio/portaudio2/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= audio
MASTER_SITES= http://www.portaudio.com/archives/
PKGNAMESUFFIX= 2
DISTNAME= pa_stable_v${DISTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= koalative@gmail.com
COMMENT= Portable cross-platform Audio API
@@ -23,7 +22,7 @@ CONFIGURE_ARGS+=PKG_CONFIG_LIBDIR=${PREFIX}/libdata/pkgconfig \
--libdir=${PREFIX}/lib/${PORTNAME}${PKGNAMESUFFIX} \
--includedir=${PREFIX}/include/${PORTNAME}${PKGNAMESUFFIX}
-USES= dos2unix gmake libtool pathfix pkgconfig
+USES= dos2unix gmake libtool pathfix pkgconfig tar:tgz
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}${PKGNAMESUFFIX}
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index 58d1b76c05be..f4f7920f2af4 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -6,7 +6,6 @@ PORTREVISION= 8
CATEGORIES= audio
MASTER_SITES= http://downloads.slimdevices.com/SqueezeboxServer_v${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-noCPAN
-EXTRACT_SUFX= .tgz
MAINTAINER= markk@knigma.org
COMMENT= Slim Devices audio streaming server
@@ -43,7 +42,7 @@ RUN_DEPENDS+= p5-Package-DeprecationManager>=0.10:${PORTSDIR}/devel/p5-Package-D
USERS= ${SLIMUSER}
GROUPS= ${SLIMGROUP}
-USES= perl5
+USES= perl5 tar:tgz
.include <bsd.port.pre.mk>
diff --git a/audio/taglookup/Makefile b/audio/taglookup/Makefile
index 59f9531211ff..a20e37b7850f 100644
--- a/audio/taglookup/Makefile
+++ b/audio/taglookup/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 0.2
PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.kamaz.org.uk/taglookup/
-EXTRACT_SUFX= .tgz
MAINTAINER= alex@kamaz.org.uk
COMMENT= Utility for tagging groups of audio files using CDDB
@@ -14,7 +13,7 @@ COMMENT= Utility for tagging groups of audio files using CDDB
LIB_DEPENDS= libcddb.so:${PORTSDIR}/audio/libcddb \
libtag.so:${PORTSDIR}/audio/taglib
-USES= pkgconfig
+USES= pkgconfig tar:tgz
PLIST_FILES= bin/taglookup \
man/man1/taglookup.1.gz
diff --git a/audio/toolame/Makefile b/audio/toolame/Makefile
index ea4fbba9d689..a7f2be12c3ce 100644
--- a/audio/toolame/Makefile
+++ b/audio/toolame/Makefile
@@ -7,7 +7,6 @@ PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%200.2/${PORTNAME}%2002l
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Optimized mpeg 1/2 layer 2 audio encoder
@@ -16,7 +15,7 @@ OPTIONS_DEFINE= DOCS
LICENSE= LGPL21
-USES= gmake
+USES= gmake tar:tgz
ALL_TARGET= ${PORTNAME}
MAKE_ARGS= CC="${CC}" TWEAKS="${CFLAGS}" ARCH="" PG="" OPTIM=""
USE_CSTD= gnu89
diff --git a/audio/tta/Makefile b/audio/tta/Makefile
index 18f102c2236f..1bab8e3ede9b 100644
--- a/audio/tta/Makefile
+++ b/audio/tta/Makefile
@@ -6,14 +6,13 @@ PORTVERSION= 3.4.1
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}enc-src
DISTNAME= ${PORTNAME}enc-${PORTVERSION}-src
-EXTRACT_SUFX= .tgz
MAINTAINER= multimedia@FreeBSD.org
COMMENT= The True Audio Encoder, lossless (de)compressor
LICENSE= GPLv2
-USES= gmake
+USES= gmake tar:tgz
ALL_TARGET= ttaenc
MAKE_ARGS= CFLAGS="${CFLAGS}" INSDIR="${STAGEDIR}${PREFIX}/bin"
diff --git a/audio/xcdplayer/Makefile b/audio/xcdplayer/Makefile
index f840c8997d57..6448ea753d93 100644
--- a/audio/xcdplayer/Makefile
+++ b/audio/xcdplayer/Makefile
@@ -6,12 +6,11 @@ PORTVERSION= 2.2
PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= XCONTRIB/../R5contrib
-EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= CD player for X
-USES= imake
+USES= imake tar:Z
USE_XORG= xbitmaps xaw
PLIST_FILES= bin/xcdplayer lib/X11/app-defaults/XCdplayer \
diff --git a/audio/xoscope/Makefile b/audio/xoscope/Makefile
index a9c288d9ffdc..d108c2da8309 100644
--- a/audio/xoscope/Makefile
+++ b/audio/xoscope/Makefile
@@ -4,14 +4,13 @@ PORTNAME= xoscope
PORTVERSION= 2.0
CATEGORIES= audio hamradio
MASTER_SITES= SF
-EXTRACT_SUFX= .tgz
MAINTAINER= db@FreeBSD.org
COMMENT= Sound card oscilloscope
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${STAGEDIR}${PREFIX} --sysconfdir=${STAGEDIR}${PREFIX}
-USES= gmake pkgconfig
+USES= gmake pkgconfig tar:tgz
USE_GNOME= gtk20
USE_XORG= x11