aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-03-19 10:04:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-03-19 10:04:01 +0000
commitac6dffe43eac4fe55a228ae70bf994d12930fad7 (patch)
treeb3705f9f95f7803d68df1bed5ef1fd375025b064 /audio
parent215eae00b7fcb275b96600b44b090b9d0787f261 (diff)
downloadports-ac6dffe43eac4fe55a228ae70bf994d12930fad7.tar.gz
ports-ac6dffe43eac4fe55a228ae70bf994d12930fad7.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/taglookup/distinfo1
-rw-r--r--audio/taglookup/files/patch-Makefile11
-rw-r--r--audio/taglookup/files/patch-tag.cpp22
3 files changed, 33 insertions, 1 deletions
diff --git a/audio/taglookup/distinfo b/audio/taglookup/distinfo
index 0a43763e839b..728354348508 100644
--- a/audio/taglookup/distinfo
+++ b/audio/taglookup/distinfo
@@ -1,3 +1,2 @@
-MD5 (taglookup-0.2.tgz) = a77d0ea7714c338be53485db94269640
SHA256 (taglookup-0.2.tgz) = 78463a754a85c438ffdffda4326ac83723616ba5f941a44dcd2d6b2dcfbfb0be
SIZE (taglookup-0.2.tgz) = 16869
diff --git a/audio/taglookup/files/patch-Makefile b/audio/taglookup/files/patch-Makefile
new file mode 100644
index 000000000000..9f154f0aaaed
--- /dev/null
+++ b/audio/taglookup/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- ./Makefile.orig 2007-10-29 08:02:54.000000000 -0400
++++ ./Makefile 2011-03-18 18:59:23.000000000 -0400
+@@ -4,7 +4,7 @@
+ TAGLIB_INCLUDE = `taglib-config --cflags`
+ TAGLIB_LIBRARY = `taglib-config --libs`
+
+-CPP = g++
++CPP = $(CXX)
+
+ CPPFLAGS = -Wall $(TAGLIB_INCLUDE) $(LIBCDDB_INCLUDE) -c
+ LDFLAGS = $(TAGLIB_LIBRARY) $(LIBCDDB_LIBRARY)
diff --git a/audio/taglookup/files/patch-tag.cpp b/audio/taglookup/files/patch-tag.cpp
new file mode 100644
index 000000000000..e76444ce7682
--- /dev/null
+++ b/audio/taglookup/files/patch-tag.cpp
@@ -0,0 +1,22 @@
+--- ./tag.cpp.orig 2007-10-28 18:42:56.000000000 -0400
++++ ./tag.cpp 2011-03-18 18:59:23.000000000 -0400
+@@ -27,6 +27,7 @@
+ #include <utility>
+
+ #include <ostream>
++#include <iostream>
+
+ // LibC TODO Replace with STL
+ // POSIX
+@@ -49,9 +50,9 @@
+ namespace TagLookup
+ {
+ // Utility functions:
+- const TagLib::String::String toUTF8String(const std::string& s)
++ const TagLib::String toUTF8String(const std::string& s)
+ {
+- const TagLib::String::String new_string(s, TagLib::String::UTF8);
++ const TagLib::String new_string(s, TagLib::String::UTF8);
+
+ return new_string;
+ } // toUTF8String