aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2005-02-14 22:19:30 +0000
committerBrooks Davis <brooks@FreeBSD.org>2005-02-14 22:19:30 +0000
commitb4533c5bdc0df0cf1d04d098671deeec6005bd69 (patch)
treedf1e5aacf6e83722f41160d9e2fb9e80d944a2ca /audio
parente7fe01858b1571482040cc089c14f590dfd8b416 (diff)
downloadports-b4533c5bdc0df0cf1d04d098671deeec6005bd69.tar.gz
ports-b4533c5bdc0df0cf1d04d098671deeec6005bd69.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/slimserver/Makefile15
-rw-r--r--audio/squeezeboxserver/Makefile15
-rw-r--r--audio/squeezecenter/Makefile15
3 files changed, 21 insertions, 24 deletions
diff --git a/audio/slimserver/Makefile b/audio/slimserver/Makefile
index a7992a17f307..41f54e608295 100644
--- a/audio/slimserver/Makefile
+++ b/audio/slimserver/Makefile
@@ -17,12 +17,11 @@ COMMENT= Slim Devices audio streaming server
DISTVERSION?= ${PORTVERSION}
-
RUN_DEPENDS+= ${LOCALBASE}/bin/mDNSResponderPosix:${PORTSDIR}/net/mDNSResponder
.include <bsd.port.pre.mk>
-SLIM_CPAN_DEPS!= cut -f 2 -d, ${FILESDIR}/pm2port | grep -v ^_builtin
+SLIM_CPAN_DEPS!= cut -f 2 -d, ${FILESDIR}/pm2port | ${GREP} -v ^_builtin | ${XARGS} echo
RUN_DEPENDS+= ${SLIM_CPAN_DEPS:S|^|${SITE_PERL}/|:S|:|:${PORTSDIR}/|}
.if ${PERL_LEVEL} < 500800
@@ -72,16 +71,16 @@ do-build:
${EXCEPTDIRS:S/$/\*/:S/^/-o -path .\//} -o -print | \
${CPIO} ${CPIOARGS} ${BINOWN}:${BINGRP} ${TMP_SLIMDIR}
@cd ${TMP_SLIMDIR}/CPAN && \
- for pm in `egrep -v ,$$ ${FILESDIR}/pm2port | cut -f 1 -d,`; do \
- grep "$${pm}:" ${FILESDIR}/CPANfiles | cut -f2 -d: | xargs rm; \
+ for pm in `${EGREP} -v ,$$ ${FILESDIR}/pm2port | cut -f 1 -d,`; do \
+ ${GREP} "$${pm}:" ${FILESDIR}/CPANfiles | cut -f2 -d: | ${XARGS} rm; \
done
- @find ${TMP_SLIMDIR}/CPAN -depth -type d -empty -delete
+ @${FIND} ${TMP_SLIMDIR}/CPAN -depth -type d -empty -delete
.if defined(PORTDEV)
@echo "Checking for unexpected files in CPAN"
@cd ${TMP_SLIMDIR}/CPAN && \
- for file in `find . -type f | sed -e 's|^\./||'`; do \
- egrep -q ":$${file}\$$" ${FILESDIR}/CPANfiles || \
- echo $${file} ; \
+ for _file in `${FIND} . -type f | ${SED} -e 's|^\./||'`; do \
+ ${EGREP} -q ":$${_file}\$$" ${FILESDIR}/CPANfiles || \
+ echo $${_file} ; \
done
@echo
.endif
diff --git a/audio/squeezeboxserver/Makefile b/audio/squeezeboxserver/Makefile
index a7992a17f307..41f54e608295 100644
--- a/audio/squeezeboxserver/Makefile
+++ b/audio/squeezeboxserver/Makefile
@@ -17,12 +17,11 @@ COMMENT= Slim Devices audio streaming server
DISTVERSION?= ${PORTVERSION}
-
RUN_DEPENDS+= ${LOCALBASE}/bin/mDNSResponderPosix:${PORTSDIR}/net/mDNSResponder
.include <bsd.port.pre.mk>
-SLIM_CPAN_DEPS!= cut -f 2 -d, ${FILESDIR}/pm2port | grep -v ^_builtin
+SLIM_CPAN_DEPS!= cut -f 2 -d, ${FILESDIR}/pm2port | ${GREP} -v ^_builtin | ${XARGS} echo
RUN_DEPENDS+= ${SLIM_CPAN_DEPS:S|^|${SITE_PERL}/|:S|:|:${PORTSDIR}/|}
.if ${PERL_LEVEL} < 500800
@@ -72,16 +71,16 @@ do-build:
${EXCEPTDIRS:S/$/\*/:S/^/-o -path .\//} -o -print | \
${CPIO} ${CPIOARGS} ${BINOWN}:${BINGRP} ${TMP_SLIMDIR}
@cd ${TMP_SLIMDIR}/CPAN && \
- for pm in `egrep -v ,$$ ${FILESDIR}/pm2port | cut -f 1 -d,`; do \
- grep "$${pm}:" ${FILESDIR}/CPANfiles | cut -f2 -d: | xargs rm; \
+ for pm in `${EGREP} -v ,$$ ${FILESDIR}/pm2port | cut -f 1 -d,`; do \
+ ${GREP} "$${pm}:" ${FILESDIR}/CPANfiles | cut -f2 -d: | ${XARGS} rm; \
done
- @find ${TMP_SLIMDIR}/CPAN -depth -type d -empty -delete
+ @${FIND} ${TMP_SLIMDIR}/CPAN -depth -type d -empty -delete
.if defined(PORTDEV)
@echo "Checking for unexpected files in CPAN"
@cd ${TMP_SLIMDIR}/CPAN && \
- for file in `find . -type f | sed -e 's|^\./||'`; do \
- egrep -q ":$${file}\$$" ${FILESDIR}/CPANfiles || \
- echo $${file} ; \
+ for _file in `${FIND} . -type f | ${SED} -e 's|^\./||'`; do \
+ ${EGREP} -q ":$${_file}\$$" ${FILESDIR}/CPANfiles || \
+ echo $${_file} ; \
done
@echo
.endif
diff --git a/audio/squeezecenter/Makefile b/audio/squeezecenter/Makefile
index a7992a17f307..41f54e608295 100644
--- a/audio/squeezecenter/Makefile
+++ b/audio/squeezecenter/Makefile
@@ -17,12 +17,11 @@ COMMENT= Slim Devices audio streaming server
DISTVERSION?= ${PORTVERSION}
-
RUN_DEPENDS+= ${LOCALBASE}/bin/mDNSResponderPosix:${PORTSDIR}/net/mDNSResponder
.include <bsd.port.pre.mk>
-SLIM_CPAN_DEPS!= cut -f 2 -d, ${FILESDIR}/pm2port | grep -v ^_builtin
+SLIM_CPAN_DEPS!= cut -f 2 -d, ${FILESDIR}/pm2port | ${GREP} -v ^_builtin | ${XARGS} echo
RUN_DEPENDS+= ${SLIM_CPAN_DEPS:S|^|${SITE_PERL}/|:S|:|:${PORTSDIR}/|}
.if ${PERL_LEVEL} < 500800
@@ -72,16 +71,16 @@ do-build:
${EXCEPTDIRS:S/$/\*/:S/^/-o -path .\//} -o -print | \
${CPIO} ${CPIOARGS} ${BINOWN}:${BINGRP} ${TMP_SLIMDIR}
@cd ${TMP_SLIMDIR}/CPAN && \
- for pm in `egrep -v ,$$ ${FILESDIR}/pm2port | cut -f 1 -d,`; do \
- grep "$${pm}:" ${FILESDIR}/CPANfiles | cut -f2 -d: | xargs rm; \
+ for pm in `${EGREP} -v ,$$ ${FILESDIR}/pm2port | cut -f 1 -d,`; do \
+ ${GREP} "$${pm}:" ${FILESDIR}/CPANfiles | cut -f2 -d: | ${XARGS} rm; \
done
- @find ${TMP_SLIMDIR}/CPAN -depth -type d -empty -delete
+ @${FIND} ${TMP_SLIMDIR}/CPAN -depth -type d -empty -delete
.if defined(PORTDEV)
@echo "Checking for unexpected files in CPAN"
@cd ${TMP_SLIMDIR}/CPAN && \
- for file in `find . -type f | sed -e 's|^\./||'`; do \
- egrep -q ":$${file}\$$" ${FILESDIR}/CPANfiles || \
- echo $${file} ; \
+ for _file in `${FIND} . -type f | ${SED} -e 's|^\./||'`; do \
+ ${EGREP} -q ":$${_file}\$$" ${FILESDIR}/CPANfiles || \
+ echo $${_file} ; \
done
@echo
.endif