aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-06-22 19:25:28 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-06-22 19:25:28 +0000
commitbcc831d73ec56badfae2cfc6d96fba5d9f3d672c (patch)
tree85fa3053ddc876ea0b63b9d3827a8ee60679be6f /audio
parente9d4feffa2d68b01cc53b946379422f54e9b6198 (diff)
downloadports-bcc831d73ec56badfae2cfc6d96fba5d9f3d672c.tar.gz
ports-bcc831d73ec56badfae2cfc6d96fba5d9f3d672c.zip
- Move devel/dumb to audio/dumb where it actually belongs
- Take maintainership - Use SF macro - Use -fPIC on 64bit architectures - Remove useless debug library Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=215545
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/dumb/Makefile13
-rw-r--r--audio/dumb/files/patch-Makefile40
-rw-r--r--audio/dumb/pkg-plist2
4 files changed, 47 insertions, 9 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 0ca5845c4863..35769f0c4756 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -119,6 +119,7 @@
SUBDIR += drumpiler
SUBDIR += dssi
SUBDIR += dtmfdial
+ SUBDIR += dumb
SUBDIR += dvda-author
SUBDIR += easytag
SUBDIR += easytag-devel
diff --git a/audio/dumb/Makefile b/audio/dumb/Makefile
index 48b61bfc9d9b..dfab9fe86a51 100644
--- a/audio/dumb/Makefile
+++ b/audio/dumb/Makefile
@@ -7,12 +7,11 @@
PORTNAME= dumb
PORTVERSION= 0.9.3
-PORTREVISION= 1
-CATEGORIES= devel audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= dumb
+PORTREVISION= 2
+CATEGORIES= audio
+MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@FreeBSD.org
COMMENT= IT, XM, S3M and MOD player library
USE_GMAKE= yes
@@ -28,6 +27,10 @@ PLIST_SUB+= ALLEGRO="@comment "
MAKE_ARGS= _PORT_ALLEGRO_CFLAGS=
.endif
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64" || ${ARCH} == "sparc64"
+CFLAGS+= -fPIC
+.endif
+
MAKE_ENV+= CC="${CC}"
pre-configure:
diff --git a/audio/dumb/files/patch-Makefile b/audio/dumb/files/patch-Makefile
index 623e96378a90..ef6504759578 100644
--- a/audio/dumb/files/patch-Makefile
+++ b/audio/dumb/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig Mon Aug 8 02:18:41 2005
-+++ ./Makefile Sun Jun 10 12:13:59 2007
+--- Makefile.orig 2005-08-08 04:18:41.000000000 +0400
++++ Makefile 2008-06-12 06:27:26.000000000 +0400
@@ -22,7 +22,7 @@
# (Note that this is unable to delete the dumbask
# executable if the configuration is absent.)
@@ -55,3 +55,39 @@
LDFLAGS := -s
+@@ -251,8 +248,8 @@
+ ALLEGRO_LIB_FILE_DEBUG := $(LIBDIR)/libaldmd.a
+
+
+-core: $(CORE_LIB_FILE_RELEASE) $(CORE_LIB_FILE_DEBUG)
+-allegro: $(ALLEGRO_LIB_FILE_RELEASE) $(ALLEGRO_LIB_FILE_DEBUG)
++core: $(CORE_LIB_FILE_RELEASE)
++allegro: $(ALLEGRO_LIB_FILE_RELEASE)
+
+ core-examples: $(CORE_EXAMPLES_EXE)
+ allegro-examples: $(ALLEGRO_EXAMPLES_EXE)
+@@ -263,11 +260,9 @@
+
+ install-core: core
+ $(call COPY,$(CORE_LIB_FILE_RELEASE),$(LIB_INSTALL_PATH))
+- $(call COPY,$(CORE_LIB_FILE_DEBUG),$(LIB_INSTALL_PATH))
+
+ install-allegro: allegro
+ $(call COPY,$(ALLEGRO_LIB_FILE_RELEASE),$(LIB_INSTALL_PATH))
+- $(call COPY,$(ALLEGRO_LIB_FILE_DEBUG),$(LIB_INSTALL_PATH))
+
+ ifeq "$(COMSPEC)" ""
+ install-core-examples: core-examples
+@@ -321,12 +316,6 @@
+ ALLEGRO_LIB_FILE := $(LIBDIR)/libaldmb.a
+ include make/Makefile.inc
+
+-OBJDIR := $(OBJDIR_BASE)/debug
+-CFLAGS := $(CFLAGS_DEBUG)
+-CORE_LIB_FILE := $(LIBDIR)/libdumbd.a
+-ALLEGRO_LIB_FILE := $(LIBDIR)/libaldmd.a
+-include make/Makefile.inc
+-
+
+ $(CORE_EXAMPLES_EXE): examples/%$(EXE_SUFFIX): examples/%.o $(CORE_LIB_FILE_RELEASE)
+ $(CC) $^ -o $@ $(LDFLAGS) $(LINK_MATH)
diff --git a/audio/dumb/pkg-plist b/audio/dumb/pkg-plist
index 0c545c9b0a64..775e11010ee9 100644
--- a/audio/dumb/pkg-plist
+++ b/audio/dumb/pkg-plist
@@ -4,6 +4,4 @@ bin/dumb2wav
include/dumb.h
%%ALLEGRO%%include/aldumb.h
lib/libdumb.a
-lib/libdumbd.a
%%ALLEGRO%%lib/libaldmb.a
-%%ALLEGRO%%lib/libaldmd.a