aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-03-23 21:14:39 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-03-23 21:14:39 +0000
commitc6a2501ef2a438d205325e3d382a031aa8486319 (patch)
treee2bedddab94c31b6b603a72007f201b1fd00c442 /audio
parentea074376d39570a02a19abe6cb0a09507466fa0a (diff)
downloadports-c6a2501ef2a438d205325e3d382a031aa8486319.tar.gz
ports-c6a2501ef2a438d205325e3d382a031aa8486319.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/csound/Makefile11
-rw-r--r--audio/csound/distinfo6
-rw-r--r--audio/raop_play/Makefile12
-rw-r--r--audio/raop_play/files/getline.h3
-rw-r--r--audio/spiralloops/Makefile2
-rw-r--r--audio/spiralsynth/Makefile2
-rw-r--r--audio/spiralsynthmodular/Makefile2
-rw-r--r--audio/zynaddsubfx/Makefile2
8 files changed, 15 insertions, 25 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 6a98c77a8b88..88d10a913b63 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= csound
-PORTVERSION= 5.11.1
-PORTREVISION= 3
+PORTVERSION= 5.12.1
CATEGORIES= audio lang
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}5.11/:src \
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}5.12/:src \
SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}5.10/:manual
# Developer does not include a newer version of the manual.
MASTER_SITE_SUBDIR= ${PORTNAME:S/$/:src/}
@@ -21,7 +20,7 @@ MAINTAINER= chris@officialunix.com
COMMENT= Sound synthesizer
LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads
+ fltk.1:${PORTSDIR}/x11-toolkits/fltk
BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
WRKSRC= ${WRKDIR}/${DISTNAME}/
@@ -47,10 +46,6 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
DISTFILES+= Csound5.10_manual_html.zip:manual
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Fails to link
-.endif
-
post-patch: apply-slist
@${SETENV} LOCALBASE=${LOCALBASE} ${SH} ${SCRIPTDIR}/check-fltk-threads.sh
@${MV} ${WRKDIR}/custom.py ${WRKSRC}
diff --git a/audio/csound/distinfo b/audio/csound/distinfo
index e56b4517324b..6aa591b59837 100644
--- a/audio/csound/distinfo
+++ b/audio/csound/distinfo
@@ -1,6 +1,6 @@
-MD5 (csound/Csound5.11.1.tar.gz) = 12d56dcead29004b4d0d052c2a1fbdb8
-SHA256 (csound/Csound5.11.1.tar.gz) = e011c47c067df6d020f7927dc1cb951e8ea4ca81a8f058fdf74e3b827ae202d8
-SIZE (csound/Csound5.11.1.tar.gz) = 6073214
+MD5 (csound/Csound5.12.1.tar.gz) = 70b0c4a159c4960a09719674657949c9
+SHA256 (csound/Csound5.12.1.tar.gz) = 89173d666df4e109e6bbbd9232e68f7710711fa0e853a29f7704aa01d502360d
+SIZE (csound/Csound5.12.1.tar.gz) = 6121581
MD5 (csound/Csound5.10_manual_html.zip) = e1eba0da11cfc1d85ef2113a81af91eb
SHA256 (csound/Csound5.10_manual_html.zip) = 2c544a1bda8897a8364fa806109bdfca6f9e01495bace014d207db145f8324b1
SIZE (csound/Csound5.10_manual_html.zip) = 5381988
diff --git a/audio/raop_play/Makefile b/audio/raop_play/Makefile
index f35e1e575c38..de909fe8edbc 100644
--- a/audio/raop_play/Makefile
+++ b/audio/raop_play/Makefile
@@ -7,7 +7,7 @@
PORTNAME= raop_play
PORTVERSION= 0.5.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= SF/raop-play/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -23,17 +23,11 @@ RUN_DEPENDS= mpg321:${PORTSDIR}/audio/mpg321 \
flac:${PORTSDIR}/audio/flac
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LDFLAGS="`fltk-config --ldflags`"
USE_GMAKE= yes
USE_GNOME= glib20
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800000 && ( ${ARCH} == "amd64" || ${ARCH} == "sparc64" )
-BROKEN= incomplete build
-.endif
-
pre-build:
${CP} ${FILESDIR}/getline.c ${FILESDIR}/getline.h ${WRKSRC}/rendezvous/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/raop_play/files/getline.h b/audio/raop_play/files/getline.h
index 3bbad5698eb3..2816a0641af1 100644
--- a/audio/raop_play/files/getline.h
+++ b/audio/raop_play/files/getline.h
@@ -11,6 +11,7 @@
#define GETLINE_NO_LIMIT -1
+#ifndef _WITH_GETLINE
int
getline __PROTO ((char **_lineptr, size_t *_n, FILE *_stream));
int
@@ -19,5 +20,5 @@ int
int
getstr __PROTO ((char **_lineptr, size_t *_n, FILE *_stream,
int _terminator, int _offset, int limit));
-
+#endif
#endif /* _getline_h_ */
diff --git a/audio/spiralloops/Makefile b/audio/spiralloops/Makefile
index 6e4a31c5de69..30ed9ee8fc40 100644
--- a/audio/spiralloops/Makefile
+++ b/audio/spiralloops/Makefile
@@ -7,7 +7,7 @@
PORTNAME= spiralloops
PORTVERSION= 2.0.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://www.pawfal.org/Software/SpiralLoops/dload/
DISTNAME= SpiralLoops-${PORTVERSION}
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index e0c42abfb88d..ab936b21a190 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -7,7 +7,7 @@
PORTNAME= spiralsynth
PORTVERSION= 0.1.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= http://www.pawfal.org/Software/SpiralSynth/dload/
DISTNAME= SpiralSynth-${PORTVERSION}
diff --git a/audio/spiralsynthmodular/Makefile b/audio/spiralsynthmodular/Makefile
index fe4112d7ea38..06511d96bb0c 100644
--- a/audio/spiralsynthmodular/Makefile
+++ b/audio/spiralsynthmodular/Makefile
@@ -7,7 +7,7 @@
PORTNAME= spiralsynthmodular
PORTVERSION= 0.2.2a
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= SF/spiralmodular/spiralmodular/${PORTVERSION}%20%28Latest%20Version%29
DISTNAME= spiralmodular-${PORTVERSION}
diff --git a/audio/zynaddsubfx/Makefile b/audio/zynaddsubfx/Makefile
index e02c82f4491f..fc798d54f843 100644
--- a/audio/zynaddsubfx/Makefile
+++ b/audio/zynaddsubfx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zynaddsubfx
PORTVERSION= 2.2.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio
MASTER_SITES= SF
DISTNAME= ZynAddSubFX-${PORTVERSION}