aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-07-17 02:07:26 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-07-17 02:09:28 +0000
commitd902630dfc4c9cc00cb97b7813f52ca0856acb0e (patch)
treedff1ed80a07aba50a2113d28c33717a04e7978b0 /audio
parente6c9092be9fcb2de5d98bee1140e961275439512 (diff)
downloadports-d902630dfc4c9cc00cb97b7813f52ca0856acb0e.tar.gz
ports-d902630dfc4c9cc00cb97b7813f52ca0856acb0e.zip
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libkeyfinder/Makefile20
-rw-r--r--audio/libkeyfinder/distinfo3
-rw-r--r--audio/libkeyfinder/pkg-descr15
-rw-r--r--audio/libkeyfinder/pkg-plist23
5 files changed, 62 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index cd1a5e2039df..ddf0309c6e62 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -380,6 +380,7 @@
SUBDIR += libinstpatch
SUBDIR += libkcddb
SUBDIR += libkcompactdisc
+ SUBDIR += libkeyfinder
SUBDIR += liblastfm-qt5
SUBDIR += liblo
SUBDIR += liblscp
diff --git a/audio/libkeyfinder/Makefile b/audio/libkeyfinder/Makefile
new file mode 100644
index 000000000000..963cc83cfbef
--- /dev/null
+++ b/audio/libkeyfinder/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= libkeyfinder
+PORTVERSION= 2.2.4
+DISTVERSIONPREFIX= v
+CATEGORIES= audio
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Small C++11 library for estimating the musical key of digital audio
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libfftw3.so:math/fftw3
+
+USES= cmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= mixxxdj
+
+CMAKE_ARGS+= -DBUILD_TESTING:BOOL=OFF
+
+.include <bsd.port.mk>
diff --git a/audio/libkeyfinder/distinfo b/audio/libkeyfinder/distinfo
new file mode 100644
index 000000000000..3432bc8ad364
--- /dev/null
+++ b/audio/libkeyfinder/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1626463815
+SHA256 (mixxxdj-libkeyfinder-v2.2.4_GH0.tar.gz) = 3588329348fef4899fb595cbb76042f5b33e9734b853f2e399972865d799d239
+SIZE (mixxxdj-libkeyfinder-v2.2.4_GH0.tar.gz) = 79053
diff --git a/audio/libkeyfinder/pkg-descr b/audio/libkeyfinder/pkg-descr
new file mode 100644
index 000000000000..78fe1b97bb3f
--- /dev/null
+++ b/audio/libkeyfinder/pkg-descr
@@ -0,0 +1,15 @@
+libkeyfinder is a small C++11 library for estimating the musical key of digital
+audio. It is published under the GNU General Public License version 3 or later.
+
+It was written by Ibrahim Shaath who wrote it in 2011 as part of a master's
+thesis in computer science. A GUI application to use it is available for macOS
+and Windows, however that is no longer maintained and does not build on
+contemporary Linux distributions.
+
+In 2020, Ibrahim handed over maintenance of libkeyfinder to the Mixxx DJ
+software team who incorporated it into Mixxx as of Mixxx 2.3. If you want to
+discuss anything related to libkeyfinder with us, please get in touch on the
+Mixxx Zulip chat. Contributions are welcome by opening pull requests and issues
+on GitHub.
+
+WWW: https://github.com/mixxxdj/libkeyfinder
diff --git a/audio/libkeyfinder/pkg-plist b/audio/libkeyfinder/pkg-plist
new file mode 100644
index 000000000000..317d85c652c3
--- /dev/null
+++ b/audio/libkeyfinder/pkg-plist
@@ -0,0 +1,23 @@
+include/keyfinder/audiodata.h
+include/keyfinder/binode.h
+include/keyfinder/chromagram.h
+include/keyfinder/chromatransform.h
+include/keyfinder/chromatransformfactory.h
+include/keyfinder/constants.h
+include/keyfinder/exception.h
+include/keyfinder/fftadapter.h
+include/keyfinder/keyclassifier.h
+include/keyfinder/keyfinder.h
+include/keyfinder/lowpassfilter.h
+include/keyfinder/lowpassfilterfactory.h
+include/keyfinder/spectrumanalyser.h
+include/keyfinder/temporalwindowfactory.h
+include/keyfinder/toneprofiles.h
+include/keyfinder/windowfunctions.h
+include/keyfinder/workspace.h
+lib/cmake/KeyFinder/KeyFinderConfig.cmake
+lib/cmake/KeyFinder/KeyFinderConfigVersion.cmake
+lib/cmake/KeyFinder/KeyFinderTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KeyFinder/KeyFinderTargets.cmake
+lib/libkeyfinder.so
+libdata/pkgconfig/libkeyfinder.pc