aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-06-13 04:26:08 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-06-13 04:26:08 +0000
commitd97c665e19df4ab47020585c86918e31f032c3d5 (patch)
tree9c83dc8fd0912f4cd8bd4fbe23750ee075e1fece /audio
parent31612f2a31c31650d3c5f0f63ceac5d5d0243a9e (diff)
downloadports-d97c665e19df4ab47020585c86918e31f032c3d5.tar.gz
ports-d97c665e19df4ab47020585c86918e31f032c3d5.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-wma/Makefile13
-rw-r--r--audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c11
2 files changed, 20 insertions, 4 deletions
diff --git a/audio/xmms-wma/Makefile b/audio/xmms-wma/Makefile
index b0c25f4832ce..42244cd213fe 100644
--- a/audio/xmms-wma/Makefile
+++ b/audio/xmms-wma/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmms-wma
PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://mcmcc.bat.ru/xmms-wma/
@@ -25,11 +25,18 @@ ONLY_FOR_ARCHS= i386
PLIST_FILES= lib/xmms/Input/libwma.so
-.if defined(ICONV)
-CFLAGS+= -DICONV
+.if defined(WITH_ICONV)
+CFLAGS+= -DUSE_ICONV
USE_ICONV= yes
.endif
+pre-everything::
+.if !defined(WITH_ICONV)
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} " "
+ @${ECHO_MSG} "WITH_ICONV=yes Enable tag recoding support using iconv"
+.endif
+
post-extract:
@${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/Makefile.inc
@${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/ffmpeg-strip-wma/config.mak
diff --git a/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c b/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c
index c4f81a12972f..3047e2c1b390 100644
--- a/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c
+++ b/audio/xmms-wma/files/patch-ffmpeg-strip-wma::asf.c
@@ -1,5 +1,5 @@
--- ffmpeg-strip-wma/asf.c.orig Wed May 26 19:16:39 2004
-+++ ffmpeg-strip-wma/asf.c Sat Dec 11 21:32:58 2004
++++ ffmpeg-strip-wma/asf.c Mon Jun 13 08:18:01 2005
@@ -16,10 +16,13 @@
* License along with this library; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
@@ -24,6 +24,15 @@
static void tag_recode(char *before, int len)
{
int result;
+@@ -842,7 +846,7 @@
+ int length = len;
+
+ memcpy(ansb, before, len);
+- frt = iconv_open(getlocale(), "UNICODE");
++ frt = iconv_open(getlocale(), "UTF-16LE");
+ if (frt == (iconv_t) - 1)
+ {
+ return;
@@ -859,6 +863,7 @@
return;
return;