aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 10:58:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-09 10:58:07 +0000
commitdb83728cb30ebd50576bd2e21091355af44fb041 (patch)
tree9652cf88ea2c09e17e67f75495f85416e9fb26ac /audio
parent8a847db1399fee380c7e2d61902f7fd61bbcda91 (diff)
downloadports-db83728cb30ebd50576bd2e21091355af44fb041.tar.gz
ports-db83728cb30ebd50576bd2e21091355af44fb041.zip
audio/py-audioread: Convert to USE_PYTHON=pytest
- Remove py-pytest-runner from TEST_DEPENDS
Diffstat (limited to 'audio')
-rw-r--r--audio/py-audioread/Makefile5
-rw-r--r--audio/py-audioread/files/patch-setup.py10
2 files changed, 11 insertions, 4 deletions
diff --git a/audio/py-audioread/Makefile b/audio/py-audioread/Makefile
index a31bd0d705e4..b8b9360cee18 100644
--- a/audio/py-audioread/Makefile
+++ b/audio/py-audioread/Makefile
@@ -12,11 +12,8 @@ COMMENT= Multi-library, cross-platform audio decoding
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${PY_FLAVOR}
-
USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent distutils pytest
NO_ARCH= yes
diff --git a/audio/py-audioread/files/patch-setup.py b/audio/py-audioread/files/patch-setup.py
new file mode 100644
index 000000000000..4da5af98e66a
--- /dev/null
+++ b/audio/py-audioread/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2019-09-01 00:41:41 UTC
++++ setup.py
+@@ -37,7 +37,6 @@ setup(name='audioread',
+ packages=['audioread'],
+
+ tests_require=[
+- 'pytest-runner',
+ 'pytest'
+ ],
+