aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-09-13 19:20:05 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-09-13 19:20:05 +0000
commite6a516443178ecbcadf6c7621c024b695d6be7fb (patch)
tree456369f0310d61ae6db1efc3ea63cbf4ab763ad4 /audio
parent52d8ad5f01003127eefac1a6aca1e41524a31459 (diff)
downloadports-e6a516443178ecbcadf6c7621c024b695d6be7fb.tar.gz
ports-e6a516443178ecbcadf6c7621c024b695d6be7fb.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/spc2it/Makefile25
-rw-r--r--audio/spc2it/distinfo3
-rw-r--r--audio/spc2it/files/patch-spc2it.130
-rw-r--r--audio/spc2it/pkg-descr3
5 files changed, 62 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index aa02f32c8a4d..a1c604ddc2b1 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -784,6 +784,7 @@
SUBDIR += soundtouch
SUBDIR += soundtracker
SUBDIR += sox
+ SUBDIR += spc2it
SUBDIR += specimen
SUBDIR += spectrogram
SUBDIR += speex
diff --git a/audio/spc2it/Makefile b/audio/spc2it/Makefile
new file mode 100644
index 000000000000..571544747e90
--- /dev/null
+++ b/audio/spc2it/Makefile
@@ -0,0 +1,25 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= spc2it
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3-14-gd4f165e
+CATEGORIES= audio converters
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Convert SPC files to IT (Impulse Tracker) files
+
+LICENSE= GPLv2
+
+USES= cmake
+USE_GITHUB= yes
+
+GH_ACCOUNT= uyjulian
+
+PLIST_FILES= bin/spc2it man/man1/spc2it.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/audio/spc2it/distinfo b/audio/spc2it/distinfo
new file mode 100644
index 000000000000..2f2128972ce2
--- /dev/null
+++ b/audio/spc2it/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536864840
+SHA256 (uyjulian-spc2it-v0.3-14-gd4f165e_GH0.tar.gz) = 6853d16b5e8540cf0182a09ccf0ada20d03237026e4bada98e6d5af9557ad882
+SIZE (uyjulian-spc2it-v0.3-14-gd4f165e_GH0.tar.gz) = 42150
diff --git a/audio/spc2it/files/patch-spc2it.1 b/audio/spc2it/files/patch-spc2it.1
new file mode 100644
index 000000000000..3188d242b444
--- /dev/null
+++ b/audio/spc2it/files/patch-spc2it.1
@@ -0,0 +1,30 @@
+--- spc2it.1.orig 2018-09-13 18:57:56 UTC
++++ spc2it.1
+@@ -0,0 +1,27 @@
++.TH spc2it "1" "September 10 2018" "User Commands"
++.SH NAME
++spc2it \- converts SPC700 sound files to the Impulse Tracker format
++.SH SYNOPSIS
++.B spc2it
++.RI [ options ] " filename"
++.TP
++Where <filename> is any .spc or .sp# file
++.SH DESCRIPTION
++This manual describes the
++.B spc2it
++command. It converts SPC files to IT (Impulse Tracker) files.
++.TP
++Options:
++.TP
++\fB\-t\fR x
++Specify a time limit in seconds [60 default]
++.TP
++\fB\-d\fR xxxxxxxx Voices to disable (1\-8) [none default]
++.TP
++\fB\-r\fR xxx
++Specify IT rows per pattern [200 default]
++.IP
++.SH "SEE ALSO"
++.BR adplay (1),
++.BR schismtracker (1).
++.br
diff --git a/audio/spc2it/pkg-descr b/audio/spc2it/pkg-descr
new file mode 100644
index 000000000000..1ccfffe5994f
--- /dev/null
+++ b/audio/spc2it/pkg-descr
@@ -0,0 +1,3 @@
+Tool to convert SPC (SNEeSe) files to IT (Impulse Tracker) files.
+
+WWW: https://github.com/uyjulian/spc2it