aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-23 20:30:50 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-23 20:30:50 +0000
commitf4a1e022c0d267b40fde97c90402277490d4eb4f (patch)
tree55da60aef1b2c32d67ec2312379a244877492550 /audio
parent0798d61585c1bb62d7fe58a74250b3d4b59388b0 (diff)
downloadports-f4a1e022c0d267b40fde97c90402277490d4eb4f.tar.gz
ports-f4a1e022c0d267b40fde97c90402277490d4eb4f.zip
Notes
Diffstat (limited to 'audio')
-rw-r--r--audio/malint/Makefile5
-rw-r--r--audio/milkytracker/Makefile11
-rw-r--r--audio/mp-player/Makefile3
-rw-r--r--audio/mp3guessenc/Makefile4
-rw-r--r--audio/openspc/Makefile5
-rw-r--r--audio/penguinsap/Makefile3
-rw-r--r--audio/playgsf/Makefile3
-rw-r--r--audio/schism/Makefile3
-rw-r--r--audio/sfront/Makefile3
-rw-r--r--audio/sidplayer/Makefile7
10 files changed, 18 insertions, 29 deletions
diff --git a/audio/malint/Makefile b/audio/malint/Makefile
index 31e6b1eb880c..0c964d053cdf 100644
--- a/audio/malint/Makefile
+++ b/audio/malint/Makefile
@@ -14,7 +14,6 @@ COMMENT= MPEG Audio stream validator
LICENSE= GPLv2
GNU_CONFIGURE= yes
-NO_STAGE= yes
PORTDOCS= README
PLIST_FILES= bin/malint
@@ -25,8 +24,8 @@ OPTIONS_DEFINE= DOCS
.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/audio/milkytracker/Makefile b/audio/milkytracker/Makefile
index 62cba784c511..307236c4874d 100644
--- a/audio/milkytracker/Makefile
+++ b/audio/milkytracker/Makefile
@@ -19,7 +19,6 @@ LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack \
zzip:${PORTSDIR}/devel/zziplib
USES= pkgconfig
-NO_STAGE= yes
GNU_CONFIGURE= yes
USE_SDL= sdl
@@ -38,15 +37,15 @@ OPTIONS_DEFINE= DOCS
post-install:
.for f in ${ICONS}
${INSTALL_DATA} ${WRKSRC}/resources/pictures/${f} \
- ${PREFIX}/share/pixmaps/${f:C/carton/milkytracker/}
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${f:C/carton/milkytracker/}
.endfor
- ${MKDIR} ${DESKTOPDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${DESKTOPDIR}
+ ${MKDIR} ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/audio/mp-player/Makefile b/audio/mp-player/Makefile
index bdbc84605978..b82938dcfe5c 100644
--- a/audio/mp-player/Makefile
+++ b/audio/mp-player/Makefile
@@ -13,7 +13,6 @@ LICENSE= GPLv2
LIB_DEPENDS= mikmod.2:${PORTSDIR}/audio/libmikmod
-NO_STAGE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lmikmod ${PTHREAD_LIBS} -lncurses -lpanel
DEFINES= -D_REENTRANT
@@ -25,6 +24,6 @@ do-build:
-o ${WRKSRC}/${PORTNAME}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/audio/mp3guessenc/Makefile b/audio/mp3guessenc/Makefile
index cd57b8db55b7..361d11c45b8b 100644
--- a/audio/mp3guessenc/Makefile
+++ b/audio/mp3guessenc/Makefile
@@ -9,8 +9,6 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:C/\.0$//}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Utility for guessing which encoder was used to encode an mp3 file
-NO_STAGE= yes
-
PLIST_FILES= bin/mp3guessenc
SRC= decode.c mp3guessenc.c bit_utils.c tags.c
@@ -22,6 +20,6 @@ do-build:
-o ${WRKSRC}/${PORTNAME} ${LDFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/audio/openspc/Makefile b/audio/openspc/Makefile
index 172412e8c480..34f9c08b92dd 100644
--- a/audio/openspc/Makefile
+++ b/audio/openspc/Makefile
@@ -14,7 +14,6 @@ COMMENT= Command-line player for .spc and .zst files
ONLY_FOR_ARCHS= i386 # contains x86 asm code
USE_LDCONFIG= yes
-NO_STAGE= yes
USE_AUTOTOOLS= libtool
USE_GCC= any
@@ -28,8 +27,8 @@ OPTIONS_DEFINE= DOCS
.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/audio/penguinsap/Makefile b/audio/penguinsap/Makefile
index 2230bd7c585a..507b4e09adc2 100644
--- a/audio/penguinsap/Makefile
+++ b/audio/penguinsap/Makefile
@@ -10,7 +10,6 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Command-line Atari(TM) .sap player
USE_DOS2UNIX= yes
-NO_STAGE= yes
SOURCES= sapPokey pokey1 sapCpu sapEngine main pokey0
@@ -45,7 +44,7 @@ do-build:
-o ${WRKSRC}/sap
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sap ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/sap ${STAGEDIR}${PREFIX}/bin
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/audio/playgsf/Makefile b/audio/playgsf/Makefile
index 9b836252ac2b..64d1bb4242a1 100644
--- a/audio/playgsf/Makefile
+++ b/audio/playgsf/Makefile
@@ -14,7 +14,6 @@ COMMENT= Command-line player for gsf audio files
LIB_DEPENDS= ao:${PORTSDIR}/audio/libao
USES= gmake
-NO_STAGE= yes
USE_DOS2UNIX= yes
GNU_CONFIGURE= yes
@@ -49,7 +48,7 @@ post-configure:
@(cd ${WRKSRC}/libresample-0.1.3; ./configure ${CONFIGURE_ENV})
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
post-install:
${CAT} ${PKGMESSAGE}
diff --git a/audio/schism/Makefile b/audio/schism/Makefile
index 50cbb6e74d05..c2f527953e26 100644
--- a/audio/schism/Makefile
+++ b/audio/schism/Makefile
@@ -17,7 +17,6 @@ LICENSE= GPLv2
ONLY_FOR_ARCHS= i386 amd64
USE_SDL= yes
-NO_STAGE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -29,7 +28,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
PORTSCOUT= skipv:20100202,20101127,20101128,20110101,20120105
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/schismtracker ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/schismtracker ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.pre.mk>
diff --git a/audio/sfront/Makefile b/audio/sfront/Makefile
index 96997d5e24df..2c6669f1cca7 100644
--- a/audio/sfront/Makefile
+++ b/audio/sfront/Makefile
@@ -12,7 +12,6 @@ COMMENT= Translator that converts MP4-SA files into efficient C programs
LICENSE= BSD
USES= bison
-NO_STAGE= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
ALL_TARGET= ${PORTNAME}
@@ -25,6 +24,6 @@ post-patch:
@${REINPLACE_CMD} -E '/^(OPT|CC|DBUG)/d' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/audio/sidplayer/Makefile b/audio/sidplayer/Makefile
index 6c0b188916d9..6cf75f6b729f 100644
--- a/audio/sidplayer/Makefile
+++ b/audio/sidplayer/Makefile
@@ -15,7 +15,6 @@ COMMENT= C64 SID tune player
LICENSE= GPLv2
USE_SDL= yes
-NO_STAGE= yes
GNU_CONFIGURE= yes
SDLINCLUDEDIR= SDL
@@ -29,10 +28,10 @@ post-patch:
${WRKSRC}/src/main_sdl.cpp
do-install:
- ${INSTALL} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${CP} ${WRKSRC}/PSID\ Demo/* ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/PSID\ Demo/* ${STAGEDIR}${DOCSDIR}
.endif
post-install: