aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-21 21:55:08 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-21 21:55:08 +0000
commitfa7459871993c1b82be45b128cb6cc16d6d6097b (patch)
treef3de3615c4398425cec6e6c4d1a630f701a34d2d /audio
parenta379971cffb802fce69885970f1184f7228beb86 (diff)
downloadports-fa7459871993c1b82be45b128cb6cc16d6d6097b.tar.gz
ports-fa7459871993c1b82be45b128cb6cc16d6d6097b.zip
Mark some ports failing on power64. In cases where the error message
was a stub, provide a real one. While here, pet portlint. Approved by: portmgr (tier-2 blanket) Reported by: swills
Notes
Notes: svn path=/head/; revision=441429
Diffstat (limited to 'audio')
-rw-r--r--audio/acoustid-fingerprinter/Makefile2
-rw-r--r--audio/aqualung/Makefile2
-rw-r--r--audio/ardour5/Makefile3
-rw-r--r--audio/clementine-player/Makefile3
-rw-r--r--audio/cmus/Makefile2
-rw-r--r--audio/hydrogen-devel/Makefile2
-rw-r--r--audio/hydrogen/Makefile2
-rw-r--r--audio/mixxx/Makefile3
-rw-r--r--audio/ncmpcpp/Makefile2
-rw-r--r--audio/praat/Makefile2
-rw-r--r--audio/rezound/Makefile2
-rw-r--r--audio/terminatorx/Makefile2
12 files changed, 24 insertions, 3 deletions
diff --git a/audio/acoustid-fingerprinter/Makefile b/audio/acoustid-fingerprinter/Makefile
index 509f93b6ea52..214f0d3f931a 100644
--- a/audio/acoustid-fingerprinter/Makefile
+++ b/audio/acoustid-fingerprinter/Makefile
@@ -14,6 +14,8 @@ LIB_DEPENDS= libchromaprint.so:audio/chromaprint \
libtag.so:audio/taglib \
libavcodec.so:multimedia/ffmpeg
+BROKEN_powerpc64= fails to compile: libchromaprint.so: undefined reference to std::__cxx11::basic_string
+
USES= cmake desktop-file-utils
USE_QT4= corelib gui network \
qmake_build moc_build rcc_build uic_build
diff --git a/audio/aqualung/Makefile b/audio/aqualung/Makefile
index 02d29efe17ee..84e707e3000f 100644
--- a/audio/aqualung/Makefile
+++ b/audio/aqualung/Makefile
@@ -30,6 +30,8 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libcdio_paranoia.so:sysutils/libcdio-paranoia \
liblrdf.so:textproc/liblrdf
+BROKEN_powerpc64= fails to link: libicuuc.so: undefined reference to __cxa_throw_bad_array_new_length
+
USES= gettext localbase lua pkgconfig
USE_GNOME= gtk20 libxml2 libxslt
GNU_CONFIGURE= yes
diff --git a/audio/ardour5/Makefile b/audio/ardour5/Makefile
index b1c771808c39..6a48cf56fed3 100644
--- a/audio/ardour5/Makefile
+++ b/audio/ardour5/Makefile
@@ -48,7 +48,8 @@ USE_GNOME= atk cairo cairomm gdkpixbuf2 glib20 glibmm gtk20 gtkmm24 pango
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-BROKEN_aarch64= Fails to configure: Could not find the program gas,as,gcc
+BROKEN_aarch64= fails to configure: Could not find the program gas,as,gcc
+BROKEN_powerpc64= fails to compile: configuration_variable.cc: 'strtof' is not a member of 'std'
PLIST_SUB= ARDOURVERSION=${PORTVERSION}
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index 47252e15a684..dfd0bc6da222 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -14,7 +14,6 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
-
LIB_DEPENDS= libtag.so:audio/taglib \
libchromaprint.so:audio/chromaprint \
libprotobuf.so:devel/protobuf \
@@ -24,6 +23,8 @@ LIB_DEPENDS= libtag.so:audio/taglib \
libechonest.so:audio/libechonest \
libcryptopp.so:security/cryptopp
+BROKEN_powerpc64= fails to compile: tagreader.cpp: undefined reference to TagLib::String::String
+
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}${PKGNAMESUFFIX}
GH_PROJECT= Clementine
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index 55c47f98f4e4..9a1bb27416e9 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -18,6 +18,8 @@ COMMENT= Console-based music player with really cool features
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to configure: checking for successful build of ffmpeg.c... no
+
USE_GITHUB= yes
USES= gmake iconv ncurses pkgconfig
diff --git a/audio/hydrogen-devel/Makefile b/audio/hydrogen-devel/Makefile
index a806df71b3d7..1ea9621b44ab 100644
--- a/audio/hydrogen-devel/Makefile
+++ b/audio/hydrogen-devel/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libsndfile.so:audio/libsndfile
+BROKEN_powerpc64= fails to link: libicuuc.so. undefined reference to __cxa_throw_bad_array_new_length
+
CONFLICTS= hydrogen-0.*
USE_GITHUB= yes
diff --git a/audio/hydrogen/Makefile b/audio/hydrogen/Makefile
index 859830a33f1a..3c4cd2ad1c45 100644
--- a/audio/hydrogen/Makefile
+++ b/audio/hydrogen/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libsndfile.so:audio/libsndfile
+BROKEN_powerpc64= fails to link: libicuuc.so. undefined reference to __cxa_throw_bad_array_new_length
+
CONFLICTS= hydrogen-devel-0.*
USE_GITHUB= yes
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index e74a13584426..ee7efa59fc44 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -28,7 +28,8 @@ LIB_DEPENDS= libchromaprint.so:audio/chromaprint \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-BROKEN_aarch64= Fails to compile: Exception("invalid machine type")
+BROKEN_aarch64= fails to compile: Exception("invalid machine type")
+BROKEN_powerpc64= fails to configure: unmet dependencies: Could not find libprotobuf, libchromaprint, libmp4, and libwavpack
USES= scons iconv pkgconfig
USE_QT4= corelib gui network opengl script scripttools sql svg \
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index 83c7b9ccd9a3..15c5001f3ae0 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= libmpdclient.so:audio/libmpdclient \
libicuuc.so:devel/icu \
libboost_filesystem.so:devel/boost-libs
+BROKEN_powerpc64= fails to compile: tags.cpp: undefined reference to TagLib::String::to8Bit
+
USES= compiler:c++11-lib iconv libtool localbase ncurses pkgconfig readline tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= glib20
diff --git a/audio/praat/Makefile b/audio/praat/Makefile
index 17e21c587a65..cb64ed81ee4a 100644
--- a/audio/praat/Makefile
+++ b/audio/praat/Makefile
@@ -12,6 +12,8 @@ COMMENT= Phonetics by Computer
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=gnu++11"
+
USE_GITHUB= yes
DOS2UNIX_REGEX= .*Makefile
USES= dos2unix iconv pkgconfig
diff --git a/audio/rezound/Makefile b/audio/rezound/Makefile
index 84ba49092417..a4a2ed3a54cb 100644
--- a/audio/rezound/Makefile
+++ b/audio/rezound/Makefile
@@ -13,6 +13,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libFOX-1.6.so:x11-toolkits/fox16
+BROKEN_powerpc64= fails to compile: CAtomicCounter.h: boost/detail/atomic_count.hpp: No such file or directory
+
USES= bison pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-alsa
diff --git a/audio/terminatorx/Makefile b/audio/terminatorx/Makefile
index 2f0379ca945a..227adb53a9a0 100644
--- a/audio/terminatorx/Makefile
+++ b/audio/terminatorx/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:audio/ladspa \
LIB_DEPENDS= libaudiofile.so:audio/libaudiofile \
liblrdf.so:textproc/liblrdf
+BROKEN_powerpc64= fails to configure: checking for XOpenDisplay in -lX11... no
+
OPTIONS_DEFINE= ALSA JACK MPG123 SOX VORBIS MAD
OPTIONS_DEFAULT= JACK MPG123 SOX VORBIS MAD
SOX_DESC= sox (.au) support