aboutsummaryrefslogtreecommitdiff
path: root/base
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
commit02f27a83b44d4566fd409edc60570ac0734eb63e (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /base
parentbddf1289efd81317364118eb60cdc28cc766c3c2 (diff)
downloadports-02f27a83b44d4566fd409edc60570ac0734eb63e.tar.gz
ports-02f27a83b44d4566fd409edc60570ac0734eb63e.zip
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=431796
Diffstat (limited to 'base')
-rw-r--r--base/gcc/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/base/gcc/Makefile b/base/gcc/Makefile
index 610c7ad42f80..16459bac49c9 100644
--- a/base/gcc/Makefile
+++ b/base/gcc/Makefile
@@ -41,8 +41,6 @@ PLIST_SUB= TARGETARCH=${TARGET_ARCH} \
TARGET_ARCH= ${CROSS_TOOLCHAIN:C,-.*$,,}
EXTRA_PATCHES+= ${.CURDIR}/../../devel/powerpc64-gcc/files/freebsd-format-extensions
-CONFIGURE_ENV= LC_ALL=C
-MAKE_ENV= LC_ALL=C
GNU_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
CONFIGURE_ARGS+=--target=${GCC_TARGET} --disable-nls \