aboutsummaryrefslogtreecommitdiff
path: root/base
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2018-08-20 09:17:45 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2018-08-20 09:17:45 +0000
commit795bd50679fe3cb0fa73481b89b9619e51751c63 (patch)
treee1786ccbe8bb425346f56eb0aae900c508b5225b /base
parent0da300d4a6e89514ed4689e3ecd97999bd5bab07 (diff)
downloadports-795bd50679fe3cb0fa73481b89b9619e51751c63.tar.gz
ports-795bd50679fe3cb0fa73481b89b9619e51751c63.zip
Cleanup packing lists.
- Use BUREMOVE to strip binutils tools not installed by the base/binutils package. - Update BUREMOVE logic in devel/binutils to cope with the base package which installs tools without a BUTARGET- prefix. - Use MANPREFIX for BUREMOVE to handle the PREFIX=/usr case used by base/binutils. - Remove binutils headers and libraries explicitly from the staging area for base/binutils. - Add missing plist entries for binutils binaries installed under a BUTARGET subdirectory. - Drop plist entries from devel/binutils that are now properly removed. Previously the binaries for Windows tools like dlltool were removed from the staging area but the manpages were still left in the package. - Bump PORTREVISION. This is a recommit of r476186 but with the update to the pkg-plist of devel/binutils and PORTREVISION bump. PR: 230278 Reviewed by: antoine Differential Revision: https://reviews.freebsd.org/D16582
Notes
Notes: svn path=/head/; revision=477638
Diffstat (limited to 'base')
-rw-r--r--base/binutils/Makefile16
-rw-r--r--base/binutils/pkg-plist5
2 files changed, 21 insertions, 0 deletions
diff --git a/base/binutils/Makefile b/base/binutils/Makefile
index 7eb28ee8ac0a..8e1b175504c9 100644
--- a/base/binutils/Makefile
+++ b/base/binutils/Makefile
@@ -23,11 +23,27 @@ BUTARGET= ${TARGETARCH}-unknown-${OPSYS:tl}${OSREL}
CONFIGURE_ARGS+= --disable-host-shared
PREFIX= /usr
+BUREMOVE= addr2line \
+ ar \
+ c++filt \
+ dlltool \
+ elfedit \
+ gprof \
+ nlmconv \
+ nm \
+ ranlib \
+ readelf \
+ size \
+ strings \
+ strip \
+ windmc \
+ windres
.include "${MASTERDIR}/Makefile"
.if ${OSVERSION} >= 1100100
PLIST_SUB+= OBJCOPY="@comment "
+BUREMOVE+= objcopy
.else
PLIST_SUB+= OBJCOPY=""
.endif
diff --git a/base/binutils/pkg-plist b/base/binutils/pkg-plist
index 513e305b247e..39a589afdf3c 100644
--- a/base/binutils/pkg-plist
+++ b/base/binutils/pkg-plist
@@ -8,6 +8,11 @@ bin/%%BUTARGET%%-ld
bin/%%BUTARGET%%-ld.bfd
%%OBJCOPY%%bin/%%BUTARGET%%-objcopy
bin/%%BUTARGET%%-objdump
+%%BUTARGET%%/bin/as
+%%BUTARGET%%/bin/ld
+%%BUTARGET%%/bin/ld.bfd
+%%OBJCOPY%%%%BUTARGET%%/bin/objcopy
+%%BUTARGET%%/bin/objdump
%%I386%%%%BUTARGET%%/lib/ldscripts/elf_i386.x
%%I386%%%%BUTARGET%%/lib/ldscripts/elf_i386.xbn
%%I386%%%%BUTARGET%%/lib/ldscripts/elf_i386.xc