aboutsummaryrefslogtreecommitdiff
path: root/base
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-09-08 21:04:00 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-09-08 21:04:00 +0000
commite307f4a394a91a38de9a9a5b520f727ce155c331 (patch)
treefdc1a0b13c6a1e7529013dceed35f6dde6bd0e06 /base
parente7099d4ced9dd26733ad3fbd897059ad1c1be11f (diff)
downloadports-e307f4a394a91a38de9a9a5b520f727ce155c331.tar.gz
ports-e307f4a394a91a38de9a9a5b520f727ce155c331.zip
Update the README to include how to cross build gcc
Also add instructions on how to add the plist for other arches in binutils
Notes
Notes: svn path=/head/; revision=421582
Diffstat (limited to 'base')
-rw-r--r--base/README12
1 files changed, 12 insertions, 0 deletions
diff --git a/base/README b/base/README
index 501bf6a0e6bc..3a13d6953653 100644
--- a/base/README
+++ b/base/README
@@ -16,3 +16,15 @@ make CROSS_TOOLCHAIN=sparc64-gcc TARGET=sparc64 TARGET_ARCH=sparc64 installworld
4/ build the required port
$ cd base/binutils
make CROSS_TOOLCHAIN=sparc64-gcc CROSS_SYSROOT=/sysroots/sparc64 package
+
+$ cd base/gcc
+make CROSS_TOOLCHAIN=sparc64-gcc CROSS_SYSROOT=/sysroots/sparc64 package
+
+the package are in base/gcc/work/pkg/*.txz and base/binutils/work/pkg/*.txz
+
+To add a plist for a new binutils target
+$ cd base/binutils
+make CROSS_TOOLCHAIN=sparc64-gcc CROSS_SYSROOT=/sysroots/sparc64 makeplist > pkg-plist
+
+edit the pkg-plist and remove everything which base does not provide via the
+elftoolchain