aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/bonnie++
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-14 21:47:45 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-14 21:47:45 +0000
commit24a1c852ed7269dcee852ac70d248892a66ab070 (patch)
treeb77dfe45c5b3fa817e83af93e5de2a5973b0e021 /benchmarks/bonnie++
parent96cd4dd6fd915ee148afb3f30af76f7fca31edf9 (diff)
downloadports-24a1c852ed7269dcee852ac70d248892a66ab070.tar.gz
ports-24a1c852ed7269dcee852ac70d248892a66ab070.zip
Update to 1.02c
PR: 39220 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Notes
Notes: svn path=/head/; revision=61278
Diffstat (limited to 'benchmarks/bonnie++')
-rw-r--r--benchmarks/bonnie++/Makefile2
-rw-r--r--benchmarks/bonnie++/distinfo2
-rw-r--r--benchmarks/bonnie++/files/patch-Makefile.in6
-rw-r--r--benchmarks/bonnie++/files/patch-bonnie++.cpp10
4 files changed, 5 insertions, 15 deletions
diff --git a/benchmarks/bonnie++/Makefile b/benchmarks/bonnie++/Makefile
index a8d2d142dda4..0d8c28bd9fb5 100644
--- a/benchmarks/bonnie++/Makefile
+++ b/benchmarks/bonnie++/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= bonnie++
-PORTVERSION= 1.02
+PORTVERSION= 1.02c
CATEGORIES= benchmarks
MASTER_SITES= http://www.coker.com.au/bonnie++/
EXTRACT_SUFX= .tgz
diff --git a/benchmarks/bonnie++/distinfo b/benchmarks/bonnie++/distinfo
index 3e9e2520e037..2c0ed7900ca5 100644
--- a/benchmarks/bonnie++/distinfo
+++ b/benchmarks/bonnie++/distinfo
@@ -1 +1 @@
-MD5 (bonnie++-1.02.tgz) = 08a6d638cb32c87cba2e0b7a7eda450f
+MD5 (bonnie++-1.02c.tgz) = 25d6f9882a7d8b7b538e3ed869bcb701
diff --git a/benchmarks/bonnie++/files/patch-Makefile.in b/benchmarks/bonnie++/files/patch-Makefile.in
index f2640289ed16..161ed3801bfb 100644
--- a/benchmarks/bonnie++/files/patch-Makefile.in
+++ b/benchmarks/bonnie++/files/patch-Makefile.in
@@ -1,10 +1,10 @@
---- Makefile.in.orig Mon Feb 19 22:25:04 2001
-+++ Makefile.in Wed Oct 17 17:00:46 2001
+--- Makefile.in.orig Thu Jun 13 12:09:24 2002
++++ Makefile.in Thu Jun 13 12:09:55 2002
@@ -8,7 +8,7 @@
eprefix=@exec_prefix@
#MORE_WARNINGS=-Weffc++ -Wcast-align
WFLAGS=-Wall -W -Wshadow -Wpointer-arith -Wwrite-strings -pedantic -ffor-scope $(MORE_WARNINGS)
--CFLAGS=-O2 -DNDEBUG $(WFLAGS) $(MORECFLAGS)
+-CFLAGS=-O2 @debug@ -DNDEBUG $(WFLAGS) $(MORECFLAGS)
+CFLAGS=${CXXFLAGS} -DNDEBUG $(WFLAGS) $(MORECFLAGS)
CXX=@CXX@ $(CFLAGS)
diff --git a/benchmarks/bonnie++/files/patch-bonnie++.cpp b/benchmarks/bonnie++/files/patch-bonnie++.cpp
deleted file mode 100644
index 9aa4622af0ce..000000000000
--- a/benchmarks/bonnie++/files/patch-bonnie++.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- bonnie++.cpp.orig Mon Aug 20 00:39:12 2001
-+++ bonnie++.cpp Fri Nov 2 19:54:31 2001
-@@ -172,7 +172,6 @@
- #endif
-
- int int_c;
-- optind = 0;
- while(-1 != (int_c = getopt(argc, argv, "bd:fg:m:n:p:qr:s:u:x:y")) )
- {
- switch(char(int_c))