aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/bonnie++
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2012-11-28 08:26:47 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2012-11-28 08:26:47 +0000
commitd5287447151989a9c6c8ccf11ac59189a00d974b (patch)
tree1cd0b7f30ec0628d716a795eb29c370ca725fe3e /benchmarks/bonnie++
parent7caff2b969d6c2502185f37ab108645752139398 (diff)
downloadports-d5287447151989a9c6c8ccf11ac59189a00d974b.tar.gz
ports-d5287447151989a9c6c8ccf11ac59189a00d974b.zip
- Update to 1.97
- Use $PTHREAD_LIBS instead of -lpthread Feature safe: yes
Notes
Notes: svn path=/head/; revision=307891
Diffstat (limited to 'benchmarks/bonnie++')
-rw-r--r--benchmarks/bonnie++/Makefile13
-rw-r--r--benchmarks/bonnie++/distinfo4
-rw-r--r--benchmarks/bonnie++/files/patch-configure23
3 files changed, 33 insertions, 7 deletions
diff --git a/benchmarks/bonnie++/Makefile b/benchmarks/bonnie++/Makefile
index 0f3b6d8fa0be..e73ba3af23ce 100644
--- a/benchmarks/bonnie++/Makefile
+++ b/benchmarks/bonnie++/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= bonnie++
-PORTVERSION= 1.96
-PORTREVISION= 1
+PORTVERSION= 1.97
CATEGORIES= benchmarks
MASTER_SITES= http://www.coker.com.au/bonnie++/experimental/
EXTRACT_SUFX= .tgz
@@ -20,6 +19,8 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.97.1
+
MAN1= bon_csv2html.1 bon_csv2txt.1 generate_randfile.1
MAN8= bonnie++.8 getc_putc.8 zcav.8
@@ -27,14 +28,16 @@ PORTDOCS= readme.html
.include <bsd.port.options.mk>
-pre-patch:
- @${REINPLACE_CMD} -e \
+post-patch:
+ @${REINPLACE_CMD} \
's|/usr/share/|${PREFIX}/share/|g' ${WRKSRC}/bonnie++.8
+ @${REINPLACE_CMD} \
+ 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/readme.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.html ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/benchmarks/bonnie++/distinfo b/benchmarks/bonnie++/distinfo
index 76ea3349b94b..82a3cfc66714 100644
--- a/benchmarks/bonnie++/distinfo
+++ b/benchmarks/bonnie++/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bonnie++-1.96.tgz) = 9c9d87bf09ac5a42a915ceeb9d8bb8358c0ca4642d86b85ed48ca5f15ee3456c
-SIZE (bonnie++-1.96.tgz) = 105183
+SHA256 (bonnie++-1.97.tgz) = 44f5a05937648a6526ba99354555d7d15f2dd392e55d3436f6746da6f6c35982
+SIZE (bonnie++-1.97.tgz) = 102604
diff --git a/benchmarks/bonnie++/files/patch-configure b/benchmarks/bonnie++/files/patch-configure
new file mode 100644
index 000000000000..8e104760e358
--- /dev/null
+++ b/benchmarks/bonnie++/files/patch-configure
@@ -0,0 +1,23 @@
+--- configure.orig 2011-01-18 22:36:19.000000000 +0100
++++ configure 2012-11-27 17:10:24.000000000 +0100
+@@ -3925,7 +3925,7 @@
+ linux_pthread="#define LINUX_PTHREAD"
+ fi
+
+-LDFLAGS=-lpthread
++LDFLAGS=%%PTHREAD_LIBS%%
+
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+@@ -3944,10 +3944,7 @@
+ }
+ _ACEOF
+ if ac_fn_cxx_try_link "$LINENO"; then :
+- thread_ldflags="-lpthread"
+-
+-else
+- thread_ldflags="-pthread"
++ thread_ldflags="%%PTHREAD_LIBS%%"
+ fi
+ rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext