aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/dbench
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-16 13:25:28 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-16 13:25:28 +0000
commit373714ddfe0ed8e14df03cb97963bae9c309eaf1 (patch)
treeb93912f40ccd670f30a104cf58c7f7fd2b0f3359 /benchmarks/dbench
parentc67ccf4ed502efcc564fe60569cadd2d526be9d9 (diff)
downloadports-373714ddfe0ed8e14df03cb97963bae9c309eaf1.tar.gz
ports-373714ddfe0ed8e14df03cb97963bae9c309eaf1.zip
- Patch how makefile uses $(mandir) instead of hacking configure script
which will be conflict with default --mandir in bsd.port.mk (testing in exp run now) Reported by: pointyhat exp run Approved by: jmelo (maintainer)
Notes
Notes: svn path=/head/; revision=195737
Diffstat (limited to 'benchmarks/dbench')
-rw-r--r--benchmarks/dbench/Makefile4
-rw-r--r--benchmarks/dbench/files/patch-configure9
2 files changed, 4 insertions, 9 deletions
diff --git a/benchmarks/dbench/Makefile b/benchmarks/dbench/Makefile
index d1bcd9e70902..ca7e807026e7 100644
--- a/benchmarks/dbench/Makefile
+++ b/benchmarks/dbench/Makefile
@@ -19,4 +19,8 @@ GNU_CONFIGURE= yes
MAN1= dbench.1
MLINKS= dbench.1 tbench.1 dbench.1 tbench_srv.1
+post-patch:
+ @${REINPLACE_CMD} -e 's,$$(mandir),$$(mandir)/man1,' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/benchmarks/dbench/files/patch-configure b/benchmarks/dbench/files/patch-configure
index 5f9ef2676ff7..a2e7d2f659c9 100644
--- a/benchmarks/dbench/files/patch-configure
+++ b/benchmarks/dbench/files/patch-configure
@@ -9,12 +9,3 @@
sysconfdir='${prefix}/etc'
sharedstatedir='${prefix}/com'
localstatedir='${prefix}/var'
-@@ -347,7 +347,7 @@
- includedir='${prefix}/include'
- oldincludedir='/usr/include'
- infodir='${prefix}/info'
--mandir='${prefix}/man'
-+mandir='${prefix}/man/man1'
-
- ac_prev=
- for ac_option