aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/dbs/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-13 12:19:33 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-13 12:19:33 +0000
commit90d0a779a537c595d9ed44fff0e3661739e3a236 (patch)
tree44f16bb825c28a3f245503bb20204973a8e5964e /benchmarks/dbs/Makefile
parent5fb39377812c9d47b68cbd7ece4b8f72ac791186 (diff)
downloadports-90d0a779a537c595d9ed44fff0e3661739e3a236.tar.gz
ports-90d0a779a537c595d9ed44fff0e3661739e3a236.zip
Notes
Diffstat (limited to 'benchmarks/dbs/Makefile')
-rw-r--r--benchmarks/dbs/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/benchmarks/dbs/Makefile b/benchmarks/dbs/Makefile
index 7e38ff995fde..9937acff86b0 100644
--- a/benchmarks/dbs/Makefile
+++ b/benchmarks/dbs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dbs
-# Date created: 1 August 1998
-# Whom: jkoshy
-#
+# Created by: Joseph Koshy <jkoshy@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= dbs
PORTVERSION= 1.1.5
@@ -13,7 +9,7 @@ MASTER_SITES= http://www.kusa.ac.jp/~yukio-m/dbs/software1.1.5/ \
LOCAL/jkoshy
MAINTAINER= ports@FreeBSD.org
-COMMENT= A distributed network benchmarking system
+COMMENT= Distributed network benchmarking system
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
@@ -23,9 +19,13 @@ INSTALL_WRKSRC= ${WRKSRC}/obj/${OPSYS}
USE_PERL5_RUN= yes
MAKEFILE= makefile
+PLIST_FILES= bin/dbs_view bin/dbsc bin/dbsd
PORTDOCS= *
PORTEXAMPLES= *
-PLIST_FILES= bin/dbs_view bin/dbsc bin/dbsd
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e \
@@ -41,13 +41,13 @@ do-install:
.for bin in dbs_view
cd ${WRKSRC}/script; ${INSTALL_SCRIPT} ${bin} ${PREFIX}/bin
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for doc in Copyright dbs.man dbs.man.jis dbs_paper.ps
cd ${WRKSRC}/doc; ${INSTALL_DATA} ${doc} ${DOCSDIR}
.endfor
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
.for ex in TCP2.cmd TCPvsMPEG.cmd
cd ${WRKSRC}/sample; ${INSTALL_DATA} ${ex} ${EXAMPLESDIR}