aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/dhrystone
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2015-01-19 15:05:12 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2015-01-19 15:05:12 +0000
commit13bc7ac7684a578a799875e553cd4ff6aac60a80 (patch)
tree1e34e9f2341474668a499bb8e738e33f7a756923 /benchmarks/dhrystone
parent9d7ba2eb3db7e8371a01016927b6f5b10edd855a (diff)
downloadports-13bc7ac7684a578a799875e553cd4ff6aac60a80.tar.gz
ports-13bc7ac7684a578a799875e553cd4ff6aac60a80.zip
- Remove duplicate spaces and fix typo
- Delete makefil as a patch - Add new makefile for the project without BSD dependencies - Fix out of order declarations in makefile - Install doc by default - bump port revision Submitted by: rodrigo Reviewed by: bapt, danfe
Notes
Notes: svn path=/head/; revision=377438
Diffstat (limited to 'benchmarks/dhrystone')
-rw-r--r--benchmarks/dhrystone/Makefile6
-rw-r--r--benchmarks/dhrystone/files/Makefile9
-rw-r--r--benchmarks/dhrystone/files/patch-Makefile12
-rw-r--r--benchmarks/dhrystone/pkg-descr2
4 files changed, 13 insertions, 16 deletions
diff --git a/benchmarks/dhrystone/Makefile b/benchmarks/dhrystone/Makefile
index 8a4b9d763a88..0c4eb87c48d5 100644
--- a/benchmarks/dhrystone/Makefile
+++ b/benchmarks/dhrystone/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dhrystone
PORTVERSION= 2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= benchmarks
MASTER_SITES= NETLIB/benchmark
DISTNAME= dhry-c
@@ -16,13 +16,13 @@ LICENSE= BSD2CLAUSE
EXTRACT_CMD= ${SH}
NO_WRKSUBDIR= yes
+MAKEFILE= ${FILESDIR}/Makefile
PLIST_FILES= bin/dhry
+PORTDOCS= RATIONALE submit.frm README_C VARIATIONS
OPTIONS_DEFINE= DOCS
-PORTDOCS= RATIONALE submit.frm README_C VARIATIONS
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dhry ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/benchmarks/dhrystone/files/Makefile b/benchmarks/dhrystone/files/Makefile
new file mode 100644
index 000000000000..9d3d76eebf64
--- /dev/null
+++ b/benchmarks/dhrystone/files/Makefile
@@ -0,0 +1,9 @@
+OBJS= dhry_1.o dhry_2.o
+
+all: dhry
+
+dhry: $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS)
+
+%.o: %.c
+ $(CC) $(CFLAGS) -o $@ $<
diff --git a/benchmarks/dhrystone/files/patch-Makefile b/benchmarks/dhrystone/files/patch-Makefile
deleted file mode 100644
index 25e0f93d5a71..000000000000
--- a/benchmarks/dhrystone/files/patch-Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
---- Makefile.orig 2015-01-16 10:40:03.233485586 +0000
-+++ Makefile 2015-01-16 10:50:21.034404184 +0000
-@@ -0,0 +1,9 @@
-+OBJ= dhry_1.o dhry_2.o
-+
-+all: dhry
-+
-+dhry: $(OBJ)
-+ $(CC) $(LDFLAGS) $(OBJ) -o $@
-+
-+%.o: %.c
-+ $(CC) -o $@ $< $(CFLAGS)
diff --git a/benchmarks/dhrystone/pkg-descr b/benchmarks/dhrystone/pkg-descr
index 35c8c091fdcb..1623c852d385 100644
--- a/benchmarks/dhrystone/pkg-descr
+++ b/benchmarks/dhrystone/pkg-descr
@@ -4,7 +4,7 @@ programming. The Dhrystone grew to become representative of general
processor (CPU) performance.
DMIPS value is result of dhrystone test divided by 1757, results are often
-reported in DMIPS/MHz. For more information, see
+reported in DMIPS/MHz. For more information, see
http://en.wikipedia.org/wiki/Dhrystone.
WWW: http://www.netlib.org/benchmark/