aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/dkftpbench
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-10-26 18:45:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-10-26 18:45:44 +0000
commitdb755cbc1bb400d38c7da62492d3bded60d4d171 (patch)
tree0dc9aafb2d3a1b6fd37fa999a6ca8b80a86df3d5 /benchmarks/dkftpbench
parentd7aecd0c11fe13f3237992d1b2586df814000e81 (diff)
downloadports-db755cbc1bb400d38c7da62492d3bded60d4d171.tar.gz
ports-db755cbc1bb400d38c7da62492d3bded60d4d171.zip
Add dkftpbench 0.45,
dkftpbench is an FTP benchmark program inspired by SPECweb99. The result of the benchmark is a number-of-simultaneous-users rating; after running the benchmark properly, you have a good idea how many simultaneous dialup clients a server can support. The target bandwidth per client is set at 28.8 kilobits/second to model dialup users; this is important for servers on the real Internet, which often serve thousands of clients on only 10 MBits/sec of bandwidth. PR: ports/73006 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
Notes
Notes: svn path=/head/; revision=120271
Diffstat (limited to 'benchmarks/dkftpbench')
-rw-r--r--benchmarks/dkftpbench/Makefile24
-rw-r--r--benchmarks/dkftpbench/distinfo2
-rw-r--r--benchmarks/dkftpbench/files/patch-Makefile.am159
-rw-r--r--benchmarks/dkftpbench/pkg-descr8
4 files changed, 193 insertions, 0 deletions
diff --git a/benchmarks/dkftpbench/Makefile b/benchmarks/dkftpbench/Makefile
new file mode 100644
index 000000000000..50a49f52266a
--- /dev/null
+++ b/benchmarks/dkftpbench/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: dkftpbench
+# Date created: 2004-10-22
+# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dkftpbench
+PORTVERSION= 0.45
+CATEGORIES= benchmarks
+MASTER_SITES= http://www.kegel.com/dkftpbench/
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= A FTP benchmark program
+
+PLIST_FILES= bin/dkftpbench
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+USE_AUTOCONF_VER=259
+USE_AUTOMAKE_VER=14
+
+.include <bsd.port.mk>
diff --git a/benchmarks/dkftpbench/distinfo b/benchmarks/dkftpbench/distinfo
new file mode 100644
index 000000000000..b20169f12cbc
--- /dev/null
+++ b/benchmarks/dkftpbench/distinfo
@@ -0,0 +1,2 @@
+MD5 (dkftpbench-0.45.tar.gz) = 3f929cc438870436421812a48e8615ef
+SIZE (dkftpbench-0.45.tar.gz) = 273760
diff --git a/benchmarks/dkftpbench/files/patch-Makefile.am b/benchmarks/dkftpbench/files/patch-Makefile.am
new file mode 100644
index 000000000000..e522bfefaa2f
--- /dev/null
+++ b/benchmarks/dkftpbench/files/patch-Makefile.am
@@ -0,0 +1,159 @@
+--- Makefile.am.orig Wed Jul 31 00:10:30 2002
++++ Makefile.am Fri Oct 22 08:46:31 2004
+@@ -8,36 +8,9 @@
+ #----------------------------------------------------------------------
+ # List everything we build; break list into three kinds of executables
+
+-# Unattended unit tests
+-TESTS = \
+- ftp_client_proto_test \
+- nbbio_test \
+- Poller_test \
+- Sked_test
+-
+-# Following tests are not yet unattended
+-HAND_TESTS = \
+- robouser_test \
+- ftp_client_pipe_test
+-
+ # Real programs
+ bin_PROGRAMS = dkftpbench
+
+-noinst_PROGRAMS = $(TESTS) $(HAND_TESTS) dklimits Poller_bench profile
+-
+-lib_LIBRARIES = libPoller.a
+-pkginclude_HEADERS = \
+- Poller.h \
+- Poller_devpoll.h \
+- Poller_poll.h \
+- Poller_select.h \
+- Poller_sigio.h \
+- Poller_sigfd.h \
+- Poller_kqueue.h
+-
+-# No info yet
+-info_TEXINFOS =
+-
+ EXTRA_DIST = \
+ inet_aton.c \
+ bakeoff.html \
+@@ -87,16 +60,6 @@
+ # For each thing we build, list its sources, and anything special about
+ # how to build it
+
+-libPoller_a_SOURCES = \
+- Poller.h \
+- Poller_sigfd.cc \
+- Poller_sigio.cc \
+- Poller_poll.cc \
+- Poller_select.cc \
+- Poller_devpoll.cc \
+- Poller_kqueue.cc \
+- Poller.cc
+-
+ dkftpbench_SOURCES = \
+ CHECK.h \
+ Poller.h \
+@@ -128,90 +91,6 @@
+ Poller.cc \
+ Sked.cc
+
+-dklimits_SOURCES = \
+- dklimits.c
+-
+-ftp_client_proto_test_SOURCES = \
+- dprint.cc \
+- ftp_client_proto.cc \
+- ftp_client_proto_test.cc
+-
+-ftp_client_pipe_test_SOURCES = \
+- dprint.cc \
+- eclock.cc \
+- ftp_client_pipe.cc \
+- ftp_client_pipe_test.cc \
+- ftp_client_proto.cc \
+- Poller_poll.cc \
+- Poller.cc \
+- nbbio.cc \
+- Sked.cc
+-
+-nbbio_test_SOURCES = \
+- dprint.cc \
+- nbbio.cc \
+- nbbio_test.cc
+-
+-robouser_test_SOURCES = \
+- dprint.cc \
+- eclock.cc \
+- ftp_client_pipe.cc \
+- ftp_client_proto.cc \
+- nbbio.cc \
+- robouser.cc \
+- Platoon.cc \
+- robouser_test.cc \
+- CHECK.cc \
+- Poller_poll.cc \
+- Poller.cc \
+- Sked.cc
+-
+-Poller_bench_SOURCES = \
+- dprint.cc \
+- eclock.cc \
+- CHECK.cc \
+- Poller.h \
+- Poller.cc \
+- Poller_devpoll.cc \
+- Poller_devpoll.h \
+- Poller_poll.h \
+- Poller_poll.cc \
+- Poller_bench.cc \
+- Poller_select.h \
+- Poller_select.cc \
+- Poller_sigio.h \
+- Poller_sigio.cc \
+- Poller_sigfd.h \
+- Poller_sigfd.cc \
+- Poller_kqueue.h \
+- Poller_kqueue.cc
+-
+-Poller_test_SOURCES = \
+- dprint.cc \
+- CHECK.cc \
+- eclock.cc \
+- Poller.h \
+- Poller.cc \
+- Poller_sigfd.cc \
+- Poller_sigfd.h \
+- Poller_sigio.cc \
+- Poller_sigio.h \
+- Poller_devpoll.cc \
+- Poller_devpoll.h \
+- Poller_poll.h \
+- Poller_poll.cc \
+- Poller_test.cc \
+- Poller_select.h \
+- Poller_select.cc \
+- Poller_kqueue.h \
+- Poller_kqueue.cc
+-
+-Sked_test_SOURCES = \
+- dprint.cc \
+- eclock.cc \
+- Sked.cc \
+- Sked_test.cc
+-
+ #------- start of corba. Not fully autoconfisticated yet ---------
+
+ CorbaPlatoon_srv.cc: CorbaPlatoon.idl
+@@ -242,11 +121,6 @@
+ /bin/rm -f *.o CorbaPlatoon.hh CorbaPlatoon{_srv,Dyn_srv}.cc
+
+ #---- end of corba --------------------------------------------------------
+-
+-#--------------------------------------------------------------------------
+-# Program to do fine-grained profiling of Linux kernel. From the net...
+-
+-profile_SOURCES = profile.c
+
+ #--------------------------------------------------------------------------
+ # Extract documentation from sources.
diff --git a/benchmarks/dkftpbench/pkg-descr b/benchmarks/dkftpbench/pkg-descr
new file mode 100644
index 000000000000..395f2192f297
--- /dev/null
+++ b/benchmarks/dkftpbench/pkg-descr
@@ -0,0 +1,8 @@
+dkftpbench is an FTP benchmark program inspired by SPECweb99. The result of the
+benchmark is a number-of-simultaneous-users rating; after running the benchmark
+properly, you have a good idea how many simultaneous dialup clients a server
+can support. The target bandwidth per client is set at 28.8 kilobits/second to
+model dialup users; this is important for servers on the real Internet, which
+often serve thousands of clients on only 10 MBits/sec of bandwidth.
+
+WWW: http://www.kegel.com/dkftpbench/