aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/dkftpbench
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-08-25 11:08:23 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-08-25 11:08:23 +0000
commitf24c8dd211cc3b2f69ac486c7f4f63f9f5e5fbb0 (patch)
tree1fb248c88b2b35bc6bf25a67a57dc7f38426a01a /benchmarks/dkftpbench
parent9d5d9d316a4d77b1ff42cd4bff315bd969052f24 (diff)
downloadports-f24c8dd211cc3b2f69ac486c7f4f63f9f5e5fbb0.tar.gz
ports-f24c8dd211cc3b2f69ac486c7f4f63f9f5e5fbb0.zip
Notes
Diffstat (limited to 'benchmarks/dkftpbench')
-rw-r--r--benchmarks/dkftpbench/Makefile11
-rw-r--r--benchmarks/dkftpbench/files/patch-Platoon.h26
2 files changed, 28 insertions, 9 deletions
diff --git a/benchmarks/dkftpbench/Makefile b/benchmarks/dkftpbench/Makefile
index 496743505e44..072037ac9f5e 100644
--- a/benchmarks/dkftpbench/Makefile
+++ b/benchmarks/dkftpbench/Makefile
@@ -10,16 +10,9 @@ MASTER_SITES= http://www.kegel.com/dkftpbench/
MAINTAINER= novel@FreeBSD.org
COMMENT= FTP benchmark program
-PLIST_FILES= bin/dkftpbench
-
GNU_CONFIGURE= yes
-
USE_AUTOTOOLS= automake14 autoconf
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1000000
-BROKEN= does not build on FreeBSD 10 or better
-.endif
+PLIST_FILES= bin/dkftpbench
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/benchmarks/dkftpbench/files/patch-Platoon.h b/benchmarks/dkftpbench/files/patch-Platoon.h
new file mode 100644
index 000000000000..ab34a9438253
--- /dev/null
+++ b/benchmarks/dkftpbench/files/patch-Platoon.h
@@ -0,0 +1,26 @@
+--- Platoon.h.orig 2002-02-13 05:06:01 UTC
++++ Platoon.h
+@@ -1,13 +1,11 @@
+ #ifndef Platoon_H
+ #define Platoon_H
+ #include "robouser.h"
+-#include <list.h>
++#include <list>
+
+ /* FIXME: 'reasonable' upper bound on number of users CPU can handle */
+ #define Platoon_MAXUSERS (1 << 16)
+
+-enum robouser_t::state_t;
+-
+ /**----------------------------------------------------------------------
+ Platoon of robousers.
+ ----------------------------------------------------------------------*/
+@@ -150,7 +148,7 @@ private:
+ robouser_t *m_users[Platoon_MAXUSERS];
+
+ /** List of dead robousers waiting to be reaped */
+- list<robouser_t *> m_deadlist;
++ std::list<robouser_t *> m_deadlist;
+
+ /** Health: count of bytes fetched so far from all files */
+ size_t m_bytesFetched;