aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/fhourstones
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-18 15:46:32 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-18 15:46:32 +0000
commitf8f07cc50728f95aede625a599483aa5fc5b2b3e (patch)
tree0a7527c758686068300c703055874b93cd9bf957 /benchmarks/fhourstones
parent72bec17006ac746531ff8a7819f4b97ac2be8bac (diff)
downloadports-f8f07cc50728f95aede625a599483aa5fc5b2b3e.tar.gz
ports-f8f07cc50728f95aede625a599483aa5fc5b2b3e.zip
Notes
Diffstat (limited to 'benchmarks/fhourstones')
-rw-r--r--benchmarks/fhourstones/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/benchmarks/fhourstones/Makefile b/benchmarks/fhourstones/Makefile
index 866da303fa97..eafe437bad60 100644
--- a/benchmarks/fhourstones/Makefile
+++ b/benchmarks/fhourstones/Makefile
@@ -15,15 +15,14 @@ NO_WRKSUBDIR= yes
PLIST_FILES= bin/fhourstones lib/fhourstones/SearchGame lib/fhourstones/inputs
PLIST_DIRS= lib/fhourstones
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/fhourstones
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/fhourstones
do-install:
- ${MKDIR} ${PREFIX}/lib/fhourstones
- ${INSTALL_SCRIPT} ${WRKDIR}/fhourstones ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKDIR}/SearchGame ${PREFIX}/lib/fhourstones/
- ${INSTALL_DATA} ${WRKDIR}/inputs ${PREFIX}/lib/fhourstones
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/fhourstones
+ ${INSTALL_SCRIPT} ${WRKDIR}/fhourstones ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKDIR}/SearchGame ${STAGEDIR}${PREFIX}/lib/fhourstones
+ ${INSTALL_DATA} ${WRKDIR}/inputs ${STAGEDIR}${PREFIX}/lib/fhourstones
.include <bsd.port.mk>