aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/fhourstones
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-05-19 08:37:43 +0000
committerJohn Marino <marino@FreeBSD.org>2015-05-19 08:37:43 +0000
commitfe8803e74a6b292d3d77ba3acb44928913a2f832 (patch)
treeb7a412cec1334c8990b6ae77a6b424bb27b94bb2 /benchmarks/fhourstones
parentf30318a865bc273ecaadfc60a711fb86e2308169 (diff)
downloadports-fe8803e74a6b292d3d77ba3acb44928913a2f832.tar.gz
ports-fe8803e74a6b292d3d77ba3acb44928913a2f832.zip
Notes
Diffstat (limited to 'benchmarks/fhourstones')
-rw-r--r--benchmarks/fhourstones/Makefile32
-rw-r--r--benchmarks/fhourstones/files/patch-Makefile10
-rw-r--r--benchmarks/fhourstones/files/patch-fhourstones7
-rw-r--r--benchmarks/fhourstones/pkg-descr2
4 files changed, 22 insertions, 29 deletions
diff --git a/benchmarks/fhourstones/Makefile b/benchmarks/fhourstones/Makefile
index a8b30a1386e3..d1fda0de29c5 100644
--- a/benchmarks/fhourstones/Makefile
+++ b/benchmarks/fhourstones/Makefile
@@ -3,26 +3,36 @@
PORTNAME= fhourstones
PORTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= benchmarks
-MASTER_SITES= http://homepages.cwi.nl/~tromp/c4/
+MASTER_SITES= http://tromp.github.io/c4/
DISTNAME= Fhourstones
MAINTAINER= ports@FreeBSD.org
-COMMENT= The Fhourstones Benchmark
+COMMENT= Integrated benchmark program
-BROKEN= Unfetchable
NO_WRKSUBDIR= yes
-PLIST_FILES= bin/fhourstones lib/fhourstones/SearchGame lib/fhourstones/inputs
+PLIST_FILES= bin/fhourstones \
+ libexec/fhourstones/SearchGame \
+ share/fhourstones/inputs
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/fhourstones
+ @${REINPLACE_CMD} -e \
+ 's| = -O3| +=|' ${WRKSRC}/Makefile
+
+post-build:
+ ${ECHO_CMD} '#!${SH}' > ${WRKSRC}/fhourstones
+ ${ECHO_CMD} 'libexecdir=${PREFIX}/libexec/fhourstones' \
+ >> ${WRKSRC}/fhourstones
+ ${ECHO_CMD} 'datadir=${DATADIR}' >> ${WRKSRC}/fhourstones
+ ${ECHO_CMD} 'exec $${libexecdir}/SearchGame < $${datadir}/inputs' \
+ >> ${WRKSRC}/fhourstones
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/fhourstones
- ${INSTALL_SCRIPT} ${WRKDIR}/fhourstones ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKDIR}/SearchGame ${STAGEDIR}${PREFIX}/lib/fhourstones
- ${INSTALL_DATA} ${WRKDIR}/inputs ${STAGEDIR}${PREFIX}/lib/fhourstones
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/fhourstones ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/fhourstones ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/inputs ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/SearchGame \
+ ${STAGEDIR}${PREFIX}/libexec/fhourstones
.include <bsd.port.mk>
diff --git a/benchmarks/fhourstones/files/patch-Makefile b/benchmarks/fhourstones/files/patch-Makefile
deleted file mode 100644
index adf8596da270..000000000000
--- a/benchmarks/fhourstones/files/patch-Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.orig 2008-06-17 21:47:28.000000000 +0200
-+++ Makefile 2008-06-17 21:47:37.000000000 +0200
-@@ -1,6 +1,6 @@
- # GNU Makefile
-
--CFLAGS = -O3 -Wextra -Wall
-+CFLAGS += -Wextra -Wall
- CFILES = SearchGame.c TransGame.c Game.c
- JAVAFILES = SearchGame.java Connect4.java Game.java TransGame.java
- HASKELLFILES = Main.hs Connect4.hs GameTreeSearch.hs
diff --git a/benchmarks/fhourstones/files/patch-fhourstones b/benchmarks/fhourstones/files/patch-fhourstones
deleted file mode 100644
index b55ccf45180a..000000000000
--- a/benchmarks/fhourstones/files/patch-fhourstones
+++ /dev/null
@@ -1,7 +0,0 @@
---- /dev/null Thu Nov 23 08:52:26 2006
-+++ fhourstones Thu Nov 23 08:45:21 2006
-@@ -0,0 +1,4 @@
-+#!/bin/sh
-+
-+exec %%PREFIX%%/lib/fhourstones/SearchGame < %%PREFIX%%/lib/fhourstones/inputs
-+
diff --git a/benchmarks/fhourstones/pkg-descr b/benchmarks/fhourstones/pkg-descr
index f2a42a5e8b03..8e4d426b0d95 100644
--- a/benchmarks/fhourstones/pkg-descr
+++ b/benchmarks/fhourstones/pkg-descr
@@ -2,4 +2,4 @@ This integer benchmark solves positions in the game of connect-4,
as played on a vertical 7x6 board. This takes about 10 minutes
on contemporary PCs.
-WWW: http://homepages.cwi.nl/~tromp/c4/fhour.html
+WWW: http://tromp.github.io/c4/fhour.html