aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/flops
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-07-06 10:02:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-07-06 10:02:08 +0000
commit31989704f143f6ac79e20f173253073993622f94 (patch)
treea0359dd28697eff65c4408237fb97a77c04ff7f7 /benchmarks/flops
parent2779c809629bcd22d674848579d0466fc6b68f01 (diff)
downloadports-31989704f143f6ac79e20f173253073993622f94.tar.gz
ports-31989704f143f6ac79e20f173253073993622f94.zip
Add flops, floating point benchmark to give your MFLOPS rating.
Inspired by: NetBSD pkgsrc
Notes
Notes: svn path=/head/; revision=138569
Diffstat (limited to 'benchmarks/flops')
-rw-r--r--benchmarks/flops/Makefile37
-rw-r--r--benchmarks/flops/distinfo4
-rw-r--r--benchmarks/flops/pkg-descr12
3 files changed, 53 insertions, 0 deletions
diff --git a/benchmarks/flops/Makefile b/benchmarks/flops/Makefile
new file mode 100644
index 000000000000..fed874267977
--- /dev/null
+++ b/benchmarks/flops/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: flops
+# Date created: 06 Jul 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flops
+PORTVERSION= 2.0
+CATEGORIES= benchmarks
+MASTER_SITES= ftp://ftp.nosc.mil/pub/aburto/flops/
+DISTFILES= ${PORTNAME}.c ${PORTNAME}.doc
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Floating point benchmark to give your MFLOPS rating
+
+PLIST_FILES= bin/flops
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= flops.doc
+.endif
+
+do-extract: .SILENT
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/flops.c ${DISTDIR}/flops.doc ${WRKSRC}
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -DUNIX -o flops flops.c)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/flops ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/flops.doc ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/benchmarks/flops/distinfo b/benchmarks/flops/distinfo
new file mode 100644
index 000000000000..d559a8dd7d26
--- /dev/null
+++ b/benchmarks/flops/distinfo
@@ -0,0 +1,4 @@
+MD5 (flops.c) = 2d6e2a28b9ee2a358b6d340389859d57
+SIZE (flops.c) = 33791
+MD5 (flops.doc) = 99656908a2598b646cf66b788c101cf8
+SIZE (flops.doc) = 7751
diff --git a/benchmarks/flops/pkg-descr b/benchmarks/flops/pkg-descr
new file mode 100644
index 000000000000..051d734ad411
--- /dev/null
+++ b/benchmarks/flops/pkg-descr
@@ -0,0 +1,12 @@
+flops.c is a C program which attempts to estimate your system's floating-
+point 'MFLOPS' rating for the FADD, FSUB, FMUL, and FDIV operations based on
+specific 'instruction mixes' (discussed below). The program provides an
+estimate of PEAK MFLOPS performance by making maximal use of register
+variables with minimal interaction with main memory. The execution loops
+are all small so that they will fit in any cache. The flops.c execution
+modules include various percent weightings of FDIV's (from 0% to 25% FDIV's)
+so that the range of performance can be obtained when using FDIV's. FDIV's,
+being computationally more intensive than FADD's or FMUL's, can impact
+performance considerably on some systems.
+
+WWW: http://performance.netlib.org/performance/html/flops.html