aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/flowgrind/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-12-05 08:06:02 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-12-05 08:06:02 +0000
commit516306e5ddef5027010d5833d67208f80dc88b82 (patch)
treecb1021356878135e53812764bbd0b9b9ff680439 /benchmarks/flowgrind/Makefile
parent83d11d273ac5c3cb4bbc1d338599db3f92ddf38f (diff)
Notes
Diffstat (limited to 'benchmarks/flowgrind/Makefile')
-rw-r--r--benchmarks/flowgrind/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/benchmarks/flowgrind/Makefile b/benchmarks/flowgrind/Makefile
index c6ad32ff976d..d7d4abb3c4cf 100644
--- a/benchmarks/flowgrind/Makefile
+++ b/benchmarks/flowgrind/Makefile
@@ -2,29 +2,26 @@
# $FreeBSD$
PORTNAME= flowgrind
-PORTVERSION= 0.7.5
-PORTREVISION= 1
+PORTVERSION= 0.8.0
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= benchmarks
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dbaio@bsd.com.br
COMMENT= Measure throughput and other metrics for TCP
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgsl.so:math/gsl \
- libxmlrpc.so:net/xmlrpc-c
+ libxmlrpc.so:net/xmlrpc-c \
+ libcurl.so:ftp/curl \
+ libwwwxml.so:www/libwww \
+ libuuid.so:misc/e2fsprogs-libuuid
USE_GITHUB= yes
-USES= autoreconf
+USES= autoreconf ssl
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-pcap --enable-gsl
-CONFIGURE_ENV= LIBS="${LIBS} -lpcap"
-
-post-patch:
- @${RM} -r ${WRKSRC}/build-aux
- @${REINPLACE_CMD} -e 's|AC_LIB_RPATH||g' ${WRKSRC}/configure.ac
+CONFIGURE_ENV= LIBS="${LIBS} -lpcap"
.include <bsd.port.mk>