aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/hs-criterion/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-08-08 17:21:45 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-08-08 17:21:45 +0000
commit25bf018f0fa446ca38508d35b6b3474e88d758d3 (patch)
tree45b457da59382af32e809be042d2a1a7cad9e952 /benchmarks/hs-criterion/Makefile
parent1c8feb1a3fd41782660f5439357efe8a9519c625 (diff)
Notes
Diffstat (limited to 'benchmarks/hs-criterion/Makefile')
-rw-r--r--benchmarks/hs-criterion/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/benchmarks/hs-criterion/Makefile b/benchmarks/hs-criterion/Makefile
index 589010d47ed6..78affc26a4ab 100644
--- a/benchmarks/hs-criterion/Makefile
+++ b/benchmarks/hs-criterion/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= criterion
-PORTVERSION= 1.1.0.0
+PORTVERSION= 1.2.1.0
CATEGORIES= benchmarks haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,15 +10,17 @@ COMMENT= Robust, reliable performance measurement and analysis
LICENSE= BSD3CLAUSE
-USE_CABAL= aeson>=0.8 ansi-wl-pprint>=0.6.7.2 cassava>=0.3.0.0 \
- Glob>=0.7.2 hastache>=0.6.0 mtl>=2 mwc-random>=0.8.0.3 \
- optparse-applicative>=0.11 parsec>=3.1.0 statistics>=0.13.2.1 \
- text>=0.11 vector>=0.7.1 vector-algorithms>=0.4
+USE_CABAL= aeson ansi-wl-pprint base-compat cassava code-page \
+ exceptions Glob js-flot js-jquery microstache mtl mwc-random \
+ optparse-applicative parsec statistics text transformers-compat \
+ vector vector-algorithms
INSTALL_PORTEXAMPLES= \
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
INSTALL_PORTDATA= ${INSTALL_DATA} ${WRKSRC}/README.markdown ${STAGEDIR}${DATADIR}
+EXECUTABLE= criterion-report
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>