aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/httperf
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-02-02 14:52:51 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-02-02 14:52:51 +0000
commitdf198fc3406d239c43ef49842f1e05706eac9b30 (patch)
treef0e987e273d96c7a00d7439d6c5a6bf55d7bc912 /benchmarks/httperf
parentd478d3c7f450f3a2212c103a41949a3b8d978bf8 (diff)
downloadports-df198fc3406d239c43ef49842f1e05706eac9b30.tar.gz
ports-df198fc3406d239c43ef49842f1e05706eac9b30.zip
Conditionalize libgnugetopt dependencies.
PR: ports/47757 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=74509
Diffstat (limited to 'benchmarks/httperf')
-rw-r--r--benchmarks/httperf/Makefile13
-rw-r--r--benchmarks/httperf/files/patch-lib::Makefile.in11
2 files changed, 19 insertions, 5 deletions
diff --git a/benchmarks/httperf/Makefile b/benchmarks/httperf/Makefile
index b52250718488..97ed230db5bc 100644
--- a/benchmarks/httperf/Makefile
+++ b/benchmarks/httperf/Makefile
@@ -12,17 +12,20 @@ MASTER_SITES= ftp://ftp.hpl.hp.com/pub/httperf/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
-
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= httperf.1
-.if !defined(NOPORTDOCS)
+.if !exists(/usr/include/getopt.h)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
+.endif
+
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ChangeLog NEWS README TODO
${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/benchmarks/httperf/files/patch-lib::Makefile.in b/benchmarks/httperf/files/patch-lib::Makefile.in
new file mode 100644
index 000000000000..1b6cfa626b87
--- /dev/null
+++ b/benchmarks/httperf/files/patch-lib::Makefile.in
@@ -0,0 +1,11 @@
+--- lib/Makefile.in.orig Thu Oct 12 10:04:32 2000
++++ lib/Makefile.in Fri Jan 24 05:57:18 2003
+@@ -27,7 +27,7 @@
+ .c.o:
+ $(COMPILE) $<
+
+-LIBUTIL_OBJS = getopt.o getopt1.o ssl_writev.o
++LIBUTIL_OBJS = ssl_writev.o
+
+ all: libutil.a
+