aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/iozone21
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-06 10:51:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-06 10:51:12 +0000
commit9e33a4d5b182f9f02c85961003cc91897839f60d (patch)
treea8ff5bbbc065253c9b850638e9db2ccef4f89e63 /benchmarks/iozone21
parenta1104d673926083dc57a7b37373f3be9f29ac641 (diff)
downloadports-9e33a4d5b182f9f02c85961003cc91897839f60d.tar.gz
ports-9e33a4d5b182f9f02c85961003cc91897839f60d.zip
- Stage support
Notes
Notes: svn path=/head/; revision=343021
Diffstat (limited to 'benchmarks/iozone21')
-rw-r--r--benchmarks/iozone21/Makefile5
-rw-r--r--benchmarks/iozone21/files/patch-aa8
2 files changed, 6 insertions, 7 deletions
diff --git a/benchmarks/iozone21/Makefile b/benchmarks/iozone21/Makefile
index 13897dc562c5..3036da5a38ec 100644
--- a/benchmarks/iozone21/Makefile
+++ b/benchmarks/iozone21/Makefile
@@ -13,13 +13,12 @@ COMMENT= Performance Test of Sequential File I/O (older version)
CONFLICTS= iozone-3.*
-PLIST_FILES= bin/iozone
+PLIST_FILES= bin/iozone \
+ man/man1/iozone.1.gz
EXTRACT_CMD= ( ${GZCAT} | ${AWK} '{if (/^\#!/) x++} {if(x) print $$0'}| ${SH} )
EXTRACT_BEFORE_ARGS= <
EXTRACT_AFTER_ARGS= # empty
NO_WRKSUBDIR= YES
-MAN1= iozone.1
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/benchmarks/iozone21/files/patch-aa b/benchmarks/iozone21/files/patch-aa
index aaf31dd9cc7c..5b796bbf61ed 100644
--- a/benchmarks/iozone21/files/patch-aa
+++ b/benchmarks/iozone21/files/patch-aa
@@ -9,9 +9,9 @@
+ $(CC) $(CFLAGS) -Dbsd4_3 -DOS_TYPE="\"FreeBSD 2.x\"" -o iozone iozone.c
+
+ install:
-+ -@mkdir -p ${PREFIX}/bin
-+ -@mkdir -p ${PREFIX}/man/man1
-+ ${BSD_INSTALL_PROGRAM} iozone ${PREFIX}/bin
++ -@mkdir -p $(DESTDIR)${PREFIX}/bin
++ -@mkdir -p $(DESTDIR)${PREFIX}/man/man1
++ ${BSD_INSTALL_PROGRAM} iozone $(DESTDIR)${PREFIX}/bin
+ @echo .Dd `/bin/date` > iozone.1
+ @echo .Dt IOZONE 1 >> iozone.1
+ @echo .Sh NAME >> iozone.1
@@ -35,4 +35,4 @@
+ {if (x) print $0}' >>iozone.1
+ @echo .Sh AUTHOR >> iozone.1
+ @echo Bill Norcott >> iozone.1
-+ ${BSD_INSTALL_MAN} iozone.1 ${PREFIX}/man/man1
++ ${BSD_INSTALL_MAN} iozone.1 $(DESTDIR)${PREFIX}/man/man1