aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/iozone
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2006-02-10 10:12:29 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2006-02-10 10:12:29 +0000
commiteb8e70347a09f15e6ef0fced2a9b955fbee95d76 (patch)
treeb19d414eae8c63a2a89ffdfec6d42130e0f84a4d /benchmarks/iozone
parent334811d5ef47fa3a7cc8eef399acf47bea900157 (diff)
downloadports-eb8e70347a09f15e6ef0fced2a9b955fbee95d76.tar.gz
ports-eb8e70347a09f15e6ef0fced2a9b955fbee95d76.zip
Use the right fix (PTHREAD_LIBS) to build on all OS versions.
Eagle eyes: kris
Notes
Notes: svn path=/head/; revision=155636
Diffstat (limited to 'benchmarks/iozone')
-rw-r--r--benchmarks/iozone/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 146c7004f769..047ff0c21b5b 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -27,15 +27,13 @@ ALL_TARGET=
MAN1= iozone.1
PLIST_FILES= bin/iozone
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500000
OPTIONS= THREADS "Enable threading (uses pthreads)" on
-.endif
+
+.include <bsd.port.pre.mk>
.if defined (WITH_THREADS)
-CFLAGS+= -pthread
-MAKE_ENV= LDFLAGS=-lpthread
+CFLAGS+= ${PTHREAD_CFLAGS}
+MAKE_ENV= LDFLAGS=${PTHREAD_LIBS}
.else
CFLAGS+=-DNO_THREADS
.endif