aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/libcelero
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-04-23 17:18:48 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-04-23 17:18:48 +0000
commit6b1f82333831f5d989a3ca246cdd2db16483159c (patch)
tree8767c51e4c3f134db699c489a89d64d3d4a99bd5 /benchmarks/libcelero
parentcb08bca15936aeeedd43ceb0371f94d7ca7c6a66 (diff)
downloadports-6b1f82333831f5d989a3ca246cdd2db16483159c.tar.gz
ports-6b1f82333831f5d989a3ca246cdd2db16483159c.zip
benchmarks/libcelero: fix build on GCC architectures and powerpc64 elfv2
clang 8 doesn't have full support for powerpc, powerpc64 or powerpcspe, so use GCC there. On powerpc64 elfv2, the default is to build for elfv1, so pass a flag to fix it. MFH: 2020Q2 (fix build blanket)
Notes
Notes: svn path=/head/; revision=532697
Diffstat (limited to 'benchmarks/libcelero')
-rw-r--r--benchmarks/libcelero/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/benchmarks/libcelero/Makefile b/benchmarks/libcelero/Makefile
index 7a0db1c43644..09ddb8331f38 100644
--- a/benchmarks/libcelero/Makefile
+++ b/benchmarks/libcelero/Makefile
@@ -14,17 +14,26 @@ LICENSE_FILE= ${WRKSRC}/license.txt
BUILD_DEPENDS= ${LOCALBASE}/include/sys/sysinfo.h:devel/libsysinfo
-USES= cmake localbase:ldflags # compiler:c++11-lang
+USES= cmake compiler localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= DigitalInBlue
GH_PROJECT= Celero
USE_LDCONFIG= yes
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
+USE_GCC= yes
+.else
# workaround for breakage with clang-10: https://github.com/DigitalInBlue/Celero/issues/142
LLVM_VER= 80
BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
CPP= clang-cpp${LLVM_VER}
CC= clang${LLVM_VER}
CXX= clang++${LLVM_VER}
+.if ${ARCH} == powerpc64
+CFLAGS+= -mabi=elfv2
+.endif
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>