aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/libcelero
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-03-29 06:05:47 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-03-29 06:05:47 +0000
commit7fa7e7ccbdd210af4d6b507cc223e9bf5ccd061d (patch)
tree6176294120d6c42f61fb92c5762dd77098e400e2 /benchmarks/libcelero
parentca86f55fa318b0fca049cf5c1cc3a7340c61bcef (diff)
downloadports-7fa7e7ccbdd210af4d6b507cc223e9bf5ccd061d.tar.gz
ports-7fa7e7ccbdd210af4d6b507cc223e9bf5ccd061d.zip
benchmarks/libcelero: Fix build
Fix breakage with clang10 by switching to clang-8: error: loop variable 'udm' of type 'const std::__1::shared_ptr<celero::UserDefinedMeasurement>' creates a copy from type 'const std::__1::shared_ptr<celero::UserDefinedMeasurement>' https://github.com/DigitalInBlue/Celero/issues/142 Reported by: fallout
Notes
Notes: svn path=/head/; revision=529772
Diffstat (limited to 'benchmarks/libcelero')
-rw-r--r--benchmarks/libcelero/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/benchmarks/libcelero/Makefile b/benchmarks/libcelero/Makefile
index 1c01a14720f2..7a0db1c43644 100644
--- a/benchmarks/libcelero/Makefile
+++ b/benchmarks/libcelero/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libcelero
DISTVERSIONPREFIX= v
DISTVERSION= 2.6.0
+PORTREVISION= 1
CATEGORIES= benchmarks
MAINTAINER= yuri@FreeBSD.org
@@ -13,10 +14,17 @@ LICENSE_FILE= ${WRKSRC}/license.txt
BUILD_DEPENDS= ${LOCALBASE}/include/sys/sysinfo.h:devel/libsysinfo
-USES= cmake compiler:c++11-lang localbase:ldflags
+USES= cmake localbase:ldflags # compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= DigitalInBlue
GH_PROJECT= Celero
USE_LDCONFIG= yes
+# workaround for breakage with clang-10: https://github.com/DigitalInBlue/Celero/issues/142
+LLVM_VER= 80
+BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
+CPP= clang-cpp${LLVM_VER}
+CC= clang${LLVM_VER}
+CXX= clang++${LLVM_VER}
+
.include <bsd.port.mk>