aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/libcelero
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-14 05:45:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-14 05:45:10 +0000
commite1cc3cbeb9bdd40452d42e9ffe839fee8a9d80fe (patch)
tree853766126e4e5853bbdc2d03c0a959f3485bc943 /benchmarks/libcelero
parent9551e869aada768a7f17a38cf919c51cf52df703 (diff)
downloadports-e1cc3cbeb9bdd40452d42e9ffe839fee8a9d80fe.tar.gz
ports-e1cc3cbeb9bdd40452d42e9ffe839fee8a9d80fe.zip
New port: benchmarks/libcelero: C++ benchmark authoring library/framework
Notes
Notes: svn path=/head/; revision=482026
Diffstat (limited to 'benchmarks/libcelero')
-rw-r--r--benchmarks/libcelero/Makefile22
-rw-r--r--benchmarks/libcelero/distinfo3
-rw-r--r--benchmarks/libcelero/pkg-descr8
-rw-r--r--benchmarks/libcelero/pkg-plist31
4 files changed, 64 insertions, 0 deletions
diff --git a/benchmarks/libcelero/Makefile b/benchmarks/libcelero/Makefile
new file mode 100644
index 000000000000..bc4b4fcbc870
--- /dev/null
+++ b/benchmarks/libcelero/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= libcelero
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.3.0
+CATEGORIES= benchmarks
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ benchmark authoring library/framework
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+BUILD_DEPENDS= ${LOCALBASE}/include/sys/sysinfo.h:devel/libsysinfo
+
+USES= cmake:outsource compiler:c++11-lang localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= DigitalInBlue
+GH_PROJECT= Celero
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/benchmarks/libcelero/distinfo b/benchmarks/libcelero/distinfo
new file mode 100644
index 000000000000..033aecfcaa13
--- /dev/null
+++ b/benchmarks/libcelero/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539495341
+SHA256 (DigitalInBlue-Celero-v2.3.0_GH0.tar.gz) = 5f8c7121f90856fc69669124697849ba262cef5a1876902fe65542e180945960
+SIZE (DigitalInBlue-Celero-v2.3.0_GH0.tar.gz) = 103446
diff --git a/benchmarks/libcelero/pkg-descr b/benchmarks/libcelero/pkg-descr
new file mode 100644
index 000000000000..401ce090c39d
--- /dev/null
+++ b/benchmarks/libcelero/pkg-descr
@@ -0,0 +1,8 @@
+Celero aims to be a small library which can be added to a C++ project and
+perform benchmarks on code in a way which is easy to reproduce, share, and
+compare among individual runs, developers, or projects. Celero uses a framework
+similar to that of GoogleTest to make its API easier to use and integrate into a
+project. Make automated benchmarking as much a part of your development process
+as automated testing.
+
+WWW: https://github.com/DigitalInBlue/Celero
diff --git a/benchmarks/libcelero/pkg-plist b/benchmarks/libcelero/pkg-plist
new file mode 100644
index 000000000000..b9a9ece847b7
--- /dev/null
+++ b/benchmarks/libcelero/pkg-plist
@@ -0,0 +1,31 @@
+include/celero/Archive.h
+include/celero/Benchmark.h
+include/celero/Callbacks.h
+include/celero/Celero.h
+include/celero/CommandLine.h
+include/celero/Console.h
+include/celero/Distribution.h
+include/celero/Exceptions.h
+include/celero/Executor.h
+include/celero/Experiment.h
+include/celero/ExperimentResult.h
+include/celero/Export.h
+include/celero/Factory.h
+include/celero/FileReader.h
+include/celero/GenericFactory.h
+include/celero/JUnit.h
+include/celero/Memory.h
+include/celero/Pimpl.h
+include/celero/PimplImpl.h
+include/celero/Print.h
+include/celero/ResultTable.h
+include/celero/Statistics.h
+include/celero/TestFixture.h
+include/celero/TestVector.h
+include/celero/ThreadLocal.h
+include/celero/ThreadTestFixture.h
+include/celero/Timer.h
+include/celero/Utilities.h
+lib/libcelero.so
+share/celero-target-%%CMAKE_BUILD_TYPE%%.cmake
+share/celero-target.cmake