aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/linux-vdbench
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2019-07-10 14:40:02 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2019-07-10 14:40:02 +0000
commit7003875294fc8b811ffe452c376f66a855494f60 (patch)
tree9754e52797ffd2ab1caf7b83b3fa360ba5db8a85 /benchmarks/linux-vdbench
parentb3ec6fb0fe1868f49bc3ae82909a818a4d043678 (diff)
downloadports-7003875294fc8b811ffe452c376f66a855494f60.tar.gz
ports-7003875294fc8b811ffe452c376f66a855494f60.zip
On amd64 adding DEFAULT_VERSIONS+=linux=c6 to /etc/make.conf made Linux
infrastructure ports (linux_base-c6 and linux-c6*) install i386 CentOS 6 packages. Using c6_64 instead of c6 made them install mixed amd64/i386 CentOS 6 packages and allowed Linux application ports to install amd64 binaries when available. The i386-only configuration was only useful for users of x11/nvidia-driver* which didn't provide Linux amd64 emulation until recently. With x11/nvidia-driver* now supporting Linux amd64 there's no longer a need for i386-only Linux on amd64. Let DEFAULT_VERSIONS+=linux=c6 make Linux infrastructure ports install mixed amd64/i386 CentOS 6 packages, like c6_64 before, and remove support for c6_64 as a value. Replace LINUX_ARCH with ARCH everywhere because they are always the same now.
Notes
Notes: svn path=/head/; revision=506352
Diffstat (limited to 'benchmarks/linux-vdbench')
-rw-r--r--benchmarks/linux-vdbench/Makefile16
-rw-r--r--benchmarks/linux-vdbench/pkg-plist3
2 files changed, 7 insertions, 12 deletions
diff --git a/benchmarks/linux-vdbench/Makefile b/benchmarks/linux-vdbench/Makefile
index f8a9a5a0af65..010628f4d1aa 100644
--- a/benchmarks/linux-vdbench/Makefile
+++ b/benchmarks/linux-vdbench/Makefile
@@ -25,6 +25,7 @@ EXTRACT_AFTER_ARGS= -d ${WRKSRC}
JAVA_VERSION= 1.7+
JAVA_OS= linux
NO_BUILD= yes
+PLIST_SUB= LINUX_ARCH=${LINUX_ARCH}
SHEBANG_FILES= ${PORTNAME} linux/config.sh
bash_CMD= ${SH}
@@ -38,12 +39,12 @@ DOWNLOAD_URL= https://www.oracle.com/technetwork/server-storage/vdbench-download
IGNORE=You must manually download ${DISTFILES} from ${DOWNLOAD_URL} and place it in ${DISTDIR} then run make again
.endif
-.if ${LINUX_ARCH} == "i386"
-PLIST_SUB+= LINUX_ARCH_32="" LINUX_ARCH_64="@comment "
+.if ${ARCH} == i386
+LINUX_ARCH= 32
.endif
-.if ${LINUX_ARCH} == "x86_64"
-PLIST_SUB+= LINUX_ARCH_32="@comment " LINUX_ARCH_64=""
+.if ${ARCH} == amd64
+LINUX_ARCH= 64
.endif
post-patch:
@@ -59,12 +60,7 @@ do-install:
for f in vdbench.jar build_sds.txt swatcharts.txt; do \
${INSTALL_DATA} ${WRKSRC}/$${f} ${STAGEDIR}${DATADIR}; \
done
-.if ${LINUX_ARCH} == "i386"
- ${INSTALL_DATA} ${WRKSRC}/linux/linux32.so ${STAGEDIR}${DATADIR}/linux
-.endif
-.if ${LINUX_ARCH} == "x86_64"
- ${INSTALL_DATA} ${WRKSRC}/linux/linux64.so ${STAGEDIR}${DATADIR}/linux
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/linux/linux${LINUX_ARCH}.so ${STAGEDIR}${DATADIR}/linux
${INSTALL_SCRIPT} ${WRKSRC}/linux/config.sh ${STAGEDIR}${DATADIR}/linux
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${DATADIR}
${RLN} ../${DATADIR_REL}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/benchmarks/linux-vdbench/pkg-plist b/benchmarks/linux-vdbench/pkg-plist
index 193fb021d9bc..74d9e5a87185 100644
--- a/benchmarks/linux-vdbench/pkg-plist
+++ b/benchmarks/linux-vdbench/pkg-plist
@@ -39,8 +39,7 @@ bin/linux-vdbench
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/raw/seq_write_xfersizes
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/raw/tpcc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/readme.txt
-%%LINUX_ARCH_32%%%%DATADIR%%/linux/linux32.so
-%%LINUX_ARCH_64%%%%DATADIR%%/linux/linux64.so
+%%DATADIR%%/linux/linux%%LINUX_ARCH%%.so
%%DATADIR%%/build_sds.txt
%%DATADIR%%/linux/config.sh
%%DATADIR%%/swatcharts.txt