aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/nbench
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-03-27 12:26:47 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-03-27 12:26:47 +0000
commit1af771fdf0dc3b140ebdba225bc46e212b580e86 (patch)
tree55f1f6728e8501d5fedfda72e6241d005efc4a1a /benchmarks/nbench
parent9487b7a5a838408f103553cd0a4e2c1db77db7a3 (diff)
downloadports-1af771fdf0dc3b140ebdba225bc46e212b580e86.tar.gz
ports-1af771fdf0dc3b140ebdba225bc46e212b580e86.zip
Import nbench port. nbench are BYTE magazine's native benchmarks.
Don't ask me how this differs from bytebench, but it seems to be different enough to warrant a seperate port. PR: 5330 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=10331
Diffstat (limited to 'benchmarks/nbench')
-rw-r--r--benchmarks/nbench/Makefile29
-rw-r--r--benchmarks/nbench/distinfo1
-rw-r--r--benchmarks/nbench/files/patch-aa11
-rw-r--r--benchmarks/nbench/files/patch-ab17
-rw-r--r--benchmarks/nbench/pkg-comment1
-rw-r--r--benchmarks/nbench/pkg-descr3
-rw-r--r--benchmarks/nbench/pkg-plist8
7 files changed, 70 insertions, 0 deletions
diff --git a/benchmarks/nbench/Makefile b/benchmarks/nbench/Makefile
new file mode 100644
index 000000000000..4a6b9dfad7b0
--- /dev/null
+++ b/benchmarks/nbench/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: nbench
+# Version required: 2.1
+# Date created: 17 December 1997
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= nbench-byte-2.1
+PKGNAME= nbench-2.1
+CATEGORIES= benchmarks
+MASTER_SITES= ftp://ftp.tux.org/pub/tux/mayer/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= system/benchmark
+
+MAINTAINER= andy@icc.surw.chel.su
+
+ALL_TARGET=
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/nbench ${PREFIX}/bin
+ @ ${MKDIR} ${PREFIX}/share/nbench
+ @ ${INSTALL_DATA} ${WRKSRC}/NNET.DAT ${PREFIX}/share/nbench
+ @ ${MKDIR} ${PREFIX}/share/doc/nbench
+.for file in README README.submit RESULTS bdoc.txt
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/nbench
+.endfor
+
+.include <bsd.port.mk>
diff --git a/benchmarks/nbench/distinfo b/benchmarks/nbench/distinfo
new file mode 100644
index 000000000000..aba451c30ba6
--- /dev/null
+++ b/benchmarks/nbench/distinfo
@@ -0,0 +1 @@
+MD5 (nbench-byte-2.1.tar.gz) = 18741c3f7d01bf216a57c0132896b196
diff --git a/benchmarks/nbench/files/patch-aa b/benchmarks/nbench/files/patch-aa
new file mode 100644
index 000000000000..e065dcf4b2c4
--- /dev/null
+++ b/benchmarks/nbench/files/patch-aa
@@ -0,0 +1,11 @@
+--- nbench1.h Thu Dec 11 20:54:46 1997
++++ /home/andy/tmp/wrk/nbench1.h Wed Dec 17 08:28:11 1997
+@@ -352,7 +352,7 @@
+ ** The Neural Net test requires an input data file.
+ ** The name is specified here.
+ */
+-char *inpath="NNET.DAT";
++char *inpath="/usr/local/share/nbench/NNET.DAT";
+
+ /*
+ ** PROTOTYPES
diff --git a/benchmarks/nbench/files/patch-ab b/benchmarks/nbench/files/patch-ab
new file mode 100644
index 000000000000..41cd28c1b01c
--- /dev/null
+++ b/benchmarks/nbench/files/patch-ab
@@ -0,0 +1,17 @@
+--- sysinfo.sh Thu Dec 11 20:54:46 1997
++++ /home/andy/tmp/wrk/sysinfo.sh Wed Dec 17 08:30:28 1997
+@@ -50,8 +50,8 @@
+
+ # this bombs out on Ultrix which expect "cut -d"
+
+-compsystem=`uname -a | cut -b 1-78`
+-compdate=`date|cut -b1-55`
++compsystem=`uname -a | cut -f 1-78`
++compdate=`date | cut -f 1-55`
+
+ # let's hope that ctrl-c is not part of any string here
+ # this also will barf later if " is in any of the strings
+@@ -60,4 +60,4 @@
+ sed -e "s%CCVERSION%$gccversion" -e "s%LIBCVERSION%$libcversion"\
+ -e "s%SYSTEM%$compsystem" -e "s%DATE%$compdate"\
+ ${i}.template > $i
diff --git a/benchmarks/nbench/pkg-comment b/benchmarks/nbench/pkg-comment
new file mode 100644
index 000000000000..275cc403e78f
--- /dev/null
+++ b/benchmarks/nbench/pkg-comment
@@ -0,0 +1 @@
+BYTE Magazine's native benchmarks
diff --git a/benchmarks/nbench/pkg-descr b/benchmarks/nbench/pkg-descr
new file mode 100644
index 000000000000..5f6ae2f57145
--- /dev/null
+++ b/benchmarks/nbench/pkg-descr
@@ -0,0 +1,3 @@
+ BYTE Magazine's native benchmarks (also called BYTEmark)
+designed to expose the capabilities of a system's CPU, FPU,
+and memory system.
diff --git a/benchmarks/nbench/pkg-plist b/benchmarks/nbench/pkg-plist
new file mode 100644
index 000000000000..2ae5879250ab
--- /dev/null
+++ b/benchmarks/nbench/pkg-plist
@@ -0,0 +1,8 @@
+bin/nbench
+share/nbench/NNET.DAT
+share/doc/nbench/README
+share/doc/nbench/README.submit
+share/doc/nbench/RESULTS
+share/doc/nbench/bdoc.txt
+@dirrm share/nbench
+@dirrm share/doc/nbench