aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/nbench
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-08-01 23:37:02 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-08-01 23:37:02 +0000
commitef2ecca4b33f18228c45309c5786d61702ca9a18 (patch)
tree1b448ac3ad6529f1b9c4a26e2cced12062e7632d /benchmarks/nbench
parent128571445c5cb63ed311d34326c973ce22e5057f (diff)
downloadports-ef2ecca4b33f18228c45309c5786d61702ca9a18.tar.gz
ports-ef2ecca4b33f18228c45309c5786d61702ca9a18.zip
- Support PREFIX/CC/CFLAGS properly
- Support NOPORTDOCS - Add WWW: line into pkg/DESCR PR: 20148 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=31220
Diffstat (limited to 'benchmarks/nbench')
-rw-r--r--benchmarks/nbench/Makefile28
-rw-r--r--benchmarks/nbench/files/patch-aa6
-rw-r--r--benchmarks/nbench/files/patch-ac11
-rw-r--r--benchmarks/nbench/files/patch-ad15
-rw-r--r--benchmarks/nbench/pkg-descr2
5 files changed, 46 insertions, 16 deletions
diff --git a/benchmarks/nbench/Makefile b/benchmarks/nbench/Makefile
index 66d436e9bd89..a87d277fb0fb 100644
--- a/benchmarks/nbench/Makefile
+++ b/benchmarks/nbench/Makefile
@@ -5,25 +5,27 @@
# $FreeBSD$
#
-PORTNAME= nbench
-PORTVERSION= 2.1
-CATEGORIES= benchmarks
-MASTER_SITES= ftp://ftp.tux.org/pub/tux/mayer/ \
- ${MASTER_SITE_SUNSITE}
+PORTNAME= nbench
+PORTVERSION= 2.1
+CATEGORIES= benchmarks
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ ftp://ftp.tux.org/pub/tux/mayer/
MASTER_SITE_SUBDIR= system/benchmark
-DISTNAME= nbench-byte-2.1
+DISTNAME= ${PORTNAME}-byte-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-ALL_TARGET=
+ALL_TARGET= # empty
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/nbench ${PREFIX}/bin
- @ ${MKDIR} ${PREFIX}/share/nbench
- @ ${INSTALL_DATA} ${WRKSRC}/NNET.DAT ${PREFIX}/share/nbench
- @ ${MKDIR} ${PREFIX}/share/doc/nbench
+ ${INSTALL_PROGRAM} ${WRKSRC}/nbench ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/nbench
+ ${INSTALL_DATA} ${WRKSRC}/NNET.DAT ${PREFIX}/share/nbench
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/nbench
.for file in README README.submit RESULTS bdoc.txt
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/nbench
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/nbench
.endfor
+.endif
.include <bsd.port.mk>
diff --git a/benchmarks/nbench/files/patch-aa b/benchmarks/nbench/files/patch-aa
index e065dcf4b2c4..f7c039a96eb1 100644
--- a/benchmarks/nbench/files/patch-aa
+++ b/benchmarks/nbench/files/patch-aa
@@ -1,11 +1,11 @@
---- nbench1.h Thu Dec 11 20:54:46 1997
-+++ /home/andy/tmp/wrk/nbench1.h Wed Dec 17 08:28:11 1997
+--- nbench1.h.orig Thu Dec 11 20:54:46 1997
++++ nbench1.h Wed Dec 17 08:28:11 1997
@@ -352,7 +352,7 @@
** The Neural Net test requires an input data file.
** The name is specified here.
*/
-char *inpath="NNET.DAT";
-+char *inpath="/usr/local/share/nbench/NNET.DAT";
++char *inpath=DATADIR "NNET.DAT";
/*
** PROTOTYPES
diff --git a/benchmarks/nbench/files/patch-ac b/benchmarks/nbench/files/patch-ac
new file mode 100644
index 000000000000..c31eeaa16564
--- /dev/null
+++ b/benchmarks/nbench/files/patch-ac
@@ -0,0 +1,11 @@
+--- sysspec.h.orig Fri Dec 12 05:54:46 1997
++++ sysspec.h Tue Jul 25 02:30:29 2000
+@@ -33,7 +33,7 @@
+
+ #include "nmglobal.h"
+
+-#ifndef MAC
++#if !defined(MAC) && !defined(__STDC__)
+ #include <malloc.h>
+ #endif
+
diff --git a/benchmarks/nbench/files/patch-ad b/benchmarks/nbench/files/patch-ad
new file mode 100644
index 000000000000..01a8c8dcd411
--- /dev/null
+++ b/benchmarks/nbench/files/patch-ad
@@ -0,0 +1,15 @@
+--- Makefile.orig Fri Dec 12 05:54:46 1997
++++ Makefile Tue Jul 25 02:27:40 2000
+@@ -22,10 +22,10 @@
+ # you should leave -static in the CFLAGS so that your sysinfo can be
+ # compiled into the executable
+
+-CC = gcc
++CC ?= gcc
+
+ # generic options for gcc
+-CFLAGS = -s -static -Wall -O3
++CFLAGS += -static -DDATADIR=\"${PREFIX}/share/nbench/\"
+
+ # if your gcc lets you do it, then try this one
+ #CFLAGS = -s -static -Wall -O3 -fomit-frame-pointer -funroll-loops
diff --git a/benchmarks/nbench/pkg-descr b/benchmarks/nbench/pkg-descr
index fba3ca2051ae..f02ca03bc82b 100644
--- a/benchmarks/nbench/pkg-descr
+++ b/benchmarks/nbench/pkg-descr
@@ -1,3 +1,5 @@
BYTE Magazine's native benchmarks (also called BYTEmark), which are
designed to expose the capabilities of a system's CPU, FPU, and memory
system.
+
+WWW: http://www.tux.org/~mayer/linux/bmark.html