aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/netperf
diff options
context:
space:
mode:
authorMarius Strobl <marius@FreeBSD.org>2015-10-20 20:43:43 +0000
committerMarius Strobl <marius@FreeBSD.org>2015-10-20 20:43:43 +0000
commit4cd4a909063ea4897d0c818d51fa4721079686fa (patch)
tree48fe79c293bc94506dc29d41ec7000d52a6d52b6 /benchmarks/netperf
parent84cb5553e9be9599c61d09e1ab58834a81541064 (diff)
downloadports-4cd4a909063ea4897d0c818d51fa4721079686fa.tar.gz
ports-4cd4a909063ea4897d0c818d51fa4721079686fa.zip
- Update to 2.7.0.
- Add an EXAMPLES knob. - Unbreak CPU utilization measurement support for FreeBSD >= 10 [1], unbreak SCTP support for FreeBSD >= 10. PR: 203752 [1]
Notes
Notes: svn path=/head/; revision=399880
Diffstat (limited to 'benchmarks/netperf')
-rw-r--r--benchmarks/netperf/Makefile24
-rw-r--r--benchmarks/netperf/distinfo4
-rw-r--r--benchmarks/netperf/files/patch-bloat.sh34
-rw-r--r--benchmarks/netperf/files/patch-configure17
-rw-r--r--benchmarks/netperf/files/patch-netcpu_sysctl.c11
-rw-r--r--benchmarks/netperf/files/patch-nettest_unix.c10
-rw-r--r--benchmarks/netperf/files/patch-runemomni.sh74
-rw-r--r--benchmarks/netperf/files/patch-runemomniagg2.sh69
-rw-r--r--benchmarks/netperf/files/patch-runemomniaggdemo.sh11
-rw-r--r--benchmarks/netperf/pkg-plist22
10 files changed, 240 insertions, 36 deletions
diff --git a/benchmarks/netperf/Makefile b/benchmarks/netperf/Makefile
index 2086a00d7e52..9715b480238d 100644
--- a/benchmarks/netperf/Makefile
+++ b/benchmarks/netperf/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= netperf
-PORTVERSION= 2.6.0
-PORTREVISION= 3
+PORTVERSION= 2.7.0
CATEGORIES= benchmarks ipv6
MASTER_SITES= ftp://ftp.netperf.org/netperf/ \
http://fossies.org/unix/misc/
@@ -11,14 +10,14 @@ MASTER_SITES= ftp://ftp.netperf.org/netperf/ \
MAINTAINER= marius@FreeBSD.org
COMMENT= Network performance benchmarking package
-OPTIONS_DEFINE= OMNI SCTP SOCKETS HISTOGRAM EXS
+OPTIONS_DEFINE= EXAMPLES EXS HISTOGRAM OMNI SCTP SOCKETS
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+EXS_DESC= Enable ICSC async socket support
+HISTOGRAM_DESC= Enable optional histogram output
OMNI_DESC= Enable OMNI tests
SCTP_DESC= Enable SCTP support
SOCKETS_DESC= Enable Unix Domain socket support
-HISTOGRAM_DESC= Enable optional histogram output
-EXS_DESC= Enable ICSC async socket support
USE_CSTD= gnu89
GNU_CONFIGURE= yes
@@ -28,19 +27,20 @@ CONFIGURE_ARGS= --program-prefix="" --program-suffix="" --enable-dirty \
INFO= netperf
-SOCKETS_CONFIGURE_ENABLE= unixdomain
-SCTP_CONFIGURE_ENABLE= sctp
-EXS_CONFIGURE_ENABLE= exs
HISTOGRAM_CONFIGURE_ENABLE= histogram
+EXS_CONFIGURE_ENABLE= exs
OMNI_CONFIGURE_ENABLE= omni
+SOCKETS_CONFIGURE_ENABLE= unixdomain
+SCTP_CONFIGURE_ENABLE= sctp
-SCRIPTS= arr_script packet_byte_script sctp_stream_script snapshot_script \
- tcp_range_script tcp_rr_script tcp_stream_script udp_rr_script \
- udp_stream_script
+SCRIPTS= arr_script bloat.sh packet_byte_script runemomni.sh \
+ runemomniagg2.sh runemomniaggdemo.sh sctp_stream_script \
+ snapshot_script tcp_range_script tcp_rr_script \
+ tcp_stream_script udp_rr_script udp_stream_script
post-patch:
.for i in ${SCRIPTS}
- @${REINPLACE_CMD} -e 's^%%PREFIX%%^${PREFIX}^' ${WRKSRC}/doc/examples/$i
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/doc/examples/$i
.endfor
post-install:
diff --git a/benchmarks/netperf/distinfo b/benchmarks/netperf/distinfo
index 0e355d3bb32d..2076ab6179e1 100644
--- a/benchmarks/netperf/distinfo
+++ b/benchmarks/netperf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (netperf-2.6.0.tar.gz) = 8eda5aa348ed9ea3ffd99b45ab2d860ffdde09f2f6faeab64fa52f12ebe17a33
-SIZE (netperf-2.6.0.tar.gz) = 1308763
+SHA256 (netperf-2.7.0.tar.gz) = 9170c4758463bc5342dcdbfc88a40b586fcc9d7ccca048ecbb3b2d49387a28b9
+SIZE (netperf-2.7.0.tar.gz) = 1299801
diff --git a/benchmarks/netperf/files/patch-bloat.sh b/benchmarks/netperf/files/patch-bloat.sh
new file mode 100644
index 000000000000..32a55dee4707
--- /dev/null
+++ b/benchmarks/netperf/files/patch-bloat.sh
@@ -0,0 +1,34 @@
+--- doc/examples/bloat.sh.orig 2012-10-05 02:25:19.000000000 +0200
++++ doc/examples/bloat.sh 2015-10-19 15:18:22.392273000 +0200
+@@ -3,12 +3,7 @@
+ # buffer bloat on latency. We assume that netperf has been compiled
+ # with demo-mode enabled via ./configure --enable-demo
+
+-NETPERF=`which netperf`
+-if [ $? -ne 0 ]
+-then
+- echo "Unable to find a netperf binary."
+- exit -1
+-fi
++NETPERF="%%PREFIX%%/bin/netperf"
+
+ CHUNK=60
+
+@@ -20,7 +15,7 @@
+ # in more accurate demo intervals once the STREAM test kicks-in, but a
+ # somewhat lower transaction rate. not unlike enabling histogram
+ # mode.
+-netperf -H $1 -l 7200 -t TCP_RR -D -0.5 -v 2 -- -r 1 2>&1 > netperf_rr.out &
++$NETPERF -H $1 -l 7200 -t TCP_RR -D -0.5 -v 2 -- -r 1 2>&1 > netperf_rr.out &
+
+ # sleep CHUNK seconds
+ sleep $CHUNK
+@@ -29,7 +24,7 @@
+
+ STREAM_START=`date +%s`
+ echo "Starting netperf TCP_STREAM test at $STREAM_START" | tee -a bloat.log
+-netperf -H $1 -l `expr $CHUNK \* 2` -t TCP_STREAM -D 0.25 -v 2 -- -m 1K 2>&1 > netperf_stream.out
++$NETPERF -H $1 -l `expr $CHUNK \* 2` -t TCP_STREAM -D 0.25 -v 2 -- -m 1K 2>&1 > netperf_stream.out
+ STREAM_STOP=`date +%s`
+ echo "Netperf TCP_STREAM test stopped at $STREAM_STOP" | tee -a bloat.log
+
diff --git a/benchmarks/netperf/files/patch-configure b/benchmarks/netperf/files/patch-configure
index 1003cd1fca47..49d35272d24b 100644
--- a/benchmarks/netperf/files/patch-configure
+++ b/benchmarks/netperf/files/patch-configure
@@ -1,29 +1,20 @@
--- ./configure.orig 2012-05-12 07:05:20.000000000 +1000
+++ ./configure 2012-05-12 07:22:49.000000000 +1000
-@@ -6594,7 +6594,7 @@
+@@ -6567,7 +6567,7 @@
done
case "$host" in
- *-*-freebsd78.*)
-+ *-*-freebsd[7-9].*)
++ *-*-freebsd[7-9].* | *-*-freebsd[1-9][0-9].*)
# FreeBSD 7.x and later SCTP support doesn't need -lsctp.
;;
*)
-@@ -7169,7 +7169,7 @@
+@@ -7142,7 +7142,7 @@
enable_cpuutil="kstat - auto"
NETCPU_SOURCE="kstat"
;;
- *-*-freebsd[4-8].* | *-*-netbsd[1-9].* )
-+ *-*-freebsd[4-9].* | *-*-netbsd[1-9].* )
++ *-*-freebsd[4-9].* | *-*-freebsd[1-9][0-9].* | *-*-netbsd[1-9].* )
use_cpuutil=true
$as_echo "#define USE_SYSCTL /**/" >>confdefs.h
-@@ -7238,7 +7238,7 @@
- enable_rtlookup="rtmget - auto"
- NETRTLKUP_SOURCE="rtmget"
- ;;
-- *-*-freebsd[4-8].* | *-*-darwin*)
-+ *-*-freebsd[4-9].* | *-*-darwin*)
- use_rtlookup=true
- enable_rtlookup="rtmget - auto"
- NETRTLKUP_SOURCE="rtmget"
diff --git a/benchmarks/netperf/files/patch-netcpu_sysctl.c b/benchmarks/netperf/files/patch-netcpu_sysctl.c
new file mode 100644
index 000000000000..cf96284de13d
--- /dev/null
+++ b/benchmarks/netperf/files/patch-netcpu_sysctl.c
@@ -0,0 +1,11 @@
+--- src/netcpu_sysctl.c.orig 2014-06-04 01:37:37.000000000 +0200
++++ src/netcpu_sysctl.c 2015-10-19 16:05:51.583777000 +0200
+@@ -6,6 +6,8 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <unistd.h>
+
+ #if HAVE_INTTYPES_H
diff --git a/benchmarks/netperf/files/patch-nettest_unix.c b/benchmarks/netperf/files/patch-nettest_unix.c
new file mode 100644
index 000000000000..fb6e6b3b21de
--- /dev/null
+++ b/benchmarks/netperf/files/patch-nettest_unix.c
@@ -0,0 +1,10 @@
+--- src/nettest_unix.c.orig 2012-06-19 22:35:37.000000000 +0200
++++ src/nettest_unix.c 2015-10-19 16:15:15.347526000 +0200
+@@ -2714,7 +2714,6 @@
+ that sort of rot... */
+
+ #ifdef WANT_INTERVALS
+- kept_times[MAX_KEPT_TIMES] = 0;
+ time_index = 0;
+ while (time_index < MAX_KEPT_TIMES) {
+ if (kept_times[time_index] > 0) {
diff --git a/benchmarks/netperf/files/patch-runemomni.sh b/benchmarks/netperf/files/patch-runemomni.sh
new file mode 100644
index 000000000000..939f3508fa25
--- /dev/null
+++ b/benchmarks/netperf/files/patch-runemomni.sh
@@ -0,0 +1,74 @@
+--- doc/examples/runemomni.sh.orig 2011-07-28 22:35:06.000000000 +0200
++++ doc/examples/runemomni.sh 2015-10-19 15:22:10.484922000 +0200
+@@ -1,6 +1,8 @@
+ # a script to run a set of single-instance netperf tests
+ # between two machines
+
++NETPERF="%%PREFIX%%/bin/netperf"
++
+ # the length in seconds of each test iteration. the actual
+ # run time will then be somewhere between that times min
+ # and max iteration for confidence intervals
+@@ -81,7 +83,7 @@
+ fi
+ for j in $set
+ do
+- netperf $HDR -T $i,$j -t omni -c -C -H $control_host -l $length $confidence -- $CSV -H $data -m 64K;HDR="-P 0";
++ $NETPERF $HDR -T $i,$j -t omni -c -C -H $control_host -l $length $confidence -- $CSV -H $data -m 64K;HDR="-P 0";
+ done
+ done
+ fi
+@@ -100,7 +102,7 @@
+ fi
+ for j in $set
+ do
+- netperf $HDR -T $i,$j -t omni -c -C -H $control_host -l $length $confidence -- $CSV -H $data -s 1M -S 1M -m 64K;HDR="-P 0";
++ $NETPERF $HDR -T $i,$j -t omni -c -C -H $control_host -l $length $confidence -- $CSV -H $data -s 1M -S 1M -m 64K;HDR="-P 0";
+ done
+ done
+ fi
+@@ -119,7 +121,7 @@
+ fi
+ for j in $set
+ do
+- netperf $HDR -T $i,$j -t omni -f m -c -C -H $control_host -l $length $confidence -- $CSV -H $data -s 1M -S 1M -r 64K -b 12; HDR="-P 0";
++ $NETPERF $HDR -T $i,$j -t omni -f m -c -C -H $control_host -l $length $confidence -- $CSV -H $data -s 1M -S 1M -r 64K -b 12; HDR="-P 0";
+ done
+ done
+ fi
+@@ -138,7 +140,7 @@
+ fi
+ for j in $set
+ do
+- netperf $HDR -T $i,$j -t omni -c -C -H $control_host -l $length $confidence -- $CSV -H $data -r 1; HDR="-P 0";
++ $NETPERF $HDR -T $i,$j -t omni -c -C -H $control_host -l $length $confidence -- $CSV -H $data -r 1; HDR="-P 0";
+ done
+ done
+ fi
+@@ -151,7 +153,7 @@
+ do
+ for req in $reqs; do
+ for burst in $bursts; do
+- netperf $HDR -T $i -t omni -f m -c -C -H $control_host -l $length $confidence -- $CSV -H $data -s 1M -S 1M -r $req -b $burst -D;HDR=-"P 0";
++ $NETPERF $HDR -T $i -t omni -f m -c -C -H $control_host -l $length $confidence -- $CSV -H $data -s 1M -S 1M -r $req -b $burst -D;HDR=-"P 0";
+ done
+ done
+ done
+@@ -165,7 +167,7 @@
+ do
+ for req in $reqs; do
+ for burst in $bursts; do
+- netperf $HDR -T $i -t omni -f m -c -C -H $control_host -l $length $confidence -- $CSV -H $data -s 1M -S 1M -r $req -b $burst -T udp;HDR=-"P 0";
++ $NETPERF $HDR -T $i -t omni -f m -c -C -H $control_host -l $length $confidence -- $CSV -H $data -s 1M -S 1M -r $req -b $burst -T udp;HDR=-"P 0";
+ done
+ done
+ done
+@@ -180,7 +182,7 @@
+ for i in $netperf_CPUs
+ do
+ for req in $reqs; do
+- netperf $HDR -T $i -t omni -f m -c -C -H $control_host -l $length $confidence -- $CSV -H $data -s 1M -S 1M -m $req -T udp;HDR=-"P 0";
++ $NETPERF $HDR -T $i -t omni -f m -c -C -H $control_host -l $length $confidence -- $CSV -H $data -s 1M -S 1M -m $req -T udp;HDR=-"P 0";
+ done
+ done
+ fi
diff --git a/benchmarks/netperf/files/patch-runemomniagg2.sh b/benchmarks/netperf/files/patch-runemomniagg2.sh
new file mode 100644
index 000000000000..e39d00419b0a
--- /dev/null
+++ b/benchmarks/netperf/files/patch-runemomniagg2.sh
@@ -0,0 +1,69 @@
+--- doc/examples/runemomniagg2.sh.orig 2011-07-28 20:37:22.000000000 +0200
++++ doc/examples/runemomniagg2.sh 2015-10-19 15:35:43.704236000 +0200
+@@ -1,4 +1,7 @@
+ #set -x
++
++NETPERF="%%PREFIX%%/bin/netperf"
++
+ # edit and add to this array as necessary
+ # the hosts you will use should be contiguous
+ # starting at index zero
+@@ -84,11 +87,11 @@
+ echo TCP_STREAM
+ for i in $concurrent_sessions; do
+ j=0;
+- NETUUID=`netperf -t uuid`;
++ NETUUID=`$NETPERF -t uuid`;
+ echo $i concurrent streams id $NETUUID;
+ while [ $j -lt $i ]; do
+ client=`expr $j % $num_cli` ;
+- netperf $HDR -t omni -c -C -H ${remote_hosts[$client]} -l $length $confidence -- $CSV -H ${remote_hosts[$client]} $socket_sizes -m 64K -u $NETUUID & HDR="-P 0";
++ $NETPERF $HDR -t omni -c -C -H ${remote_hosts[$client]} -l $length $confidence -- $CSV -H ${remote_hosts[$client]} $socket_sizes -m 64K -u $NETUUID & HDR="-P 0";
+ j=`expr $j + 1`;
+ done;
+ wait;
+@@ -99,11 +102,11 @@
+ echo TCP_MAERTS
+ for i in $concurrent_sessions; do
+ j=0;
+- NETUUID=`netperf -t uuid`;
++ NETUUID=`$NETPERF -t uuid`;
+ echo $i concurrent streams id $NETUUID;
+ while [ $j -lt $i ]; do
+ client=`expr $j % $num_cli` ;
+- netperf $HDR -t omni -c -C -H ${remote_hosts[$client]} -l $length $confidence -- $CSV -H ${remote_hosts[$client]} $socket_sizes -M ,64K -u $NETUUID & HDR="-P 0";
++ $NETPERF $HDR -t omni -c -C -H ${remote_hosts[$client]} -l $length $confidence -- $CSV -H ${remote_hosts[$client]} $socket_sizes -M ,64K -u $NETUUID & HDR="-P 0";
+ j=`expr $j + 1`;
+ done;
+ wait;
+@@ -115,11 +118,11 @@
+ HDR="-P 1"
+ for i in $concurrent_sessions;
+ do j=0;
+- NETUUID=`netperf -t uuid`;
++ NETUUID=`$NETPERF -t uuid`;
+ echo $i concurrent streams id $NETUUID;
+ while [ $j -lt $i ]; do
+ client=`expr $j % $num_cli` ;
+- netperf $HDR -t omni -f m -c -C -H ${remote_hosts[$client]} -l $length $confidence -- $CSV -H ${remote_hosts[$client]} -s 1M -S 1M -r 64K -b 12 -u $NETUUID & HDR="-P 0";
++ $NETPERF $HDR -t omni -f m -c -C -H ${remote_hosts[$client]} -l $length $confidence -- $CSV -H ${remote_hosts[$client]} -s 1M -S 1M -r 64K -b 12 -u $NETUUID & HDR="-P 0";
+ j=`expr $j + 1`;
+ done;
+ wait;
+@@ -130,14 +133,14 @@
+ echo TCP_RR aggregates
+ HDR="-P 1"
+ for i in $concurrent_sessions; do
+- NETUUID=`netperf -t uuid`;
++ NETUUID=`$NETPERF -t uuid`;
+ echo $i concurrent streams id $NETUUID;
+ for b in $burst_sizes; do
+ echo burst of $b;
+ j=0;
+ while [ $j -lt $i ]; do
+ client=`expr $j % $num_cli` ;
+- netperf $HDR -t omni -f x -c -C -H ${remote_hosts[$client]} -l $length $confidence -- $CSV -H ${remote_hosts[$client]} -r 1 -b $b -D -u $NETUUID & HDR="-P 0";
++ $NETPERF $HDR -t omni -f x -c -C -H ${remote_hosts[$client]} -l $length $confidence -- $CSV -H ${remote_hosts[$client]} -r 1 -b $b -D -u $NETUUID & HDR="-P 0";
+ j=`expr $j + 1`;
+ done;
+ wait;
diff --git a/benchmarks/netperf/files/patch-runemomniaggdemo.sh b/benchmarks/netperf/files/patch-runemomniaggdemo.sh
new file mode 100644
index 000000000000..0c5ab9e01da8
--- /dev/null
+++ b/benchmarks/netperf/files/patch-runemomniaggdemo.sh
@@ -0,0 +1,11 @@
+--- doc/examples/runemomniaggdemo.sh.orig 2013-05-10 20:14:25.000000000 +0200
++++ doc/examples/runemomniaggdemo.sh 2015-10-19 15:37:46.597952000 +0200
+@@ -138,7 +138,7 @@
+ fi
+
+ # allow the netperf binary to be used to be overridden
+-NETPERF=${NETPERF:="netperf"}
++NETPERF="%%PREFIX%%/bin/netperf"
+
+ if [ $NUM_REMOTE_HOSTS -lt 2 ]
+ then
diff --git a/benchmarks/netperf/pkg-plist b/benchmarks/netperf/pkg-plist
index a40827188de2..fd66708063ee 100644
--- a/benchmarks/netperf/pkg-plist
+++ b/benchmarks/netperf/pkg-plist
@@ -2,12 +2,16 @@ bin/netperf
bin/netserver
man/man1/netperf.1.gz
man/man1/netserver.1.gz
-%%EXAMPLESDIR%%/arr_script
-%%EXAMPLESDIR%%/packet_byte_script
-%%EXAMPLESDIR%%/sctp_stream_script
-%%EXAMPLESDIR%%/snapshot_script
-%%EXAMPLESDIR%%/tcp_range_script
-%%EXAMPLESDIR%%/tcp_rr_script
-%%EXAMPLESDIR%%/tcp_stream_script
-%%EXAMPLESDIR%%/udp_rr_script
-%%EXAMPLESDIR%%/udp_stream_script
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arr_script
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bloat.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/packet_byte_script
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/runemomni.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/runemomniagg2.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/runemomniaggdemo.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sctp_stream_script
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/snapshot_script
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcp_range_script
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcp_rr_script
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tcp_stream_script
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/udp_rr_script
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/udp_stream_script