aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/netperf
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-01-02 22:47:32 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-01-02 22:47:32 +0000
commit803a57e552020a11216032f69a8cee8ab9a692d1 (patch)
treea0d43766c28f3509741f7da1b40c3b5a4c542972 /benchmarks/netperf
parent823f6912e5825c837f879420ddcf77725dba6974 (diff)
downloadports-803a57e552020a11216032f69a8cee8ab9a692d1.tar.gz
ports-803a57e552020a11216032f69a8cee8ab9a692d1.zip
- Fix build with clang [1]
- Use standard header - Convert spaces to tabs in options and descriptions - Spelling fixes in pkg-descr PR: ports/174887 [1] Reported by: Garrett Cooper <yanegomi@gmail.com> [1]
Notes
Notes: svn path=/head/; revision=309847
Diffstat (limited to 'benchmarks/netperf')
-rw-r--r--benchmarks/netperf/Makefile17
-rw-r--r--benchmarks/netperf/pkg-descr4
2 files changed, 11 insertions, 10 deletions
diff --git a/benchmarks/netperf/Makefile b/benchmarks/netperf/Makefile
index 121276b99c40..abdb09c10186 100644
--- a/benchmarks/netperf/Makefile
+++ b/benchmarks/netperf/Makefile
@@ -1,4 +1,4 @@
-# Created by: koshy
+# Created by: koshy
# $FreeBSD$
PORTNAME= netperf
@@ -10,17 +10,18 @@ MASTER_SITES= ftp://ftp.netperf.org/netperf/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Network performance benchmarking package
-OPTIONS_DEFINE= OMNI SCTP SOCKETS HISTOGRAM EXS
-OPTIONS_DEFAULT= SCTP SOCKETS HISTOGRAM EXS
+OPTIONS_DEFINE= OMNI SCTP SOCKETS HISTOGRAM EXS
+OPTIONS_DEFAULT= SCTP SOCKETS HISTOGRAM EXS
-OMNI_DESC= Enable OMNI tests
-SCTP_DESC= Enable SCTP support
-SOCKETS_DESC= Enable Unix Domain socket support
-HISTOGRAM_DESC= Enable optional histogram output
-EXS_DESC= Enable ICSC async socket support
+OMNI_DESC= Enable OMNI tests
+SCTP_DESC= Enable SCTP support
+SOCKETS_DESC= Enable Unix Domain socket support
+HISTOGRAM_DESC= Enable optional histogram output
+EXS_DESC= Enable ICSC async socket support
.include <bsd.port.options.mk>
+USE_CSTD= gnu89
GNU_CONFIGURE= yes
CONFIGURE_ENV= "transform="
CONFIGURE_ARGS= --program-prefix="" --program-suffix="" --enable-dirty \
diff --git a/benchmarks/netperf/pkg-descr b/benchmarks/netperf/pkg-descr
index 8665ef754d5c..d23c3e363755 100644
--- a/benchmarks/netperf/pkg-descr
+++ b/benchmarks/netperf/pkg-descr
@@ -8,8 +8,8 @@ Some of these are:
* specification of desired confidence levels for the tests
Netperf will warn the user if these levels were not achieved.
* filling send buffers with specified data (to beat compression schemes)
- * specification of send/recieve buffer alignments and data offsets
- * requesting cpu utilization and service demand calculations
+ * specification of send/receive buffer alignments and data offsets
+ * requesting CPU utilization and service demand calculations
* specification of sizes of data to send
Netperf can be used for measuring stream performance as well as
round-trip performance.