aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/pear-Benchmark/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-10-18 15:11:32 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-10-18 15:11:32 +0000
commitfa2b68c8c25ed17c112e5a888336dd385e6cee77 (patch)
tree94d2f78260aac039212868887429bff29e517409 /benchmarks/pear-Benchmark/Makefile
parent75c6d17033d56f22c6540c95d547fbee48409601 (diff)
downloadports-fa2b68c8c25ed17c112e5a888336dd385e6cee77.tar.gz
ports-fa2b68c8c25ed17c112e5a888336dd385e6cee77.zip
Notes
Diffstat (limited to 'benchmarks/pear-Benchmark/Makefile')
-rw-r--r--benchmarks/pear-Benchmark/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/benchmarks/pear-Benchmark/Makefile b/benchmarks/pear-Benchmark/Makefile
new file mode 100644
index 000000000000..2ddc1bc59721
--- /dev/null
+++ b/benchmarks/pear-Benchmark/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-Benchmark
+# Date created: 09 September 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Benchmark
+PORTVERSION= 1.2.1
+CATEGORIES= benchmarks devel www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= Framework to benchmark PHP scripts or function calls
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Benchmark
+FILES= Timer.php Iterate.php Profiler.php
+DOCS= timer_example.php
+
+_DOCSDIR= doc
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>