aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/perftest
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2018-06-08 14:51:46 +0000
committerPhilip Paeps <philip@FreeBSD.org>2018-06-08 14:51:46 +0000
commit8dd3f1bd33378d16fec51703eaffa0b28c7531ad (patch)
treee32c82ad846f9fa2673f7145a1f314beb74edbd0 /benchmarks/perftest
parent272cba7bd4d785760f3a9e455c3b5c00a0ccc8a5 (diff)
Notes
Diffstat (limited to 'benchmarks/perftest')
-rw-r--r--benchmarks/perftest/Makefile26
-rw-r--r--benchmarks/perftest/distinfo3
-rw-r--r--benchmarks/perftest/pkg-descr14
-rw-r--r--benchmarks/perftest/pkg-plist14
4 files changed, 57 insertions, 0 deletions
diff --git a/benchmarks/perftest/Makefile b/benchmarks/perftest/Makefile
new file mode 100644
index 000000000000..e753674e2b6a
--- /dev/null
+++ b/benchmarks/perftest/Makefile
@@ -0,0 +1,26 @@
+# Created by: Slava Shwartsman <slavash@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= perftest
+DISTVERSION= 4.2-0.7
+CATEGORIES= benchmarks
+
+MAINTAINER= slavash@FreeBSD.org
+COMMENT= Collection of tests for RDMA micro-benchmark
+
+LICENSE= LGPL21 BSD2CLAUSE
+LICENSE_COMB= dual
+
+.if !exists(/usr/lib/libibverbs.so)
+IGNORE= missing OFED user space
+.endif
+
+USES= autoreconf libtool
+
+USE_GITHUB= yes
+GH_ACCOUNT= linux-rdma
+GH_TAGNAME= V4.2-0.7
+
+GNU_CONFIGURE=yes
+
+.include <bsd.port.mk>
diff --git a/benchmarks/perftest/distinfo b/benchmarks/perftest/distinfo
new file mode 100644
index 000000000000..46704df6a84c
--- /dev/null
+++ b/benchmarks/perftest/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1526476189
+SHA256 (linux-rdma-perftest-4.2-0.7-V4.2-0.7_GH0.tar.gz) = c376e7232508fad50f34845a364a23400bd542140388702ba28748cc4496bce5
+SIZE (linux-rdma-perftest-4.2-0.7-V4.2-0.7_GH0.tar.gz) = 139384
diff --git a/benchmarks/perftest/pkg-descr b/benchmarks/perftest/pkg-descr
new file mode 100644
index 000000000000..78c15be83d03
--- /dev/null
+++ b/benchmarks/perftest/pkg-descr
@@ -0,0 +1,14 @@
+This is a collection of tests written over uverbs intended for use as a
+performance micro-benchmark. The tests may be used for HW or SW tuning
+as well as for functional testing.
+
+The collection contains a set of bandwidth and latency benchmark such as:
+
+ * Send - ib_send_bw and ib_send_lat
+ * RDMA Read - ib_read_bw and ib_read_lat
+ * RDMA Write - ib_write_bw and ib_wriet_lat
+ * RDMA Atomic - ib_atomic_bw and ib_atomic_lat
+ * Native Ethernet (when working with MOFED2) -
+ raw_ethernet_bw, raw_ethernet_lat
+
+WWW: https://github.com/linux-rdma/perftest/
diff --git a/benchmarks/perftest/pkg-plist b/benchmarks/perftest/pkg-plist
new file mode 100644
index 000000000000..2c50d82c3e6b
--- /dev/null
+++ b/benchmarks/perftest/pkg-plist
@@ -0,0 +1,14 @@
+bin/ib_send_bw
+bin/ib_send_lat
+bin/ib_write_lat
+bin/ib_write_bw
+bin/ib_read_lat
+bin/ib_read_bw
+bin/ib_atomic_lat
+bin/ib_atomic_bw
+bin/raw_ethernet_bw
+bin/raw_ethernet_lat
+bin/raw_ethernet_burst_lat
+bin/raw_ethernet_fs_rate
+bin/run_perftest_loopback
+bin/run_perftest_multi_devices