aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/phoronix-test-suite
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-04-21 16:23:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-04-21 16:23:17 +0000
commitb8368cf7ed0d644f8b7afbfa2317ca634ee8967e (patch)
tree0a5a0f1163fc5b8411637cd86a5d1c54f84ae261 /benchmarks/phoronix-test-suite
parente28e7a8885b61fae58a3788f21b5f6db75255612 (diff)
downloadports-b8368cf7ed0d644f8b7afbfa2317ca634ee8967e.tar.gz
ports-b8368cf7ed0d644f8b7afbfa2317ca634ee8967e.zip
- Fix shebangs
Notes
Notes: svn path=/head/; revision=439091
Diffstat (limited to 'benchmarks/phoronix-test-suite')
-rw-r--r--benchmarks/phoronix-test-suite/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/benchmarks/phoronix-test-suite/Makefile b/benchmarks/phoronix-test-suite/Makefile
index 042fd8f44276..14375afc2902 100644
--- a/benchmarks/phoronix-test-suite/Makefile
+++ b/benchmarks/phoronix-test-suite/Makefile
@@ -3,7 +3,7 @@
PORTNAME= phoronix-test-suite
PORTVERSION= 6.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= benchmarks
MASTER_SITES= http://www.phoronix-test-suite.com/releases/
@@ -13,12 +13,23 @@ COMMENT= Phoronix Benchmarking Suite
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= php:cli,build
+USES= php:cli,build python shebangfix
USE_GCC= any
-USE_PHP= ctype curl dom filter gd hash json openssl pcntl posix session \
- simplexml sockets sqlite3 zip zlib
+USE_PHP= ctype curl dom filter gd hash json openssl pcntl posix \
+ session simplexml sockets sqlite3 zip zlib
NO_BUILD= yes
WRKSRC= ${WRKDIR}/phoronix-test-suite
+SHEBANG_FILES= deploy/juju/trusty/pts/hooks/start \
+ deploy/juju/trusty/pts/hooks/upgrade-charm \
+ deploy/juju/trusty/pts/hooks/stop \
+ deploy/juju/trusty/pts/hooks/phoronix-common \
+ deploy/juju/trusty/pts/hooks/install \
+ deploy/juju/trusty/pts/hooks/config-changed \
+ deploy/juju/trusty/pts/actions/memory \
+ deploy/juju/trusty/pts/actions/benchmark \
+ deploy/juju/trusty/pts/actions/custom \
+ deploy/juju/trusty/pts/actions/smoke \
+ deploy/juju/trusty/pts/scripts/parse
RUN_DEPENDS+= fpdf>0:print/fpdf
RUN_DEPENDS+= cmake:devel/cmake