aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/polygraph
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-01-06 13:29:29 +0000
committerWen Heping <wen@FreeBSD.org>2018-01-06 13:29:29 +0000
commitf8e5a5fff8c39d1ef4dee091a3e00c636a15ce68 (patch)
tree0a0ef7f7fee4154e65a121d8005d0658099076ee /benchmarks/polygraph
parent3f32d6015e8795b68c6179c8465da445cd89feda (diff)
downloadports-f8e5a5fff8c39d1ef4dee091a3e00c636a15ce68.tar.gz
ports-f8e5a5fff8c39d1ef4dee091a3e00c636a15ce68.zip
Notes
Diffstat (limited to 'benchmarks/polygraph')
-rw-r--r--benchmarks/polygraph/Makefile3
-rw-r--r--benchmarks/polygraph/distinfo5
-rw-r--r--benchmarks/polygraph/files/patch-src_xstd_Ring.h18
3 files changed, 4 insertions, 22 deletions
diff --git a/benchmarks/polygraph/Makefile b/benchmarks/polygraph/Makefile
index f37f8f0f0aeb..4619c14f4dda 100644
--- a/benchmarks/polygraph/Makefile
+++ b/benchmarks/polygraph/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= polygraph
-PORTVERSION= 4.9.0
-PORTREVISION= 4
+PORTVERSION= 4.11.0
DISTVERSIONSUFFIX= -src
CATEGORIES= benchmarks www
MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/
diff --git a/benchmarks/polygraph/distinfo b/benchmarks/polygraph/distinfo
index 1479654cb984..b4f99a79abc4 100644
--- a/benchmarks/polygraph/distinfo
+++ b/benchmarks/polygraph/distinfo
@@ -1,2 +1,3 @@
-SHA256 (polygraph-4.9.0-src.tgz) = 36af0031e15b0a123fecda2d74c36cbe632cd479bdb2c85c1b020d4e57ff6bf4
-SIZE (polygraph-4.9.0-src.tgz) = 3371570
+TIMESTAMP = 1515222711
+SHA256 (polygraph-4.11.0-src.tgz) = 7add54d7ef560cc5151bacee3bd17769f079e70a4da740375738a13ba80726c6
+SIZE (polygraph-4.11.0-src.tgz) = 3413931
diff --git a/benchmarks/polygraph/files/patch-src_xstd_Ring.h b/benchmarks/polygraph/files/patch-src_xstd_Ring.h
deleted file mode 100644
index 4082eced6195..000000000000
--- a/benchmarks/polygraph/files/patch-src_xstd_Ring.h
+++ /dev/null
@@ -1,18 +0,0 @@
-commit a1b938b85e2b9aabb95fb09b9f7137b27135ea72
-Author: Alex Rousskov <rousskov@measurement-factory.com>
-Date: Thu Jan 7 08:20:34 2016 -0700
-
- lp:1380660: Make failed if gcc 4.9 is used.
-
- Merged POLY-43-lp1380660-make-failed-if-gcc-49-.
-
---- src/xstd/Ring.h.orig 2014-10-22 23:22:22 UTC
-+++ src/xstd/Ring.h
-@@ -19,6 +19,7 @@ class Ring: protected Array<Item> {
-
- using Array<Item>::capacity;
- using Array<Item>::size;
-+ using Array<Item>::Value;
-
- int count() const { return theInOff - theOutOff; }
- bool empty() const { return theInOff <= theOutOff; }